aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2013-05-08 16:37:43 +0000
committerFrederic Culot <culot@FreeBSD.org>2013-05-08 16:37:43 +0000
commita67d26649eab09fd96ff709785ffb7be607f4f82 (patch)
tree459c711b66a1aab63a5c52d6314b8c7d851fce8a /textproc
parent947a52d830dffe19e25be2dc994ca01012f32143 (diff)
downloadports-a67d26649eab09fd96ff709785ffb7be607f4f82.tar.gz
ports-a67d26649eab09fd96ff709785ffb7be607f4f82.zip
Text::TestBase is a parser for the Test::Base format.
Notes
Notes: svn path=/head/; revision=317700
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-TestBase/Makefile35
-rw-r--r--textproc/p5-Text-TestBase/distinfo2
-rw-r--r--textproc/p5-Text-TestBase/pkg-descr3
-rw-r--r--textproc/p5-Text-TestBase/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fbb008e8094c..7e9b86547c4d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -862,6 +862,7 @@
SUBDIR += p5-Text-TabularDisplay
SUBDIR += p5-Text-Tags
SUBDIR += p5-Text-Template
+ SUBDIR += p5-Text-TestBase
SUBDIR += p5-Text-Textile
SUBDIR += p5-Text-Tmpl
SUBDIR += p5-Text-Trac
diff --git a/textproc/p5-Text-TestBase/Makefile b/textproc/p5-Text-TestBase/Makefile
new file mode 100644
index 000000000000..4daf021487cd
--- /dev/null
+++ b/textproc/p5-Text-TestBase/Makefile
@@ -0,0 +1,35 @@
+# Created by: Frederic Culot <culot@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Text-TestBase
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Parser for Test::Base format
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_MODBUILD= yes
+
+MAN3= Data::Section::TestBase.3 \
+ Test::Base::Less.3 \
+ Text::TestBase.3 \
+ Text::TestBase::Block.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-TestBase/distinfo b/textproc/p5-Text-TestBase/distinfo
new file mode 100644
index 000000000000..22818806030c
--- /dev/null
+++ b/textproc/p5-Text-TestBase/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Text-TestBase-0.10.tar.gz) = 9c39207d363267886d516eee2825b1f1eda389b8f11e2a170ab8a7583c614f79
+SIZE (Text-TestBase-0.10.tar.gz) = 14810
diff --git a/textproc/p5-Text-TestBase/pkg-descr b/textproc/p5-Text-TestBase/pkg-descr
new file mode 100644
index 000000000000..b0420829ee00
--- /dev/null
+++ b/textproc/p5-Text-TestBase/pkg-descr
@@ -0,0 +1,3 @@
+Text::TestBase is a parser for the Test::Base format.
+
+WWW: http://search.cpan.org/dist/Text-TestBase/
diff --git a/textproc/p5-Text-TestBase/pkg-plist b/textproc/p5-Text-TestBase/pkg-plist
new file mode 100644
index 000000000000..bfec5233f035
--- /dev/null
+++ b/textproc/p5-Text-TestBase/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Data/Section/TestBase.pm
+%%SITE_PERL%%/Test/Base/Less.pm
+%%SITE_PERL%%/Text/TestBase.pm
+%%SITE_PERL%%/Text/TestBase/Block.pm
+@dirrmtry %%SITE_PERL%%/Data/Section
+@dirrmtry %%SITE_PERL%%/Data
+@dirrmtry %%SITE_PERL%%/Test/Base
+@dirrmtry %%SITE_PERL%%/Test
+@dirrm %%SITE_PERL%%/Text/TestBase
+@dirrmtry %%SITE_PERL%%/Text