aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-09-20 12:15:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-09-20 12:15:57 +0000
commitdbf9cc73e25a7d1827be42a9fe07bd519eb41cd6 (patch)
tree4deb538cf1c818b266b0ddc0ac64b6d6b5a69fb8 /textproc
parent6a1bfebdef7dd9271e4ddfcdbfc03ce225664f86 (diff)
downloadports-dbf9cc73e25a7d1827be42a9fe07bd519eb41cd6.tar.gz
ports-dbf9cc73e25a7d1827be42a9fe07bd519eb41cd6.zip
Make sure we use system hunspell and look in the right location where to
find the dictionaries. [1] Do the same for hspell and ispell, and use new lib_depend syntax. USE_GMAKE => USES=gmake and fix bug in configure script. PR: ports/180660 Submitted by: tijl@
Notes
Notes: svn path=/head/; revision=327695
Diffstat (limited to 'textproc')
-rw-r--r--textproc/enchant/Makefile18
-rw-r--r--textproc/enchant/files/patch-configure11
2 files changed, 21 insertions, 8 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index f987f58f8319..92e5a52af6e9 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -12,10 +12,9 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Dictionary/spellchecking framework
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
USE_GNOME= glib20 ltverhack
CONFIGURE_ARGS= --disable-uspell \
--disable-voikko
@@ -34,7 +33,7 @@ ZEMBEREK_DESC= Spell checking via Zemberek
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= pspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--enable-aspell \
--with-aspell-prefix=${LOCALBASE}
PLIST_SUB+= ASPELL=""
@@ -45,7 +44,8 @@ PLIST_SUB+= ASPELL="@comment "
.if ${PORT_OPTIONS:MHSPELL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libhspell.a:${PORTSDIR}/hebrew/hspell
-CONFIGURE_ARGS+=--enable-hspell
+CONFIGURE_ARGS+=--enable-hspell \
+ --with-hspell-prefix=${LOCALBASE}
PLIST_SUB+= HSPELL=""
.else
CONFIGURE_ARGS+=--disable-hspell
@@ -53,8 +53,9 @@ PLIST_SUB+= HSPELL="@comment "
.endif
.if ${PORT_OPTIONS:MHUNSPELL}
-LIB_DEPENDS+= hunspell-1.3:${PORTSDIR}/textproc/hunspell
-CONFIGURE_ARGS+=--enable-myspell
+LIB_DEPENDS+= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
+CONFIGURE_ARGS+=--enable-myspell --with-system-myspell=yes \
+ --with-myspell-dir=${LOCALBASE}
PLIST_SUB+= HUNSPELL=""
.else
CONFIGURE_ARGS+=--disable-myspell
@@ -63,7 +64,8 @@ PLIST_SUB+= HUNSPELL="@comment "
.if ${PORT_OPTIONS:MISPELL}
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
-CONFIGURE_ARGS+=--enable-ispell
+CONFIGURE_ARGS+=--enable-ispell \
+ --with-ispell-dir=${LOCALBASE}
PLIST_SUB+= ISPELL=""
.else
CONFIGURE_ARGS+=--disable-ispell
@@ -71,7 +73,7 @@ PLIST_SUB+= ISPELL="@comment "
.endif
.if ${PORT_OPTIONS:MZEMBEREK}
-LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-zemberek
PLIST_SUB+= ZEMBEREK=""
.else
diff --git a/textproc/enchant/files/patch-configure b/textproc/enchant/files/patch-configure
new file mode 100644
index 000000000000..9c5605d3cdc8
--- /dev/null
+++ b/textproc/enchant/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-08-16 18:30:56.000000000 +0200
++++ configure 2013-08-16 18:31:33.000000000 +0200
+@@ -18213,7 +18213,7 @@
+ fi
+
+
+- ASPELL_CFLAGS+=" -DHAVE_PSPELL_H"
++ ASPELL_CFLAGS="${ASPELL_CFLAGS} -DHAVE_PSPELL_H"
+ elif test -f "$aspell_prefix/include/aspell.h"; then
+ { $as_echo "$as_me:$LINENO: result: yes (aspell)" >&5
+ $as_echo "yes (aspell)" >&6; }