aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@utahime.org>2021-06-30 06:43:09 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-06-30 06:43:09 +0000
commite2fdcc22cbeac646c4bbeb4d93a90f338dbda505 (patch)
tree9ba3b47f6cccea7e728d3f64e19a4f513ec70a2e /textproc
parentcfcf76eaba10400a021f3df3ee94474bc7a5d5c0 (diff)
downloadports-e2fdcc22cbeac646c4bbeb4d93a90f338dbda505.tar.gz
ports-e2fdcc22cbeac646c4bbeb4d93a90f338dbda505.zip
textproc/yaml.el: New port: YAML parser in Elisp
PR: 256879 Approved by: lwhsu (mentor)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/yaml.el/Makefile30
-rw-r--r--textproc/yaml.el/distinfo3
-rw-r--r--textproc/yaml.el/pkg-descr5
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index abdc8f03ce23..3ae514220d37 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1951,6 +1951,7 @@
SUBDIR += yali
SUBDIR += yamcha
SUBDIR += yaml-mode.el
+ SUBDIR += yaml.el
SUBDIR += ydiff
SUBDIR += yelp-tools
SUBDIR += yelp-xsl
diff --git a/textproc/yaml.el/Makefile b/textproc/yaml.el/Makefile
new file mode 100644
index 000000000000..cefaa1d98052
--- /dev/null
+++ b/textproc/yaml.el/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= yaml.el
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.3
+CATEGORIES= textproc elisp
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
+
+MAINTAINER= yasu@utahime.org
+COMMENT= YAML parser in Elisp
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= emacs
+USE_GITHUB= yes
+GH_ACCOUNT= zkry
+
+NO_ARCH= yes
+PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/yaml.el \
+ ${EMACS_VERSION_SITE_LISPDIR}/yaml.elc
+
+do-build:
+ (cd ${WRKSRC} \
+ && ${EMACS_CMD} -Q -batch -L . -f batch-byte-compile yaml.el)
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} yaml.el* \
+ ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR})
+
+.include <bsd.port.mk>
diff --git a/textproc/yaml.el/distinfo b/textproc/yaml.el/distinfo
new file mode 100644
index 000000000000..6ae8ce384e0d
--- /dev/null
+++ b/textproc/yaml.el/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624917207
+SHA256 (zkry-yaml.el-v0.3.3_GH0.tar.gz) = 82399187c1d982d6de02e94b49f907ada50bb7afadb008ec931e464d8474c5cb
+SIZE (zkry-yaml.el-v0.3.3_GH0.tar.gz) = 43264
diff --git a/textproc/yaml.el/pkg-descr b/textproc/yaml.el/pkg-descr
new file mode 100644
index 000000000000..e728004ae9a9
--- /dev/null
+++ b/textproc/yaml.el/pkg-descr
@@ -0,0 +1,5 @@
+yaml.el is a YAML parser written in Emacs List without any external
+dependencies. It provides an interface similar to the Emacs JSON
+parsing utility.
+
+WWW: https://github.com/zkry/yaml.el