aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-25 15:06:59 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-25 15:06:59 +0000
commitf8438495a8075f5d4c12be1681c7cac469ea6472 (patch)
tree600b55e1af4b02749f13ead5abe1f4fd4a98e0e1 /textproc
parent4aca91442b9e8d6992d584a68d757ab6c77e8ac8 (diff)
downloadports-f8438495a8075f5d4c12be1681c7cac469ea6472.tar.gz
ports-f8438495a8075f5d4c12be1681c7cac469ea6472.zip
- Fix warnings in urlview.c [1]
- Add LICENSE - Add stage support PR: ports/180681 Submitted by: Anton Shterenlikht <mexas@bris.ac.uk> (maintainer) [1]
Notes
Notes: svn path=/head/; revision=334855
Diffstat (limited to 'textproc')
-rw-r--r--textproc/urlview/Makefile14
-rw-r--r--textproc/urlview/files/patch-urlview.c15
2 files changed, 21 insertions, 8 deletions
diff --git a/textproc/urlview/Makefile b/textproc/urlview/Makefile
index 9cdf324565fa..e5443a4735e9 100644
--- a/textproc/urlview/Makefile
+++ b/textproc/urlview/Makefile
@@ -15,19 +15,23 @@ MASTER_SITES= ftp://ftp.mutt.org/mutt/contrib/ \
MAINTAINER= mexas@bris.ac.uk
COMMENT= URL extractor/launcher
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
-MAN1= urlview.1
PLIST_FILES= bin/urlview \
- etc/urlview.conf.sample
+ etc/urlview.conf.sample \
+ man/man1/urlview.1.gz
+MAKE_ENV= DESTDIR=${STAGEDIR}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
-e 's/url_handler.sh/firefox/' \
${WRKSRC}/*
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/urlview ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/urlview.man ${STAGEDIR}${MAN1PREFIX}/man/man1/urlview.1
${INSTALL_DATA} ${WRKSRC}/sample.urlview \
- ${PREFIX}/etc/urlview.conf.sample
+ ${STAGEDIR}${PREFIX}/etc/urlview.conf.sample
.include <bsd.port.mk>
diff --git a/textproc/urlview/files/patch-urlview.c b/textproc/urlview/files/patch-urlview.c
index 84fd37140483..63d8f3f184f0 100644
--- a/textproc/urlview/files/patch-urlview.c
+++ b/textproc/urlview/files/patch-urlview.c
@@ -1,5 +1,5 @@
---- urlview.c.orig Wed Nov 9 15:34:39 2005
-+++ urlview.c Wed Nov 9 15:35:06 2005
+--- urlview.c.orig 2013-07-19 22:44:59.000000000 +0100
++++ urlview.c 2013-07-19 22:45:22.000000000 +0100
@@ -46,6 +46,8 @@
#include <rx/rxposix.h>
#endif
@@ -7,5 +7,14 @@
+#include "quote.h"
+
#define DEFAULT_REGEXP "(((https?|ftp|gopher)://|(mailto|file|news):)[^' \t<>\"]+|(www|web|w3)\\.[-a-z0-9.]+)[^' \t.,;<>\"\\):]"
- #define DEFAULT_COMMAND "url_handler.sh %s"
+ #define DEFAULT_COMMAND "firefox %s"
#define SYSTEM_INITFILE "/usr/local/etc/urlview.conf"
+@@ -61,7 +63,7 @@
+ MOTION
+ };
+
+-extern int mutt_enter_string (unsigned char *buf, size_t buflen, int y, int x,
++extern int mutt_enter_string (char *buf, size_t buflen, int y, int x,
+ int flags);
+
+ void search_forward (char *search, int urlcount, char **url, int *redraw, int *current, int *top)