aboutsummaryrefslogtreecommitdiff
path: root/www/analog
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-07-31 10:49:23 +0000
committerRene Ladan <rene@FreeBSD.org>2011-07-31 10:49:23 +0000
commitdece55fbd7a0f6e16953bc444cad8e637b0c7158 (patch)
tree22884e6096a2f0d6bfee595946190f6f98174bb8 /www/analog
parente9d55541f5786c26fe97e930fb49767cb443b231 (diff)
downloadports-dece55fbd7a0f6e16953bc444cad8e637b0c7158.tar.gz
ports-dece55fbd7a0f6e16953bc444cad8e637b0c7158.zip
- Recognize the Chrome and Baiduspider user agents [1]
- Bump PORTREVISION PR: ports/156984 [1] Submitted by: Kurt Lidl [kurt.lidl cello.com]
Notes
Notes: svn path=/head/; revision=278622
Diffstat (limited to 'www/analog')
-rw-r--r--www/analog/Makefile2
-rw-r--r--www/analog/files/patch-ab20
2 files changed, 18 insertions, 4 deletions
diff --git a/www/analog/Makefile b/www/analog/Makefile
index 9d079b1630ac..0bae6af84a9d 100644
--- a/www/analog/Makefile
+++ b/www/analog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= analog
PORTVERSION= 6.0
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://www.analog.cx/ \
diff --git a/www/analog/files/patch-ab b/www/analog/files/patch-ab
index 3fc9222c85d4..7f4a5505e436 100644
--- a/www/analog/files/patch-ab
+++ b/www/analog/files/patch-ab
@@ -1,6 +1,20 @@
---- src/tree.c.orig Sun Mar 23 13:57:02 2003
-+++ src/tree.c Sun May 11 10:25:45 2003
-@@ -895,8 +895,16 @@
+--- src/tree.c.orig 2004-12-19 08:51:31.000000000 -0500
++++ src/tree.c 2011-05-12 16:38:50.388298051 -0400
+@@ -769,11 +769,13 @@
+ if (((*name = strstr(whole, "Mosaic")) != NULL && (len = 6)) ||
+ ((*name = strstr(whole, "mosaic")) != NULL && (len = 6)) ||
+ ((*name = strstr(whole, "Konqueror")) != NULL && (len = 9)) ||
++ ((*name = strstr(whole, "Baiduspider")) != NULL && (len = 11)) ||
+ ((*name = strstr(whole, "Galeon")) != NULL && (len = 6)) ||
+ ((*name = strstr(whole, "Phoenix")) != NULL && (len = 7)) ||
+ ((*name = strstr(whole, "Firebird")) != NULL && (len = 8)) ||
+ ((*name = strstr(whole, "Firefox")) != NULL && (len = 7)) ||
+ ((*name = strstr(whole, "Chimera")) != NULL && (len = 7)) ||
++ ((*name = strstr(whole, "Chrome")) != NULL && (len = 6)) ||
+ ((*name = strstr(whole, "Camino")) != NULL && (len = 6)) ||
+ ((*name = strstr(whole, "Safari")) != NULL && (len = 6)) ||
+ ((*name = strstr(whole, "WebTV")) != NULL && (len = 5)) ||
+@@ -904,8 +906,16 @@
*name = "Macintosh";
else if (strstr(whole, "Linux") != NULL || strstr(whole, "linux") != NULL)
*name = "Unix:Linux";