aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-modperl
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2006-01-07 06:29:57 +0000
committerDoug Barton <dougb@FreeBSD.org>2006-01-07 06:29:57 +0000
commitffde46cbf97ed90584d8c10bdc6bae8094784387 (patch)
treeb78a36a23c5db32b200d7f48cb719e48b524fa47 /www/apache13-modperl
parent0e2c03666de0675409d0d8eedd95734db4465b70 (diff)
downloadports-ffde46cbf97ed90584d8c10bdc6bae8094784387.tar.gz
ports-ffde46cbf97ed90584d8c10bdc6bae8094784387.zip
Now that new style rc.d scripts are being run as part of the
base rcorder, hard coded variable values in these scripts are overriding the values in /etc/rc.conf[.local] (due to the way that variables from the latter are read at boot time). Therefore, change the boot scripts to set default values only if the variable is unset in /etc/rc.conf[.local]. This will allow the service to start at boot time if it's been enabled as the user would expect. This change will be a noop for users who have systems that have not yet been upgraded to the new rc.d code in the base. In many cases there are other variables in the scripts that should get similar treatment, however I did not change anything other than the _enable lines. I'll leave the rest up to the maintainers to do as they see fit. Bump PORTREVISION to make sure that users and packages pick up this change.
Notes
Notes: svn path=/head/; revision=152963
Diffstat (limited to 'www/apache13-modperl')
-rw-r--r--www/apache13-modperl/Makefile2
-rw-r--r--www/apache13-modperl/files/apache.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/www/apache13-modperl/Makefile b/www/apache13-modperl/Makefile
index ff6441de2db5..dffcd9d353b3 100644
--- a/www/apache13-modperl/Makefile
+++ b/www/apache13-modperl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache+mod_perl
PORTVERSION= ${VERSION_APACHE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD:S/$/:apache/} \
${MASTER_SITE_PERL_CPAN:S/$/Apache\/:modperl/}
diff --git a/www/apache13-modperl/files/apache.sh b/www/apache13-modperl/files/apache.sh
index bc1f82cc4373..2491e0514d97 100644
--- a/www/apache13-modperl/files/apache.sh
+++ b/www/apache13-modperl/files/apache.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/www/apache13-modperl/files/Attic/apache.sh,v 1.1 2004-06-05 14:25:18 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/apache13-modperl/files/Attic/apache.sh,v 1.2 2006-01-07 06:29:56 dougb Exp $
# PROVIDE: apache
# REQUIRE: DAEMON
@@ -13,7 +13,7 @@
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
-apache_enable="NO"
+apache_enable="${apache_enable-NO}"
apache_flags=""
apache_pidfile="/var/run/httpd.pid"