aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-modssl
diff options
context:
space:
mode:
authorRalf S. Engelschall <rse@FreeBSD.org>1999-04-12 06:53:00 +0000
committerRalf S. Engelschall <rse@FreeBSD.org>1999-04-12 06:53:00 +0000
commitdb444b6649f2f63b95a7dff34b75ac3b6139d274 (patch)
tree3b91bec598f67f98e819ac2ca069b1b30a8e4723 /www/apache13-modssl
parentae325076a3d86702ad2b5e7bdbbc26adc24f2518 (diff)
downloadports-db444b6649f2f63b95a7dff34b75ac3b6139d274.tar.gz
ports-db444b6649f2f63b95a7dff34b75ac3b6139d274.zip
Cleanup Perl dependencies.
Thanks to Dirk Froemberg <dirk@freebsd.org> for hint.
Notes
Notes: svn path=/head/; revision=17802
Diffstat (limited to 'www/apache13-modssl')
-rw-r--r--www/apache13-modssl/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 6174ce990fda..c512e33477f5 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -3,7 +3,7 @@
# Date created: Sat Aug 22 12:00:00 CDT 1998
# Whom: rse@engelschall.com
#
-# $Id: Makefile,v 1.27 1999/03/26 08:47:51 dirk Exp $
+# $Id: Makefile,v 1.28 1999/03/29 11:05:37 rse Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -52,11 +52,12 @@ VERSION_MODSSL= 2.2.7
Y2K= http://www.engelschall.com/sw/mod_ssl/docs/2.2/ssl_faq.html#y2k
RESTRICTED= "Contains cryptography"
+USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--target=apache \
--with-layout=GNU \
- --with-perl=${PERL5} \
+ --with-perl=${PERL} \
--bindir=${PREFIX}/bin \
--sbindir=${PREFIX}/sbin \
--libexecdir=${PREFIX}/libexec/apache \
@@ -78,9 +79,11 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"${PREFIX}/bin:/bin:/usr/bin\\"
+
.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
-CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer -fexpensive-optimizations -ffast-math
+CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
+ -fexpensive-optimizations -ffast-math
.endif
CONFIGURE_ENV= CFLAGS='${CFLAGS}' \