aboutsummaryrefslogtreecommitdiff
path: root/www/apache22
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-07 21:46:21 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-07 21:46:21 +0000
commit3f811ff3087e01031787baf535840a74190f798d (patch)
tree7bca1242e41af3e3bfa1986639c9b75f5bc96a15 /www/apache22
parent49f14fc8430b3398a64f7a9af5b5da08cf7de71f (diff)
downloadports-3f811ff3087e01031787baf535840a74190f798d.tar.gz
ports-3f811ff3087e01031787baf535840a74190f798d.zip
- Continuation of ports/133704
apxs -A comments out the LoadModule line This adds custom FreeBSD mod to 'DELETE' the line so that it works with our pkg-plists in packages. - Remove -s form the cmp httpd.conf in pkg-plist to be blatant about why it didn't get removed - Tested with lang/php5 - Bump PORTREVISION PR: ports/133704 With Hat: apache@
Notes
Notes: svn path=/head/; revision=253918
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/files/patch-support__apxs.in12
-rw-r--r--www/apache22/pkg-plist2
3 files changed, 11 insertions, 5 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 28a43460c4fd..1de60b21666a 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache22/files/patch-support__apxs.in b/www/apache22/files/patch-support__apxs.in
index e98a7792c5c9..6fa4ed065c94 100644
--- a/www/apache22/files/patch-support__apxs.in
+++ b/www/apache22/files/patch-support__apxs.in
@@ -12,16 +12,22 @@
# check for open <containers>, so that the new LoadModule
# directive always appears *outside* of an <container>.
-@@ -610,7 +613,7 @@
+@@ -610,7 +613,13 @@
}
} else {
# replace already existing LoadModule line
- $content =~ s|^(.*\n)#?\s*$lmd[^\n]*\n|$1$c$lmd\n|s;
-+ $content =~ s|^(.*\n)#?\s*$lmd_re[^\n]*\n|$1$c$lmd\n|s;
++ # Custom FreeBSD mod
++ if ($opt_A) {
++ $content =~ s|^(.*\n)#?\s*$lmd_re[^\n]*\n|$1|s;
++ }
++ else {
++ $content =~ s|^(.*\n)#?\s*$lmd_re[^\n]*\n|$1$c$lmd\n|s;
++ }
}
$lmd =~ m|LoadModule\s+(.+?)_module.*|;
notice("[$what module `$1' in $CFG_SYSCONFDIR/$CFG_TARGET.conf]");
-@@ -619,8 +622,7 @@
+@@ -619,8 +628,7 @@
if (open(FP, ">$CFG_SYSCONFDIR/$CFG_TARGET.conf.new")) {
print FP $content;
close(FP);
diff --git a/www/apache22/pkg-plist b/www/apache22/pkg-plist
index d041aa734060..b62392302f37 100644
--- a/www/apache22/pkg-plist
+++ b/www/apache22/pkg-plist
@@ -3,7 +3,7 @@
@exec mkdir -p %D/etc/apache22/extra 2> /dev/null
@exec mkdir -p %D/etc/apache22/Includes 2> /dev/null || true
@exec mkdir -p %D/etc/apache22/envvars.d 2> /dev/null || true
-@unexec if cmp -s %D/etc/apache22/httpd.conf %D/%%EXAMPLESDIR%%/httpd.conf; then rm -f %D/etc/apache22/httpd.conf; fi
+@unexec if cmp %D/etc/apache22/httpd.conf %D/%%EXAMPLESDIR%%/httpd.conf; then rm -f %D/etc/apache22/httpd.conf; fi
%%EXAMPLESDIR%%/httpd.conf
@exec [ -f %D/etc/apache22/httpd.conf ] || cp %D/%%EXAMPLESDIR%%/httpd.conf %D/etc/apache22/httpd.conf
@unexec if cmp -s %D/etc/apache22/magic %D/%%EXAMPLESDIR%%/magic; then rm -f %D/etc/apache22/magic; fi