aboutsummaryrefslogtreecommitdiff
path: root/www/apache2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-13 22:12:11 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-13 22:12:11 +0000
commit655d57447278a1ff984eb78d55b05761a12c2ad5 (patch)
treef000cc04bacd8879429750ee23b8f611071e21ca /www/apache2
parent527f5fb11ad3727c12674817a1fb7c58571d9072 (diff)
downloadports-655d57447278a1ff984eb78d55b05761a12c2ad5.tar.gz
ports-655d57447278a1ff984eb78d55b05761a12c2ad5.zip
- Remove thread support in apr. The code prevents apache from running
on > 4.8-STABLE (from september 2003) system because apache2 used libc_r instead of libc. Compiling with -lkse (on -CURRENT) was broken too. - bump PORTREVISION to force users to upgrade. NOTE: on -STABLE DO NOT DEFINE WITH_THREADS. (unless you use a threaded MPM) Thanks to Fritz Heinrichmeyer <fritz.heinrichmeyer@fernuni-hagen.de> who helped me to track the problem. Noticed by: Fritz Heinrichmeyer <fritz.heinrichmeyer@fernuni-hagen.de> HAYASHI, "Lef" Tatsuya <lef@st.rim.or.jp> [1] PR: 61317 [1] Approved by: erwin (mentor) (implicitly)
Notes
Notes: svn path=/head/; revision=98117
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile2
-rw-r--r--www/apache2/files/patch-srclib:apr:build:apr_hints.m425
2 files changed, 1 insertions, 26 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 0126742e7be2..cf67fa794915 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.48
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
diff --git a/www/apache2/files/patch-srclib:apr:build:apr_hints.m4 b/www/apache2/files/patch-srclib:apr:build:apr_hints.m4
deleted file mode 100644
index 444351563b7f..000000000000
--- a/www/apache2/files/patch-srclib:apr:build:apr_hints.m4
+++ /dev/null
@@ -1,25 +0,0 @@
---- srclib/apr/build/apr_hints.m4.orig Tue Jun 3 00:52:28 2003
-+++ srclib/apr/build/apr_hints.m4 Mon Jan 5 12:36:32 2004
-@@ -130,14 +130,15 @@
- APR_ADDTO(CPPFLAGS, [-DNETBSD])
- ;;
- *-freebsd*)
-- case $host in
-- *freebsd[2345]*)
-- APR_ADDTO(CFLAGS, [-funsigned-char])
-- ;;
-- esac
-- APR_SETIFNULL(enable_threads, [no])
-+ os_version=`sysctl -n kern.osreldate`
-+ APR_ADDTO(CFLAGS, [-funsigned-char])
- APR_SETIFNULL(apr_lock_method, [USE_FLOCK_SERIALIZE])
-- APR_ADDTO(CPPFLAGS, [-D_REENTRANT -D_THREAD_SAFE])
-+ if test $os_version -lt "500016"; then
-+ ac_cv_pthreads_cflags="-D_THREAD_SAFE -D_REENTRANT"
-+ LIBS="$LIBS -pthread"
-+ else
-+ ac_cv_pthreads_lib="c_r"
-+ fi
- ;;
- *-next-nextstep*)
- APR_SETIFNULL(CFLAGS, [-O])