aboutsummaryrefslogtreecommitdiff
path: root/www/aria2/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-17 04:34:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-17 04:34:34 +0000
commit054762a42c7711de0cfb2a3fc3c4456927d3a790 (patch)
tree44ba5f427456b53d265ca09ef7e543dfe4a29eae /www/aria2/Makefile
parentbbc0e7b3768fd407bc6823461ac9cb1e90fe2785 (diff)
downloadports-054762a42c7711de0cfb2a3fc3c4456927d3a790.tar.gz
ports-054762a42c7711de0cfb2a3fc3c4456927d3a790.zip
www/aria2: update to 1.28.0
- Expose SSH2 option (appeared in 1.19.0) - Chase HTTP redirect in MASTER_SITES - Convert USE_OPENSSL=yes into USES+=ssl Changes: https://github.com/aria2/aria2/compare/release-1.23.0...release-1.28.0 Changes: https://github.com/aria2/aria2/releases PR: 212960 Submitted by: lightside@gmx.com Approved by: maintainer timeout (3 weeks)
Notes
Notes: svn path=/head/; revision=424093
Diffstat (limited to 'www/aria2/Makefile')
-rw-r--r--www/aria2/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index 739fc58b9379..79ca558d8c06 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= aria2
-PORTVERSION= 1.23.0
+PORTVERSION= 1.28.0
CATEGORIES= www
-MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/release-${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/release-${PORTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Yet another download tool
@@ -12,10 +12,11 @@ COMMENT= Yet another download tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= CA_BUNDLE DOCS NLS SQLITE
+OPTIONS_DEFINE= CA_BUNDLE DOCS NLS SQLITE SSH2
OPTIONS_DEFAULT=SQLITE
OPTIONS_SUB= yes
CA_BUNDLE_DESC= Use CA bundle from Mozilla Project
+SSH2_DESC= SSH2 protocol support
CONFIGURE_ARGS= --disable-epoll --enable-bittorrent --enable-libaria2 \
--enable-metalink --enable-shared --enable-ssl --enable-static \
@@ -35,9 +36,8 @@ INSTALL_TARGET= install-strip
USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_LDCONFIG= yes
-USE_OPENSSL= yes
USE_RC_SUBR= ${PORTNAME}
-USES= compiler:c++11-lib libtool pathfix pkgconfig tar:xz
+USES= compiler:c++11-lib libtool pathfix pkgconfig ssl tar:xz
PORTDOCS= *
@@ -50,6 +50,8 @@ NLS_LDFLAGS= -lintl
NLS_USES= gettext localbase
SQLITE_CONFIGURE_WITH= sqlite3
SQLITE_USES= sqlite
+SSH2_CONFIGURE_WITH= libssh2
+SSH2_LIB_DEPENDS= libssh2.so:security/libssh2
ARIA2_DISK_CACHE?= 16M