aboutsummaryrefslogtreecommitdiff
path: root/www/aria2fe/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-12-11 23:53:34 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-12-11 23:53:34 +0000
commitfa90e9df6fe31d617c15fd3b3f93b67d46fdf7bf (patch)
tree844db5b18d15a15b657e480586641427deb00274 /www/aria2fe/Makefile
parentd971d5140c9bdfb250bf42c71ad62fac1e18f237 (diff)
downloadports-fa90e9df6fe31d617c15fd3b3f93b67d46fdf7bf.tar.gz
ports-fa90e9df6fe31d617c15fd3b3f93b67d46fdf7bf.zip
Add port www/aria2fe:
aria2fe is a graphical user interface for the command line based program aria2. aria2fe was designed and constructed using C++/Qt for the GNU Unix/Posix/Linux platform. WWW: http://www.aria2fe.com/ Author: Mike Wells <aria2fe@cox.net>
Notes
Notes: svn path=/head/; revision=203078
Diffstat (limited to 'www/aria2fe/Makefile')
-rw-r--r--www/aria2fe/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/aria2fe/Makefile b/www/aria2fe/Makefile
new file mode 100644
index 000000000000..38477b2ce120
--- /dev/null
+++ b/www/aria2fe/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: aria2fe
+# Date created: 12 December 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aria2fe
+DISTVERSION= 0.0.5
+CATEGORIES= www
+MASTER_SITES= SFE
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Aria2 QT front-end
+
+RUN_DEPENDS= aria2c:${PORTSDIR}/www/aria2 \
+ xterm:${PORTSDIR}/x11/xterm
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui qmake uic moc rcc
+PLIST_FILES= bin/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+
+pre-build:
+ @cd ${BUILD_WRKSRC}/&&\
+ ${SETENV} ${MAKE_ENV} ${QMAKE} -unix ${PORTNAME}.pro
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>