aboutsummaryrefslogtreecommitdiff
path: root/www/aswiki
diff options
context:
space:
mode:
authorMakoto Matsushita <matusita@FreeBSD.org>2007-04-28 04:45:21 +0000
committerMakoto Matsushita <matusita@FreeBSD.org>2007-04-28 04:45:21 +0000
commit7fa8e9e27655be5dd088f48631b550e3e758eb3a (patch)
treebedededa2f686dee020b14e84d601ecbf30261ff /www/aswiki
parentcc729ccdcde1ab50bdeb58f5585f52a6f3d5d5de (diff)
downloadports-7fa8e9e27655be5dd088f48631b550e3e758eb3a.tar.gz
ports-7fa8e9e27655be5dd088f48631b550e3e758eb3a.zip
More broken-ruby-1.8.6-backward-compatibility adaptation.
Also bump PORTREVISION. Found by: y-manabe at ist dot osaka-u.ac.jp
Notes
Notes: svn path=/head/; revision=191049
Diffstat (limited to 'www/aswiki')
-rw-r--r--www/aswiki/Makefile2
-rw-r--r--www/aswiki/files/patch-2chbbs.rb11
-rw-r--r--www/aswiki/files/patch-demo.rb11
3 files changed, 23 insertions, 1 deletions
diff --git a/www/aswiki/Makefile b/www/aswiki/Makefile
index 3e67f1a63ee1..1f983c2df3aa 100644
--- a/www/aswiki/Makefile
+++ b/www/aswiki/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aswiki
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ruby
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/aswiki/files/patch-2chbbs.rb b/www/aswiki/files/patch-2chbbs.rb
new file mode 100644
index 000000000000..259a0d966a36
--- /dev/null
+++ b/www/aswiki/files/patch-2chbbs.rb
@@ -0,0 +1,11 @@
+--- plugin/2chbbs.rb.dist Wed Jan 8 11:01:21 2003
++++ plugin/2chbbs.rb Sat Apr 28 13:41:24 2007
+@@ -40,7 +40,7 @@
+ session['number'] = av[1].to_i
+ @data = {
+ :_session_id => session.session_id,
+- :md5sum => Digest::MD5::new(@repository.load(@name).to_s).to_s,
++ :md5sum => Digest::MD5::new.update(@repository.load(@name).to_s).to_s,
+ :msg_2chbbs_from => msg_2chbbs_from,
+ :msg_2chbbs_write => msg_2chbbs_write,
+ }
diff --git a/www/aswiki/files/patch-demo.rb b/www/aswiki/files/patch-demo.rb
new file mode 100644
index 000000000000..5e21d9db4f1d
--- /dev/null
+++ b/www/aswiki/files/patch-demo.rb
@@ -0,0 +1,11 @@
+--- plugin/demo.rb.dist Wed Jan 8 11:01:21 2003
++++ plugin/demo.rb Sat Apr 28 13:41:46 2007
+@@ -48,7 +48,7 @@
+ # session.close
+ @data = {
+ :session_id => session.session_id,
+- :md5sum => Digest::MD5::new(@repository.load(@name).to_s).to_s,
++ :md5sum => Digest::MD5::new.update(@repository.load(@name).to_s).to_s,
+ :msg_list_item => msg_list_item,
+ :msg_list_add => msg_list_add,
+ }