aboutsummaryrefslogtreecommitdiff
path: root/www/august
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-10-15 08:50:37 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-10-15 08:50:37 +0000
commitb652b7cda62f57c224bdcbce68cc97e4b0ffa892 (patch)
tree10065a016be6a12accf1ffcc311d3fdfec28d842 /www/august
parent87cd41d3f820246afaeeb0a2e835b42fa82d6c8a (diff)
downloadports-b652b7cda62f57c224bdcbce68cc97e4b0ffa892.tar.gz
ports-b652b7cda62f57c224bdcbce68cc97e4b0ffa892.zip
- Convert to USES+=tk
- Convert to OPTIONSng (DOCS) - STAGE-clean
Notes
Notes: svn path=/head/; revision=330372
Diffstat (limited to 'www/august')
-rw-r--r--www/august/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/www/august/Makefile b/www/august/Makefile
index d46818825066..b11a21b98587 100644
--- a/www/august/Makefile
+++ b/www/august/Makefile
@@ -15,26 +15,28 @@ COMMENT= HTML editor for the experienced Web author
LICENSE= GPLv2
+OPTIONS_DEFINE= DOCS
+
+USES+= tk
RUN_DEPENDS= identify:${PORTSDIR}/graphics/ImageMagick \
weblint:${PORTSDIR}/www/weblint
NO_BUILD= yes
-USE_TK_WRAPPER= yes
-
PORTDOCS= specchars.txt
PLIST_FILES= bin/august
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/bin|${LOCALBASE}/bin|g' ${WRKSRC}/august
+ 's|/usr/bin/wish|${WISH}|g' ${WRKSRC}/august
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/august ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/specchars.txt ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/august ${STAGEDIR}${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/specchars.txt ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>