aboutsummaryrefslogtreecommitdiff
path: root/www/awffull/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-01-08 21:30:31 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-01-08 21:30:31 +0000
commit6188c9e70430133753bc1250133077370fb8facc (patch)
treed445ab109fc40d2ccf3f74721a6dd7f9ca6ed994 /www/awffull/Makefile
parentc7a32e28c6cfd687149e39be60ece80b3b4e6df2 (diff)
downloadports-6188c9e70430133753bc1250133077370fb8facc.tar.gz
ports-6188c9e70430133753bc1250133077370fb8facc.zip
- Added --with-etcdir configuration option to comply with hier(7) [1]
- Fixed Makefile typo (BUILD_DEPENS) - Cleaned up some portlint warnings - Reformatted pkg-descr - Bumped PORTREVISION PR: ports/138402 Submitted by: Sascha Klauder <sascha@trimind.de> [1] Approved by: maintainer (implicit; timeout 130 days)
Notes
Notes: svn path=/head/; revision=247419
Diffstat (limited to 'www/awffull/Makefile')
-rw-r--r--www/awffull/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/awffull/Makefile b/www/awffull/Makefile
index 148a2696f116..c3f9365f84a5 100644
--- a/www/awffull/Makefile
+++ b/www/awffull/Makefile
@@ -7,19 +7,18 @@
PORTNAME= awffull
PORTVERSION= 3.10.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= www
MASTER_SITES= http://www.stedee.id.au/files/
MAINTAINER?= chad@wickdev.com
COMMENT= AWFFull is a webserver log analysis tool forked from Webalizer
+BUILD_DEPENDS= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
png.5:${PORTSDIR}/graphics/png \
pcre.0:${PORTSDIR}/devel/pcre
-
-RUN_DEPENDS?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
-BUILD_DEPENS= ${RUN_DEPENDS}
+RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS?= ja-awffull-[0-9]*
@@ -33,7 +32,8 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-font-default=${FONTDEFAULT} \
- --with-font-label=${FONTLABEL}
+ --with-font-label=${FONTLABEL} \
+ --with-etcdir=${PREFIX}/etc
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include