aboutsummaryrefslogtreecommitdiff
path: root/www/awstats/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2009-01-04 06:18:02 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2009-01-04 06:18:02 +0000
commit8c64cb93dd30649e0d12e0a7b9aec2969fe4951a (patch)
tree5e243dc97b283c04fc7537ef558fa870bcc71ba9 /www/awstats/Makefile
parentecaa9c391c62360c972589f27495c1b9dd304a80 (diff)
downloadports-8c64cb93dd30649e0d12e0a7b9aec2969fe4951a.tar.gz
ports-8c64cb93dd30649e0d12e0a7b9aec2969fe4951a.zip
- Update to 6.9
Changes 6.9: New features/improvements: - With postfix that support DSN (Delivery Status Notifications) we exclude some lines to avoid counting mails twice in maillogconvert.pl script. - Logresolvemerge.pl support FreeRADIUS logs or anything else using (the fixed length!) ctime format timestamp. - Add option stoponfirsteof in logresolvemerge tool. - Add patch to support host_proxy tag in LogFormat (for Apache LogFormat containing %{X-Forwarded-For}i) - Renamed Add to favourites on "Hit on favicon". - Increase robots, search engines database (Added Google Chrome browser, better Vista, WII, detection, ...) - Update languages files. - Added a lot of patch from sourceforge. Fixes: - Fixed broken maxmind citi, org and isp plugins. - Remove &nbsp; in name html tag to have HtmlHeadSection first. - Fix: [ 2001151 ] Security fix. - Fix: [ 2038681 ] missing <br _/_> in plugins/geoip_org_maxmind.pm - Fix: [ 1921942 ] html footer is missing from the allextraN report. - Fix: [ 1943466 ] error geoip_city_maxmind Can't locate object method "record_ - Fix: [ 1808277 ] Incorrect function call in geoip_isp_maxmind.pm - Fix: Full list of extrasections was not ordered correctly - A lot of other fixes. - Added missing icons Other/Documentation: - None - Fix CVE-2008-3714 from the upstream (Sec: Enhance security of sanitizing parameters) http://awstats.cvs.sourceforge.net/viewvc/awstats/awstats/wwwroot/cgi-bin/awstats.pl?r1=1.925&r2=1.926 PR: ports/129957, ports/130143 Submitted by: Eygene Ryabinkin <rea-fbsd _at\ codelabs.ru>, Naram Qashat <cyberbotx -at\ cyberbotx.com> Approved by: Alex Samorukov (maintainer) Security: http://secunia.com/advisories/31519
Notes
Notes: svn path=/head/; revision=225204
Diffstat (limited to 'www/awstats/Makefile')
-rw-r--r--www/awstats/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/www/awstats/Makefile b/www/awstats/Makefile
index 522c4aedd22f..094137e53c67 100644
--- a/www/awstats/Makefile
+++ b/www/awstats/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= awstats
-PORTVERSION= 6.8
-PORTREVISION= 1
+PORTVERSION= 6.9
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= SF
@@ -75,6 +74,7 @@ do-install:
@${MKDIR} ${PREFIX}/www/awstats/js
@${MKDIR} ${PREFIX}/www/awstats/tools
@${MKDIR} ${PREFIX}/www/awstats/tools/webmin
+ @${MKDIR} ${PREFIX}/www/awstats/tools/xslt
${INSTALL_SCRIPT} ${WRKSRC}/tools/awstats_buildstaticpages.pl ${PREFIX}/www/awstats/tools
${INSTALL_SCRIPT} ${WRKSRC}/tools/awstats_exportlib.pl ${PREFIX}/www/awstats/tools
${INSTALL_SCRIPT} ${WRKSRC}/tools/awstats_updateall.pl ${PREFIX}/www/awstats/tools
@@ -82,7 +82,8 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/tools/logresolvemerge.pl ${PREFIX}/www/awstats/tools
${INSTALL_SCRIPT} ${WRKSRC}/tools/maillogconvert.pl ${PREFIX}/www/awstats/tools
${INSTALL_SCRIPT} ${WRKSRC}/tools/urlaliasbuilder.pl ${PREFIX}/www/awstats/tools
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/webmin/awstats-1.8.wbm ${PREFIX}/www/awstats/tools/webmin
+ ${INSTALL_DATA} ${WRKSRC}/tools/webmin/awstats-1.8.wbm ${PREFIX}/www/awstats/tools/webmin
+ ${INSTALL_DATA} ${WRKSRC}/tools/xslt/* ${PREFIX}/www/awstats/tools/xslt
${INSTALL_SCRIPT} ${WRKSRC}/wwwroot/cgi-bin/awredir.pl ${PREFIX}/www/awstats/cgi-bin
${INSTALL_DATA} ${WRKSRC}/wwwroot/cgi-bin/awstats.model.conf ${PREFIX}/www/awstats/cgi-bin
${INSTALL_SCRIPT} ${WRKSRC}/wwwroot/cgi-bin/awstats.pl ${PREFIX}/www/awstats/cgi-bin
@@ -103,16 +104,17 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/wwwroot/icon/os/* ${PREFIX}/www/awstats/icons/os
${INSTALL_DATA} ${WRKSRC}/wwwroot/icon/other/* ${PREFIX}/www/awstats/icons/other
${INSTALL_DATA} ${WRKSRC}/wwwroot/js/* ${PREFIX}/www/awstats/js
- @${ECHO_CMD} ""
- @${ECHO_CMD} "* Rename ${PREFIX}/www/awstats/cgi-bin/awstats.model.conf to awstats.site.conf to setup awstats"
- @${ECHO_CMD} "* Documentation has been installed in ${PREFIX}/share/doc/awstats"
- @${ECHO_CMD} ""
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/images
${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
${INSTALL_DATA} ${WRKSRC}/docs/*.* ${DOCSDIR}
.endif
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "* Rename ${PREFIX}/www/awstats/cgi-bin/awstats.model.conf to awstats.site.conf to setup awstats"
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} "* Documentation has been installed in ${PREFIX}/share/doc/awstats"
+.endif
+ @${ECHO_CMD} ""
.if !defined(BATCH)
post-install: