aboutsummaryrefslogtreecommitdiff
path: root/www/b2evolution
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-08-29 06:55:59 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-08-29 06:55:59 +0000
commit1d3f59019455f0e61a9797befbbd222a3395af63 (patch)
treea7667da91a6c6fe3c41b72f4af271c87a82fcfaa /www/b2evolution
parent5f87d688366c8265d76b5c6c0fe69a0685702b61 (diff)
downloadports-1d3f59019455f0e61a9797befbbd222a3395af63.tar.gz
ports-1d3f59019455f0e61a9797befbbd222a3395af63.zip
- added missing conditional dependency on appropriate version of MySQL server,
- respect change of DESTDIR into PREFIX, committed by gabor on Aug 4. PR: ports/115243 Submitted by: maintainer (Sergei Vyshenski)
Notes
Notes: svn path=/head/; revision=198478
Diffstat (limited to 'www/b2evolution')
-rw-r--r--www/b2evolution/Makefile9
-rw-r--r--www/b2evolution/pkg-message46
2 files changed, 33 insertions, 22 deletions
diff --git a/www/b2evolution/Makefile b/www/b2evolution/Makefile
index 2b6d285ba6dd..17001eb2a4a0 100644
--- a/www/b2evolution/Makefile
+++ b/www/b2evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= b2evolution
PORTVERSION= 1.10.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= evocms
@@ -27,13 +28,19 @@ WANT_PHP_WEB= YES
TMPDIR?= ${PORTNAME}
WRKSRC= ${WRKDIR}/${TMPDIR}
-
B2EVO_URL?= b2evo
B2EVO_DIR?= www/${B2EVO_URL}
PLIST= ${WRKDIR}/pkg-plist
+OPTIONS= LOCAL_DB_SERVER "Want to use local MySQL server?" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_LOCAL_DB_SERVER)
+USE_MYSQL= YES
+RUN_DEPENDS+= mysql-server>=0:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+.endif
+
pre-install:
@cd ${WRKSRC} && ${FIND} -s . -type f | \
${SED} -e 's|^./||;s|^|${B2EVO_DIR}/|' > ${PLIST} \
diff --git a/www/b2evolution/pkg-message b/www/b2evolution/pkg-message
index 3d89792294d8..28d5c7113a3e 100644
--- a/www/b2evolution/pkg-message
+++ b/www/b2evolution/pkg-message
@@ -2,34 +2,38 @@
b2evolution is now installed. If you install it for the first time,
you may need to perform the following steps.
-1. Create the MySQL database:
+1. Make sure your mysql-server is running.
- # mysqladmin --user=root -p create b2evolution
+2. Create a new MySQL database:
-2. Create a mysql user/password for the b2evolution database:
+ # mysqladmin --user=root -p create b2evolution
+
+ (in mysql root's password is empty unless you have set it in advance).
+
+3. Create a mysql user/password for the b2evolution database:
(change user and/or password if required)
- # mysql -u root -p
- mysql> GRANT ALL ON b2evolution.* TO b2evouser@localhost
- IDENTIFIED BY 'b2evopassword';
- mysql> FLUSH PRIVILEGES;
- mysql> QUIT;
+ # mysql -u root -p
+ mysql> GRANT ALL ON b2evolution.* TO b2evouser@localhost
+ IDENTIFIED BY 'b2evopassword';
+ mysql> FLUSH PRIVILEGES;
+ mysql> QUIT;
-3. Please add the following to your apache config, and restart.
- #
- # Directives to allow use of b2evolution
- #
- Alias /%%B2EVO_URL%% "%%PREFIX%%/%%B2EVO_DIR%%/"
+4. Add the following to your apache config, and restart.
+ #
+ # Directives to allow use of b2evolution
+ #
+ Alias /%%B2EVO_URL%% "%%PREFIX%%/%%B2EVO_DIR%%/"
+ #
-4.Open b2evo installation page in your web browser
- and login with b2evouser/b2evopassword
+5. Open b2evo installation page in your web browser
+ and login with b2evouser/b2evopassword
- http://www.your.host/%%B2EVO_URL%%/blogs/install/
+ http://www.your.host/%%B2EVO_URL%%/blogs/install/
- If you are doing a fresh install...
- Note that password carefully! It is a random password that is given to you
- when you install b2evolution.
- If you lose it, you will have to delete the database tables and reinstall.
+ (if you are doing a fresh install...)
+ Note that password carefully! It is a random password that is given to you
+ when you install b2evolution.
+ If you lose it, you will have to delete the database tables and reinstall.
- Have fun!
==================================================================