aboutsummaryrefslogtreecommitdiff
path: root/www/beehive
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-09-04 01:38:54 +0000
committerSteve Wills <swills@FreeBSD.org>2020-09-04 01:38:54 +0000
commit40ab1e921354f6331d7c622462ee14e9a7a23235 (patch)
treeb0bf08853a58b186b9a2ae0b8a515249ef93e5e4 /www/beehive
parenteeb5d3b0ec7ad76a0d0100ba59deee576e79948a (diff)
downloadports-40ab1e921354f6331d7c622462ee14e9a7a23235.tar.gz
ports-40ab1e921354f6331d7c622462ee14e9a7a23235.zip
www/beehive: create port
Event and agent system, which allows you to create your own agents that perform automated tasks triggered by events and filters. It is modular, flexible and really easy to extend for anyone. It has modules (we call them Hives), so it can interface with, talk to, or retrieve information from Twitter, Tumblr, Email, IRC, Jabber, RSS, Jenkins, Hue - to name just a few. WWW: https://github.com/muesli/beehive PR: 243514 Submitted by: Lewis Cook <vulcan@wired.sh>
Notes
Notes: svn path=/head/; revision=547496
Diffstat (limited to 'www/beehive')
-rw-r--r--www/beehive/Makefile141
-rw-r--r--www/beehive/distinfo185
-rw-r--r--www/beehive/pkg-descr9
3 files changed, 335 insertions, 0 deletions
diff --git a/www/beehive/Makefile b/www/beehive/Makefile
new file mode 100644
index 000000000000..b9ee2f2c4679
--- /dev/null
+++ b/www/beehive/Makefile
@@ -0,0 +1,141 @@
+# $FreeBSD$
+
+PORTNAME= beehive
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.2
+CATEGORIES= www
+
+MAINTAINER= vulcan@wired.sh
+COMMENT= Flexible event/agent & automation system with lots of bees
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64 i386
+
+BUILD_DEPENDS= go-bindata:devel/go-bindata
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= muesli
+GH_TUPLE= ChimeraCoder:anaconda:v2.0.0:chimeracoder_anaconda/vendor/github.com/ChimeraCoder/anaconda \
+ ChimeraCoder:tokenbucket:c5a927568de7:chimeracoder_tokenbucket/vendor/github.com/ChimeraCoder/tokenbucket \
+ CleverbotIO:go-cleverbot.io:d24926702e8d:cleverbotio_go_cleverbot_io/vendor/github.com/CleverbotIO/go-cleverbot.io \
+ MariaTerzieva:gotumblr:93ca5e50a3fd:mariaterzieva_gotumblr/vendor/github.com/MariaTerzieva/gotumblr \
+ Profpatsch:GoOse:da5de31b9bd2:profpatsch_goose/vendor/github.com/Profpatsch/GoOse \
+ PuerkitoBio:goquery:v1.5.0:puerkitobio_goquery/vendor/github.com/PuerkitoBio/goquery \
+ akashshinde:go_cricket:01a06b2c3f22:akashshinde_go_cricket/vendor/github.com/akashshinde/go_cricket \
+ alexcesaro:quotedprintable:2caba252f4dc:alexcesaro_quotedprintable/vendor/gopkg.in/alexcesaro/quotedprintable.v3 \
+ andybalholm:cascadia:v1.0.0:andybalholm_cascadia/vendor/github.com/andybalholm/cascadia \
+ araddon:dateparse:0d74ffceef83:araddon_dateparse/vendor/github.com/araddon/dateparse \
+ asaskevich:EventBus:d46933a94f05:asaskevich_eventbus/vendor/github.com/asaskevich/EventBus \
+ azr:backoff:53511d3c7330:azr_backoff/vendor/github.com/azr/backoff \
+ beorn7:perks:3a771d992973:beorn7_perks/vendor/github.com/beorn7/perks \
+ briandowns:openweathermap:5f41b7c9d92d:briandowns_openweathermap/vendor/github.com/briandowns/openweathermap \
+ bwmarrin:discordgo:v0.19.0:bwmarrin_discordgo/vendor/github.com/bwmarrin/discordgo \
+ carlosdp:twiliogo:b26045ebb9d1:carlosdp_twiliogo/vendor/github.com/carlosdp/twiliogo \
+ davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
+ deckarep:gosx-notifier:e127226297fb:deckarep_gosx_notifier/vendor/github.com/deckarep/gosx-notifier \
+ dustin:go-jsonpointer:ba0abeacc3dc:dustin_go_jsonpointer/vendor/github.com/dustin/go-jsonpointer \
+ dustin:gojson:2e71ec9dd5ad:dustin_gojson/vendor/github.com/dustin/gojson \
+ emicklei:go-restful:v2.9.3:emicklei_go_restful/vendor/github.com/emicklei/go-restful \
+ fatih:set:v0.2.1:fatih_set/vendor/github.com/fatih/set \
+ flashmob:go-guerrilla:07043ae76e81:flashmob_go_guerrilla/vendor/github.com/flashmob/go-guerrilla \
+ fluffle:goirc:v1.0.1:fluffle_goirc/vendor/github.com/fluffle/goirc \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
+ garyburd:go-oauth:bca2e7f09a17:garyburd_go_oauth/vendor/github.com/garyburd/go-oauth \
+ gigawattio:window:0f5467e35573:gigawattio_window/vendor/github.com/gigawattio/window \
+ glaxx:go_pastebin:7e72d56770d0:glaxx_go_pastebin/vendor/github.com/glaxx/go_pastebin \
+ go-ini:ini:v1.42.0:go_ini_ini/vendor/github.com/go-ini/ini \
+ go-mail:mail:v2.3.1:go_mail_mail/vendor/github.com/go-mail/mail \
+ go-telegram-bot-api:telegram-bot-api:v4.6.4:go_telegram_bot_api_telegram_bot_api/vendor/github.com/go-telegram-bot-api/telegram-bot-api \
+ golang:appengine:v1.5.0:golang_appengine/vendor/google.golang.org/appengine \
+ golang:crypto:a29dc8fdc734:golang_crypto/vendor/golang.org/x/crypto \
+ golang:mock:v1.2.0:golang_mock/vendor/github.com/golang/mock \
+ golang:net:9ce7a6920f09:golang_net/vendor/golang.org/x/net \
+ golang:oauth2:9f3314589c9a:golang_oauth2/vendor/golang.org/x/oauth2 \
+ golang:protobuf:v1.3.1:golang_protobuf/vendor/github.com/golang/protobuf \
+ golang:sys:d89cdac9e872:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
+ google:go-github:v17.0.0:google_go_github/vendor/github.com/google/go-github \
+ google:go-querystring:v1.0.0:google_go_querystring/vendor/github.com/google/go-querystring \
+ gorilla:websocket:v1.4.0:gorilla_websocket/vendor/github.com/gorilla/websocket \
+ guelfey:go.dbus:f6a3a2366cc3:guelfey_go_dbus/vendor/github.com/guelfey/go.dbus \
+ huandu:facebook:v2.3.1:huandu_facebook/vendor/github.com/huandu/facebook \
+ jacobsa:go-serial:15cf729a72d4:jacobsa_go_serial/vendor/github.com/jacobsa/go-serial \
+ jayeshsolanki93:devgorant:69fb03e5c3b1:jayeshsolanki93_devgorant/vendor/github.com/jayeshsolanki93/devgorant \
+ jaytaylor:html2text:01ec452cbe43:jaytaylor_html2text/vendor/github.com/jaytaylor/html2text \
+ json-iterator:go:v1.1.6:json_iterator_go/vendor/github.com/json-iterator/go \
+ konsorten:go-windows-terminal-sequences:v1.0.2:konsorten_go_windows_terminal_sequences/vendor/github.com/konsorten/go-windows-terminal-sequences \
+ kr:pretty:v0.1.0:kr_pretty/vendor/github.com/kr/pretty \
+ kr:text:v0.1.0:kr_text/vendor/github.com/kr/text \
+ kurrik:oauth1a:cb1b80e32dd4:kurrik_oauth1a/vendor/github.com/kurrik/oauth1a \
+ mattn:go-colorable:v0.1.1:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-isatty:v0.0.7:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ mattn:go-mastodon:v0.0.3:mattn_go_mastodon/vendor/github.com/mattn/go-mastodon \
+ mattn:go-runewidth:v0.0.4:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
+ mattn:go-xmpp:6093f50721ed:mattn_go_xmpp/vendor/github.com/mattn/go-xmpp \
+ matttproud:golang_protobuf_extensions:v1.0.1:matttproud_golang_protobuf_extensions/vendor/github.com/matttproud/golang_protobuf_extensions \
+ minio:minio-go:v6.0.14:minio_minio_go/vendor/github.com/minio/minio-go \
+ mitchellh:go-homedir:v1.1.0:mitchellh_go_homedir/vendor/github.com/mitchellh/go-homedir \
+ modern-go:concurrent:bacd9c7ef1dd:modern_go_concurrent/vendor/github.com/modern-go/concurrent \
+ modern-go:reflect2:v1.0.1:modern_go_reflect2/vendor/github.com/modern-go/reflect2 \
+ mreiferson:go-httpclient:31f0106b4474:mreiferson_go_httpclient/vendor/github.com/mreiferson/go-httpclient \
+ mrexodia:wray:78a2c1f284ff:mrexodia_wray/vendor/github.com/mrexodia/wray \
+ muesli:go-pkg-rss:3bef0f3126ec:muesli_go_pkg_rss/vendor/github.com/muesli/go-pkg-rss \
+ muesli:go-pkg-xmlx:76f54ee73233:muesli_go_pkg_xmlx/vendor/github.com/muesli/go-pkg-xmlx \
+ muesli:go.hue:8aefcc693caf:muesli_go_hue/vendor/github.com/muesli/go.hue \
+ muesli:goefa:08d8ee2555d2:muesli_goefa/vendor/github.com/muesli/goefa \
+ muesli:smolder:9c21fc7135ee:muesli_smolder/vendor/github.com/muesli/smolder \
+ nlopes:slack:v0.5.0:nlopes_slack/vendor/github.com/nlopes/slack \
+ nu7hatch:gouuid:179d4d0c4d8d:nu7hatch_gouuid/vendor/github.com/nu7hatch/gouuid \
+ odwrtw:transmission:08885b3058e7:odwrtw_transmission/vendor/github.com/odwrtw/transmission \
+ olekukonko:tablewriter:v0.0.1:olekukonko_tablewriter/vendor/github.com/olekukonko/tablewriter \
+ pkg:errors:v0.8.1:pkg_errors/vendor/github.com/pkg/errors \
+ pmezard:go-difflib:v1.0.0:pmezard_go_difflib/vendor/github.com/pmezard/go-difflib \
+ prometheus:client_golang:v0.9.2:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
+ prometheus:client_model:5c3871d89910:prometheus_client_model/vendor/github.com/prometheus/client_model \
+ prometheus:common:4724e9255275:prometheus_common/vendor/github.com/prometheus/common \
+ prometheus:procfs:1dc9a6cbc91a:prometheus_procfs/vendor/github.com/prometheus/procfs \
+ rogpeppe:go-charset:2471d30d28b4:rogpeppe_go_charset/vendor/github.com/rogpeppe/go-charset \
+ shuheiktgw:go-travis:2d0b3e9898f0:shuheiktgw_go_travis/vendor/github.com/shuheiktgw/go-travis \
+ simplepush:simplepush-go:8980e96b7b02:simplepush_simplepush_go/vendor/github.com/simplepush/simplepush-go \
+ sirupsen:logrus:v1.4.1:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
+ sromku:go-gitter:70f7030a94a6:sromku_go_gitter/vendor/github.com/sromku/go-gitter \
+ ssor:bom:6386211fdfcf:ssor_bom/vendor/github.com/ssor/bom \
+ stretchr:objx:v0.2.0:stretchr_objx/vendor/github.com/stretchr/objx \
+ stretchr:testify:v1.3.0:stretchr_testify/vendor/github.com/stretchr/testify \
+ technoweenie:multipartstreamer:v1.0.1:technoweenie_multipartstreamer/vendor/github.com/technoweenie/multipartstreamer \
+ tomnomnom:linkheader:02ca5825eb80:tomnomnom_linkheader/vendor/github.com/tomnomnom/linkheader \
+ layeh:gumble:1ea1159c4956:layeh_gumble/vendor/layeh.com/gumble \
+ muesli:beehive-admin-dist:648f36d9834d:onfig/config
+
+GO_BUILDFLAGS= ${BUILD_TAGS} \
+ -ldflags \
+ "-s -w \
+ -X main.Version=${DISTVERSION} \
+ -X main.CommitSHA=${BUILD_SHA}"
+
+BUILD_TAGS= -tags "embed"
+BUILD_SHA= c66102d
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-patch:
+ # Fixes build error: https://github.com/flashmob/go-guerrilla/issues/147
+ # This can be removed once beehives dependencies have been bumped to the latest commits
+ @${REINPLACE_CMD} -e 's|rLimit.Max|uint64(rLimit.Max)|g' \
+ ${WRKSRC}/vendor/github.com/flashmob/go-guerrilla/guerrilla_unix.go
+
+pre-build:
+ (cd ${WRKSRC} && \
+ ${LOCALBASE}/bin/go-bindata ${BUILD_TAGS} --pkg api -o api/bindata.go --ignore config/.git assets/... config/...)
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/beehive/distinfo b/www/beehive/distinfo
new file mode 100644
index 000000000000..30468a1a95ad
--- /dev/null
+++ b/www/beehive/distinfo
@@ -0,0 +1,185 @@
+TIMESTAMP = 1579692437
+SHA256 (muesli-beehive-v0.3.2_GH0.tar.gz) = 1228a9c0ff1935e23158ce36885d15079a59f0af89eff05dd0df21aaad9e8fa5
+SIZE (muesli-beehive-v0.3.2_GH0.tar.gz) = 1860448
+SHA256 (ChimeraCoder-anaconda-v2.0.0_GH0.tar.gz) = be09e83cb071a24c4f9c5a8800a2b2239188de544c76c7ad53bff102d2f13948
+SIZE (ChimeraCoder-anaconda-v2.0.0_GH0.tar.gz) = 410673
+SHA256 (ChimeraCoder-tokenbucket-c5a927568de7_GH0.tar.gz) = 83391682a94c0a730a7bbdbb6f2070bcc3bcba0da44d29c5a2ca12fd39adc4f0
+SIZE (ChimeraCoder-tokenbucket-c5a927568de7_GH0.tar.gz) = 5214
+SHA256 (CleverbotIO-go-cleverbot.io-d24926702e8d_GH0.tar.gz) = 0858e2a45f30a3cf97ee17c3ec8f5e3c88b77857669d9a3c8f67ccab3c656a7e
+SIZE (CleverbotIO-go-cleverbot.io-d24926702e8d_GH0.tar.gz) = 3137
+SHA256 (MariaTerzieva-gotumblr-93ca5e50a3fd_GH0.tar.gz) = 5a3370cc9c99a9a0642f200ae2ec4dbe03b48b05aad19f4afcbae25bd36346c2
+SIZE (MariaTerzieva-gotumblr-93ca5e50a3fd_GH0.tar.gz) = 14513
+SHA256 (Profpatsch-GoOse-da5de31b9bd2_GH0.tar.gz) = 7da180ea74ffbc24c187bfb95f660a4fd09d6419a69ef2837f9cf1a95635d7e4
+SIZE (Profpatsch-GoOse-da5de31b9bd2_GH0.tar.gz) = 1582740
+SHA256 (PuerkitoBio-goquery-v1.5.0_GH0.tar.gz) = 0307341d56ae12648584b3990fb1e84f465870247e46aff00381c98c5ad231c7
+SIZE (PuerkitoBio-goquery-v1.5.0_GH0.tar.gz) = 100975
+SHA256 (akashshinde-go_cricket-01a06b2c3f22_GH0.tar.gz) = d85c8e4581b4810c729088ef3f832dc7145c5927fc8729ecf9ee4e54403c6a42
+SIZE (akashshinde-go_cricket-01a06b2c3f22_GH0.tar.gz) = 13740
+SHA256 (alexcesaro-quotedprintable-2caba252f4dc_GH0.tar.gz) = 1a314d172f499342a97996e30ae1731b2e923e17031734d7350927458f544efb
+SIZE (alexcesaro-quotedprintable-2caba252f4dc_GH0.tar.gz) = 10425
+SHA256 (andybalholm-cascadia-v1.0.0_GH0.tar.gz) = 00ab6f915e958c9e0509836cd67082a802513459c12c4aa6e7a28ef37743ce52
+SIZE (andybalholm-cascadia-v1.0.0_GH0.tar.gz) = 13232
+SHA256 (araddon-dateparse-0d74ffceef83_GH0.tar.gz) = a78f19e8dd2d798c202645fcfb2e4d16c705a555b24413fedddfba3608af3a1b
+SIZE (araddon-dateparse-0d74ffceef83_GH0.tar.gz) = 21798
+SHA256 (asaskevich-EventBus-d46933a94f05_GH0.tar.gz) = 61f9adf52a69486bdb7a8823fff14ac217593d75ae09103e72f607ef2b27ae67
+SIZE (asaskevich-EventBus-d46933a94f05_GH0.tar.gz) = 7289
+SHA256 (azr-backoff-53511d3c7330_GH0.tar.gz) = 438d9acf1fbb219aac715c8548a5d402393e8421b7412f8fb1c97ed6977cc7b4
+SIZE (azr-backoff-53511d3c7330_GH0.tar.gz) = 5130
+SHA256 (beorn7-perks-3a771d992973_GH0.tar.gz) = 5787b1e4533cadd525c240bfa03d672662c7ba48572a645238458053d73a0d59
+SIZE (beorn7-perks-3a771d992973_GH0.tar.gz) = 10798
+SHA256 (briandowns-openweathermap-5f41b7c9d92d_GH0.tar.gz) = 9181d7c24cdc7561fa69233a0625255f1a40efb98950d72c88b417ea85af7816
+SIZE (briandowns-openweathermap-5f41b7c9d92d_GH0.tar.gz) = 23744
+SHA256 (bwmarrin-discordgo-v0.19.0_GH0.tar.gz) = e61952564f58d8dfb3f05f9ee0cc62706e641d945d1ce1e06b052d834e0f45fe
+SIZE (bwmarrin-discordgo-v0.19.0_GH0.tar.gz) = 124300
+SHA256 (carlosdp-twiliogo-b26045ebb9d1_GH0.tar.gz) = e8ac779ccf698d9ef9fd94bf08cd66b10cd4cb1dba87ab96860fc1ccbc6c193a
+SIZE (carlosdp-twiliogo-b26045ebb9d1_GH0.tar.gz) = 14601
+SHA256 (davecgh-go-spew-v1.1.1_GH0.tar.gz) = 7d82b9bb7291adbe7498fe946920ab3e7fc9e6cbfc3b2294693fad00bf0dd17e
+SIZE (davecgh-go-spew-v1.1.1_GH0.tar.gz) = 42152
+SHA256 (deckarep-gosx-notifier-e127226297fb_GH0.tar.gz) = 371fee190f76a8578aa3bd10836cf06e6965677d15b5e38685a8a0aa0bc0566a
+SIZE (deckarep-gosx-notifier-e127226297fb_GH0.tar.gz) = 1010063
+SHA256 (dustin-go-jsonpointer-ba0abeacc3dc_GH0.tar.gz) = 9f04ea806232753c5eb9e7e59e5553e8701e51ce2266a9d1b0991b85d9feb49b
+SIZE (dustin-go-jsonpointer-ba0abeacc3dc_GH0.tar.gz) = 136853
+SHA256 (dustin-gojson-2e71ec9dd5ad_GH0.tar.gz) = 38365483bedcc3201513db51b3485954cefbe6f644164761cda4499d8f1a8864
+SIZE (dustin-gojson-2e71ec9dd5ad_GH0.tar.gz) = 165499
+SHA256 (emicklei-go-restful-v2.9.3_GH0.tar.gz) = 85db5255097eca7628b8910f0eda317c5640435d99d67ea978d176d80cf69e5d
+SIZE (emicklei-go-restful-v2.9.3_GH0.tar.gz) = 64206
+SHA256 (fatih-set-v0.2.1_GH0.tar.gz) = 8b1d0bf1529083f9c29cf82e5c8419d8705797c4470a41ec74cf4d4dd373622f
+SIZE (fatih-set-v0.2.1_GH0.tar.gz) = 8404
+SHA256 (flashmob-go-guerrilla-07043ae76e81_GH0.tar.gz) = 445ef20fdb70275a5a4122ffc704f264e6bbea0cb3ca1b4c47cb8efdeb762cd3
+SIZE (flashmob-go-guerrilla-07043ae76e81_GH0.tar.gz) = 274053
+SHA256 (fluffle-goirc-v1.0.1_GH0.tar.gz) = 05e1d03714c827dc88b4d04bb9380d37dc2d83f350dcee015fe8d4f1ba24493b
+SIZE (fluffle-goirc-v1.0.1_GH0.tar.gz) = 141321
+SHA256 (fsnotify-fsnotify-v1.4.7_GH0.tar.gz) = b7530d973d0ab0e58ad8ce1b9a4b963d6f57b3d72f2f9e13d49846976361b1cd
+SIZE (fsnotify-fsnotify-v1.4.7_GH0.tar.gz) = 31139
+SHA256 (garyburd-go-oauth-bca2e7f09a17_GH0.tar.gz) = 82b63ce1e960622c0683787cefef0626cf45696de2da91f5be080e56ec388f63
+SIZE (garyburd-go-oauth-bca2e7f09a17_GH0.tar.gz) = 20259
+SHA256 (gigawattio-window-0f5467e35573_GH0.tar.gz) = 380cc35f687803dc989d934cd8c1f05ddc4cdd508e4c8fe29677931727f92807
+SIZE (gigawattio-window-0f5467e35573_GH0.tar.gz) = 2422
+SHA256 (glaxx-go_pastebin-7e72d56770d0_GH0.tar.gz) = 357665343104ed49c5d3e842d11dfb780b447da4317ec249ec62ec2d5d291456
+SIZE (glaxx-go_pastebin-7e72d56770d0_GH0.tar.gz) = 15282
+SHA256 (go-ini-ini-v1.42.0_GH0.tar.gz) = 49136717e5db9000e02f86807cfd9faa98f943553a3c40319020b7c32e7c142c
+SIZE (go-ini-ini-v1.42.0_GH0.tar.gz) = 35078
+SHA256 (go-mail-mail-v2.3.1_GH0.tar.gz) = 264a42278757b9153338e618b2c98109d88f8ae8599a804f291e17bba9bb8969
+SIZE (go-mail-mail-v2.3.1_GH0.tar.gz) = 19878
+SHA256 (go-telegram-bot-api-telegram-bot-api-v4.6.4_GH0.tar.gz) = bfdb23fda6da247305164d206c95532e1a0b0537a621ad337f74798852a81958
+SIZE (go-telegram-bot-api-telegram-bot-api-v4.6.4_GH0.tar.gz) = 2076453
+SHA256 (golang-appengine-v1.5.0_GH0.tar.gz) = 0de9d0a9882054e319bf7608b6ede31a6d3005ccd3efecd85b936d4b82cbd6b1
+SIZE (golang-appengine-v1.5.0_GH0.tar.gz) = 325873
+SHA256 (golang-crypto-a29dc8fdc734_GH0.tar.gz) = 1679d2cf8fa91599635b8a9d6658feefdacfe25d25c968e63328323eb5f55923
+SIZE (golang-crypto-a29dc8fdc734_GH0.tar.gz) = 1679918
+SHA256 (golang-mock-v1.2.0_GH0.tar.gz) = b7278e2d81b4ea2b849da7a20aedafd627748e188b2118bb536b8a2e3b95a821
+SIZE (golang-mock-v1.2.0_GH0.tar.gz) = 46488
+SHA256 (golang-net-9ce7a6920f09_GH0.tar.gz) = 473a5eed183f65723358eabf8e4f692dc6067f67b0061daa8d83a34e6fb9f728
+SIZE (golang-net-9ce7a6920f09_GH0.tar.gz) = 1098880
+SHA256 (golang-oauth2-9f3314589c9a_GH0.tar.gz) = daa93a9035722a6549aad86e440fa1b3b80461f215e2f001c68342e7c05b8ffe
+SIZE (golang-oauth2-9f3314589c9a_GH0.tar.gz) = 45034
+SHA256 (golang-protobuf-v1.3.1_GH0.tar.gz) = 3f3a6123054a9847093c119895f1660612f301fe95358f3a6a1a33fd0933e6cf
+SIZE (golang-protobuf-v1.3.1_GH0.tar.gz) = 310884
+SHA256 (golang-sys-d89cdac9e872_GH0.tar.gz) = 527dec46c884a6a018025fac8afa5560cf8d80fd46c067e29dfb3d429262da62
+SIZE (golang-sys-d89cdac9e872_GH0.tar.gz) = 1384004
+SHA256 (golang-text-v0.3.2_GH0.tar.gz) = 0b9309698f5708531c5377ab1e29b423a6d9e20c55a8d386c3b8283428212f22
+SIZE (golang-text-v0.3.2_GH0.tar.gz) = 7168069
+SHA256 (google-go-github-v17.0.0_GH0.tar.gz) = 75e6007d9a17b91864d1ef83de75c07abafbe05d82caaf140522b94299abfb16
+SIZE (google-go-github-v17.0.0_GH0.tar.gz) = 212084
+SHA256 (google-go-querystring-v1.0.0_GH0.tar.gz) = 59fdfd4d740c85c60c35d3e09b587cfa2b435e78178ac4a23950afbece7118ed
+SIZE (google-go-querystring-v1.0.0_GH0.tar.gz) = 7529
+SHA256 (gorilla-websocket-v1.4.0_GH0.tar.gz) = 2b5743c72bd0930c5a80e49c0138b5b7d27fa7c085efd0c86805cccfa7220c9d
+SIZE (gorilla-websocket-v1.4.0_GH0.tar.gz) = 50228
+SHA256 (guelfey-go.dbus-f6a3a2366cc3_GH0.tar.gz) = 96fb416626cef227da5bce965aab2298e3fd4896346fb16a76e0454ff346a62c
+SIZE (guelfey-go.dbus-f6a3a2366cc3_GH0.tar.gz) = 37286
+SHA256 (huandu-facebook-v2.3.1_GH0.tar.gz) = 69b36add3d9084f74bd87639e9cebd2fc6e94016d0272bcac8e393fcdca24a3a
+SIZE (huandu-facebook-v2.3.1_GH0.tar.gz) = 40819
+SHA256 (jacobsa-go-serial-15cf729a72d4_GH0.tar.gz) = 01fd5ef8eb5fd5a6b1304f99e2d8ef94218733569646a733a091e91c8f417909
+SIZE (jacobsa-go-serial-15cf729a72d4_GH0.tar.gz) = 14214
+SHA256 (jayeshsolanki93-devgorant-69fb03e5c3b1_GH0.tar.gz) = 82d0b543fcb8278535402450f9cb65d7af233a7c8178ef81ffd79de678019e63
+SIZE (jayeshsolanki93-devgorant-69fb03e5c3b1_GH0.tar.gz) = 3572
+SHA256 (jaytaylor-html2text-01ec452cbe43_GH0.tar.gz) = 4132a677ad55a82d24cf7f5422a227bce85044c08ab9ca6be0fd14551a7ee345
+SIZE (jaytaylor-html2text-01ec452cbe43_GH0.tar.gz) = 15152
+SHA256 (json-iterator-go-v1.1.6_GH0.tar.gz) = fc04b16a3d3798aca44e644d85c1cf5a10faf294ed69a9f44ca57c6dfa6856e2
+SIZE (json-iterator-go-v1.1.6_GH0.tar.gz) = 76814
+SHA256 (konsorten-go-windows-terminal-sequences-v1.0.2_GH0.tar.gz) = e61f6422c7d1222c4c642b9134e5a4576a89ff651ef947487faa8ef33b6b4cfe
+SIZE (konsorten-go-windows-terminal-sequences-v1.0.2_GH0.tar.gz) = 1987
+SHA256 (kr-pretty-v0.1.0_GH0.tar.gz) = 3aeb5d90b719765781befb9f156d0d0b8e5a7aafbcf15321e9eabbd35df31358
+SIZE (kr-pretty-v0.1.0_GH0.tar.gz) = 8550
+SHA256 (kr-text-v0.1.0_GH0.tar.gz) = b67f2744020b25f9298153af0992db252d195edd7ca5afa3b19d6ac300c2d14e
+SIZE (kr-text-v0.1.0_GH0.tar.gz) = 8686
+SHA256 (kurrik-oauth1a-cb1b80e32dd4_GH0.tar.gz) = 4b3e06ec43ed7247b9908267f911bcbce226e6fb128caa9f3bf23c86ec19f9c7
+SIZE (kurrik-oauth1a-cb1b80e32dd4_GH0.tar.gz) = 11680
+SHA256 (mattn-go-colorable-v0.1.1_GH0.tar.gz) = 41773345d2a1037a37942b96e04a8ed5248f19a8f43a7ba26aa16a7b74132647
+SIZE (mattn-go-colorable-v0.1.1_GH0.tar.gz) = 8518
+SHA256 (mattn-go-isatty-v0.0.7_GH0.tar.gz) = 80b6b3e4fee3b15864f23d622129c17ba222786f8c93bb01f8805f3cb91dfefe
+SIZE (mattn-go-isatty-v0.0.7_GH0.tar.gz) = 3559
+SHA256 (mattn-go-mastodon-v0.0.3_GH0.tar.gz) = 4ce79e2d4ab780adad4c4e91dd9850d4c704fcbb22ecd05e4d18097e847fe477
+SIZE (mattn-go-mastodon-v0.0.3_GH0.tar.gz) = 31944
+SHA256 (mattn-go-runewidth-v0.0.4_GH0.tar.gz) = 1973c2de25bc69c3786a00e8118f4d22aa0d040bdfe46c8c8c30419b23e53dfe
+SIZE (mattn-go-runewidth-v0.0.4_GH0.tar.gz) = 19827
+SHA256 (mattn-go-xmpp-6093f50721ed_GH0.tar.gz) = f533bb7a02d1267b59a242fb4755429b4e80b7916ff071df69bca35b7befaf3a
+SIZE (mattn-go-xmpp-6093f50721ed_GH0.tar.gz) = 12978
+SHA256 (matttproud-golang_protobuf_extensions-v1.0.1_GH0.tar.gz) = 2def0ee6f6b12b1efc0e3007d89f598608a072610e805c3655ea9d13c3ead49b
+SIZE (matttproud-golang_protobuf_extensions-v1.0.1_GH0.tar.gz) = 37184
+SHA256 (minio-minio-go-v6.0.14_GH0.tar.gz) = 31afb66245c0007a3de62782e06d33a53ae629f74dd208d8389beee99fcc67bb
+SIZE (minio-minio-go-v6.0.14_GH0.tar.gz) = 187961
+SHA256 (mitchellh-go-homedir-v1.1.0_GH0.tar.gz) = 646671c73a84a8dfb4a5a76b80c7b63549ffefa906524d45077301bc7da76600
+SIZE (mitchellh-go-homedir-v1.1.0_GH0.tar.gz) = 3362
+SHA256 (modern-go-concurrent-bacd9c7ef1dd_GH0.tar.gz) = d673e902118a6ece63198dc7e0961e904d0410f142726df0936ec1a52035a60f
+SIZE (modern-go-concurrent-bacd9c7ef1dd_GH0.tar.gz) = 7526
+SHA256 (modern-go-reflect2-v1.0.1_GH0.tar.gz) = d24e856d9aa8fd51b9e6c2cdd712a44c8d18cb8b72802f1bd16e0470322363fd
+SIZE (modern-go-reflect2-v1.0.1_GH0.tar.gz) = 14394
+SHA256 (mreiferson-go-httpclient-31f0106b4474_GH0.tar.gz) = 1c6976771c5d8f8fff89cd0f8dd829a29c69851e2340aac241621782a9971401
+SIZE (mreiferson-go-httpclient-31f0106b4474_GH0.tar.gz) = 4914
+SHA256 (mrexodia-wray-78a2c1f284ff_GH0.tar.gz) = f3cc34022e5d7f0ac3e0cd6ba639b716103fffb6b88b9645954b9bcd5e71c802
+SIZE (mrexodia-wray-78a2c1f284ff_GH0.tar.gz) = 8006
+SHA256 (muesli-go-pkg-rss-3bef0f3126ec_GH0.tar.gz) = 4e50b925af5418261523db12f2e84200d0d765c1a96654ddd1b497bda5620340
+SIZE (muesli-go-pkg-rss-3bef0f3126ec_GH0.tar.gz) = 63232
+SHA256 (muesli-go-pkg-xmlx-76f54ee73233_GH0.tar.gz) = 1349daf0d11b3df1945029e50508157e2c21e30c9ae8d409de480aea2b73efcd
+SIZE (muesli-go-pkg-xmlx-76f54ee73233_GH0.tar.gz) = 14579
+SHA256 (muesli-go.hue-8aefcc693caf_GH0.tar.gz) = 9a0be01e2a1f7058e5eb274dc8d0744cc724023d8ee78851e48e5ef37e332951
+SIZE (muesli-go.hue-8aefcc693caf_GH0.tar.gz) = 5749
+SHA256 (muesli-goefa-08d8ee2555d2_GH0.tar.gz) = b0d19da1cfadd612d95bf12bb205cfa0c0564ddd302469c46a09cd30d13e7c86
+SIZE (muesli-goefa-08d8ee2555d2_GH0.tar.gz) = 80012
+SHA256 (muesli-smolder-9c21fc7135ee_GH0.tar.gz) = 72af95884db64ce1d6bad8489aaeca05cc990701ddfa57055f780ba8df40be71
+SIZE (muesli-smolder-9c21fc7135ee_GH0.tar.gz) = 17938
+SHA256 (nlopes-slack-v0.5.0_GH0.tar.gz) = 01e91b5eb1686fdcb7e7985c82d339529ab03cbc8f950845ae379fcd4e905d89
+SIZE (nlopes-slack-v0.5.0_GH0.tar.gz) = 157460
+SHA256 (nu7hatch-gouuid-179d4d0c4d8d_GH0.tar.gz) = 2ead616e5bb23c0c669a1485cb45f083d8d6752acc5faa5f668521b7e99ec2e1
+SIZE (nu7hatch-gouuid-179d4d0c4d8d_GH0.tar.gz) = 3733
+SHA256 (odwrtw-transmission-08885b3058e7_GH0.tar.gz) = a6db85530700897623cf0f61aa0af3a36419014fd757863c36f10b7812fdf4d5
+SIZE (odwrtw-transmission-08885b3058e7_GH0.tar.gz) = 7394
+SHA256 (olekukonko-tablewriter-v0.0.1_GH0.tar.gz) = d9d620f0bcd58953a44b514042caa378b8256a692bcc8c0842e8aeac5a87db89
+SIZE (olekukonko-tablewriter-v0.0.1_GH0.tar.gz) = 17505
+SHA256 (pkg-errors-v0.8.1_GH0.tar.gz) = 7a428967c6fc2e80cd84a0d9469ab6bd4dbe6b13493ba6294322a933a5a7e356
+SIZE (pkg-errors-v0.8.1_GH0.tar.gz) = 11009
+SHA256 (pmezard-go-difflib-v1.0.0_GH0.tar.gz) = 28f3dc1b5c0efd61203ab07233f774740d3bf08da4d8153fb5310db6cea0ebda
+SIZE (pmezard-go-difflib-v1.0.0_GH0.tar.gz) = 11398
+SHA256 (prometheus-client_golang-v0.9.2_GH0.tar.gz) = 5f6ca8740a08622ae0a19c32b1026b8233bfd943a1f4af34963d326ab5fa94e5
+SIZE (prometheus-client_golang-v0.9.2_GH0.tar.gz) = 130109
+SHA256 (prometheus-client_model-5c3871d89910_GH0.tar.gz) = c2d914392672f3fb66186cfbb5f5ae1a892fb91088475cc567a1bb17057cb5f9
+SIZE (prometheus-client_model-5c3871d89910_GH0.tar.gz) = 57136
+SHA256 (prometheus-common-4724e9255275_GH0.tar.gz) = fae0d9a77593fbc9c77b30beb9f6a7d68c99eee0a3526c39cd6a0e07e435877a
+SIZE (prometheus-common-4724e9255275_GH0.tar.gz) = 80877
+SHA256 (prometheus-procfs-1dc9a6cbc91a_GH0.tar.gz) = 99d89f51f06c8d5d19be441b17c3c4001fa34dfeaa9495b81335d208cea23181
+SIZE (prometheus-procfs-1dc9a6cbc91a_GH0.tar.gz) = 61589
+SHA256 (rogpeppe-go-charset-2471d30d28b4_GH0.tar.gz) = 5e2d9e452df4902ad6269f176084abd5724dbb82feb8bedd057d3fb2c09e9cef
+SIZE (rogpeppe-go-charset-2471d30d28b4_GH0.tar.gz) = 120499
+SHA256 (shuheiktgw-go-travis-2d0b3e9898f0_GH0.tar.gz) = f6032145632753165b7a4b6ca0759048f47fe2b7e2087cb212528a2ea87624de
+SIZE (shuheiktgw-go-travis-2d0b3e9898f0_GH0.tar.gz) = 35115
+SHA256 (simplepush-simplepush-go-8980e96b7b02_GH0.tar.gz) = 9d14deaf719db67974cbcd79e361547e10f6e73518a58f52f2078a595ace13ab
+SIZE (simplepush-simplepush-go-8980e96b7b02_GH0.tar.gz) = 14928
+SHA256 (sirupsen-logrus-v1.4.1_GH0.tar.gz) = aecd75cfc00edfc8d8bdb013d2cee2a5da686fce31c5cf2ae314ce4642c8e139
+SIZE (sirupsen-logrus-v1.4.1_GH0.tar.gz) = 40811
+SHA256 (sromku-go-gitter-70f7030a94a6_GH0.tar.gz) = 52d02841b1f85961b5470164b11eac8b2e9728d7d2ca1dea2b57289121c5cc3f
+SIZE (sromku-go-gitter-70f7030a94a6_GH0.tar.gz) = 11883
+SHA256 (ssor-bom-6386211fdfcf_GH0.tar.gz) = 6e05adf64dd2846fa27f0e89038171600806529d3f0df3ef50edb42304399336
+SIZE (ssor-bom-6386211fdfcf_GH0.tar.gz) = 1802
+SHA256 (stretchr-objx-v0.2.0_GH0.tar.gz) = be7dce02798cdc24cee6bd2d95bfcf6976b1521ef735349bf5e7dfe6d147746f
+SIZE (stretchr-objx-v0.2.0_GH0.tar.gz) = 79981
+SHA256 (stretchr-testify-v1.3.0_GH0.tar.gz) = 0cd9c199a72b8d80621624b37c0ed5ac724352d458506a31dfa86710551e7fc5
+SIZE (stretchr-testify-v1.3.0_GH0.tar.gz) = 102859
+SHA256 (technoweenie-multipartstreamer-v1.0.1_GH0.tar.gz) = 9247a9071eb90653e2b70efd6abd9bffbe7498b238c0f06d62d8b5096f7c31e6
+SIZE (technoweenie-multipartstreamer-v1.0.1_GH0.tar.gz) = 3246
+SHA256 (tomnomnom-linkheader-02ca5825eb80_GH0.tar.gz) = 0905f5752137e019e22d2f0c6493ae969ad2cc944ceef58c2085a948c9c99e9d
+SIZE (tomnomnom-linkheader-02ca5825eb80_GH0.tar.gz) = 4318
+SHA256 (layeh-gumble-1ea1159c4956_GH0.tar.gz) = 73614267f7fcc41ca705d0fcaddc0e67fa9fba7fe02cd9ffb5080488939fb39e
+SIZE (layeh-gumble-1ea1159c4956_GH0.tar.gz) = 143296
+SHA256 (muesli-beehive-admin-dist-648f36d9834d_GH0.tar.gz) = c6285fbac7d37f22b9f5685986364c5807e74d7fca1d043c5072e90511f39019
+SIZE (muesli-beehive-admin-dist-648f36d9834d_GH0.tar.gz) = 439849
diff --git a/www/beehive/pkg-descr b/www/beehive/pkg-descr
new file mode 100644
index 000000000000..56a9698df790
--- /dev/null
+++ b/www/beehive/pkg-descr
@@ -0,0 +1,9 @@
+Event and agent system, which allows you to create your own agents that perform
+automated tasks triggered by events and filters.
+
+It is modular, flexible and really easy to extend for anyone. It has modules
+(we call them Hives), so it can interface with, talk to, or retrieve
+information from Twitter, Tumblr, Email, IRC, Jabber, RSS, Jenkins, Hue - to
+name just a few.
+
+WWW: https://github.com/muesli/beehive