aboutsummaryrefslogtreecommitdiff
path: root/www/bk2site
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2002-09-02 17:21:05 +0000
committerClive Lin <clive@FreeBSD.org>2002-09-02 17:21:05 +0000
commit4211e9b814a41cc0d5ac73e8bb01ba96f8fcc16c (patch)
tree4f867d50a144b15fde922e9a891acd3f0d3c68bc /www/bk2site
parentb10818906fcf3d65648ceb11b5992d2bcf992fbe (diff)
downloadports-4211e9b814a41cc0d5ac73e8bb01ba96f8fcc16c.tar.gz
ports-4211e9b814a41cc0d5ac73e8bb01ba96f8fcc16c.zip
Unbreak this port on -CURRENT.
Notes
Notes: svn path=/head/; revision=65500
Diffstat (limited to 'www/bk2site')
-rw-r--r--www/bk2site/Makefile1
-rw-r--r--www/bk2site/files/patch-iwebstream.C22
-rw-r--r--www/bk2site/files/patch-reference.C35
3 files changed, 58 insertions, 0 deletions
diff --git a/www/bk2site/Makefile b/www/bk2site/Makefile
index aea102380356..bf98cb15e147 100644
--- a/www/bk2site/Makefile
+++ b/www/bk2site/Makefile
@@ -38,6 +38,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --enable-standard-datadir
+CONFIGURE_ENV= CPPFLAGS=-Wno-deprecated
PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}"
diff --git a/www/bk2site/files/patch-iwebstream.C b/www/bk2site/files/patch-iwebstream.C
new file mode 100644
index 000000000000..2b9fbe5f36e1
--- /dev/null
+++ b/www/bk2site/files/patch-iwebstream.C
@@ -0,0 +1,22 @@
+--- iwebstream.C~ Tue Sep 3 01:05:42 2002
++++ iwebstream.C Tue Sep 3 01:08:08 2002
+@@ -33,7 +33,7 @@
+ //#define DEBUG_TIMEOUT
+
+ // The constructor.
+-iwebstream::iwebstream(string url, int timeout = 30) : defaultTimeout(timeout), data(""), position(0) {
++iwebstream::iwebstream(string url, int timeout) : defaultTimeout(timeout), data(""), position(0) {
+ string origurl = url;
+ string method;
+ string host;
+@@ -424,8 +424,8 @@
+ // Case is ignored in comparisions.
+ // If begin is not found, return "". Move position to point to char after end;
+ // If end == "" then just find begin and place position just after it
+-string iwebstream::findTag(const string & begin, const string & end, const string & after = "",
+- const string & before = "") {
++string iwebstream::findTag(const string & begin, const string & end, const string & after,
++ const string & before) {
+ // cout << "findTag begin=" << begin << "=" << endl
+ // << "end=" << end << "=" << endl
+ // << "after=" << after << "=" << endl
diff --git a/www/bk2site/files/patch-reference.C b/www/bk2site/files/patch-reference.C
new file mode 100644
index 000000000000..97cc0ee28551
--- /dev/null
+++ b/www/bk2site/files/patch-reference.C
@@ -0,0 +1,35 @@
+--- reference.C~ Tue Sep 3 01:02:48 2002
++++ reference.C Tue Sep 3 01:04:14 2002
+@@ -1189,7 +1189,7 @@
+
+ The hard work is done by FolderCommentParser
+ */
+-void referenceTree::fixCommentCommands(const string parentFolderHTML = ""){
++void referenceTree::fixCommentCommands(const string parentFolderHTML){
+ for (vector<reference>::iterator i = contents.begin(); i != contents.end(); ++i){
+ reference& r = *i;
+ replaceAll(r.comment,"&lt;","<");
+@@ -1398,7 +1398,7 @@
+ returns the number of elements added.
+ Only adds URLS that are not Private and not Aliasof another one and
+ are not under avoidFolder. */
+-void referenceTree::makeVector(vector<reference> & vr, const string & avoidFolder = "")
++void referenceTree::makeVector(vector<reference> & vr, const string & avoidFolder)
+ {
+ for (vector<reference>::iterator i = contents.begin(); i != contents.end(); ++i){
+ reference & r = *i;
+@@ -1466,10 +1466,10 @@
+ void referenceTree::createSiteH(const string varValues[], vector<reference> & allReferences,
+ channelContainer & channels,
+ fileView & baseView, fileView & otherView,
+- vector<reference> & newsItems, int depth = 0,
+- string navigateBar = "", string searchNavBar = "",
+- string parentTitle = "", string folderTitle="",
+- string filePath = "") {
++ vector<reference> & newsItems, int depth,
++ string navigateBar, string searchNavBar,
++ string parentTitle, string folderTitle,
++ string filePath ) {
+ string ofileName;
+ fileView & fv = baseView;
+ string fileContents;