aboutsummaryrefslogtreecommitdiff
path: root/www/bk_edit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-26 06:18:14 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-26 06:18:14 +0000
commitd7e45701d1f31666398aa468d835ba587c5cc443 (patch)
treebdd93d28aeaa519980a14f5c4e8a7375edbff57d /www/bk_edit
parent2379d6173bd82e685687e12e0ad5a1b61b98774f (diff)
downloadports-d7e45701d1f31666398aa468d835ba587c5cc443.tar.gz
ports-d7e45701d1f31666398aa468d835ba587c5cc443.zip
add bk_edit 0.6.23
Bookmark Editor
Notes
Notes: svn path=/head/; revision=96611
Diffstat (limited to 'www/bk_edit')
-rw-r--r--www/bk_edit/Makefile22
-rw-r--r--www/bk_edit/distinfo1
-rw-r--r--www/bk_edit/files/patch-configure21
-rw-r--r--www/bk_edit/files/patch-src:Makefile.in27
-rw-r--r--www/bk_edit/files/patch-src:config.h.in11
-rw-r--r--www/bk_edit/pkg-descr17
-rw-r--r--www/bk_edit/pkg-plist13
7 files changed, 112 insertions, 0 deletions
diff --git a/www/bk_edit/Makefile b/www/bk_edit/Makefile
new file mode 100644
index 000000000000..0bf6fe7c9ef4
--- /dev/null
+++ b/www/bk_edit/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# Ports collection makefile for: bk_edit
+# Date created: Dec 26, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= bk_edit
+PORTVERSION= 0.6.23
+CATEGORIES= www
+MASTER_SITES= http://www2.fht-esslingen.de/~clfuit00/sasnt/packages/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Bookmark Editor
+
+USE_BISON= yes
+USE_GETOPT_LONG= yes
+USE_GNOME= gtk12 libxml2
+HAS_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/bk_edit/distinfo b/www/bk_edit/distinfo
new file mode 100644
index 000000000000..d734fee782e9
--- /dev/null
+++ b/www/bk_edit/distinfo
@@ -0,0 +1 @@
+MD5 (bk_edit-0.6.23.tar.gz) = 75d753de003b87ca85f71e652ca4d759
diff --git a/www/bk_edit/files/patch-configure b/www/bk_edit/files/patch-configure
new file mode 100644
index 000000000000..47e4882eb74e
--- /dev/null
+++ b/www/bk_edit/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig Fri Dec 26 14:03:40 2003
++++ configure Fri Dec 26 14:04:19 2003
+@@ -51,7 +51,7 @@
+
+ exit 1
+ fi
+-echo "install path: $INSTALL_DIR/bin/ & $INSTALL_DIR/share/bkedit/"
++echo "install path: $INSTALL_DIR/bin/ & $INSTALL_DIR/lib/bkedit/"
+
+
+
+@@ -64,9 +64,6 @@
+ ;;
+ SunOS)
+ LIB='-ldl'
+- ;;
+- FreeBSD)
+- LIB='-lgnugetopt'
+ ;;
+ esac
+ echo "$OS"
diff --git a/www/bk_edit/files/patch-src:Makefile.in b/www/bk_edit/files/patch-src:Makefile.in
new file mode 100644
index 000000000000..55a8c343c0bb
--- /dev/null
+++ b/www/bk_edit/files/patch-src:Makefile.in
@@ -0,0 +1,27 @@
+--- src/Makefile.in.orig Sat Nov 29 21:14:14 2003
++++ src/Makefile.in Fri Dec 26 14:08:00 2003
+@@ -1,10 +1,10 @@
+ PROG = bkedit#
+
+-CC = gcc
++#CC = gcc
+ LD = gcc
+
+-CFLAGS = -Wall `@GTK_CONFIG@ --cflags` `@XML2_CONFIG@ --cflags`#-ggdb -pg -a
+-LDFLAGS = @LIB@ `@GTK_CONFIG@ --libs` `@XML2_CONFIG@ --libs` -Wl,-export-dynamic# -rdynamic 'reverse dependencies' # -pg
++CFLAGS += -Wall `@GTK_CONFIG@ --cflags` `@XML2_CONFIG@ --cflags`#-ggdb -pg -a
++LDFLAGS += @LIB@ `@GTK_CONFIG@ --libs` `@XML2_CONFIG@ --libs` -Wl,-export-dynamic# -rdynamic 'reverse dependencies' # -pg
+
+ OBJS = bk_edit.o bk_edit_menu.o bk_edit_tree.o bk_edit_edit.o bk_edit_file.o \
+ bk_edit_ccp.o bk_edit_data.o bk_edit_undo.o bk_edit_dnd.o bk_edit_misc.o \
+@@ -31,8 +31,8 @@
+ install:
+ $(INSTALL) -d -m 755 @PREFIX@/bin/
+ $(INSTALL) -m 755 $(PROG) @PREFIX@/bin/
+- $(INSTALL) -d -m 755 @PREFIX@/share/bkedit/
+- $(INSTALL) -m 755 ./plugins/*.so @PREFIX@/share/bkedit/
++ $(INSTALL) -d -m 755 @PREFIX@/lib/bkedit/
++ $(INSTALL) -m 755 ./plugins/*.so @PREFIX@/lib/bkedit/
+
+ uninstall:
+ $(RM) @PREFIX@/bin/$(PROG)
diff --git a/www/bk_edit/files/patch-src:config.h.in b/www/bk_edit/files/patch-src:config.h.in
new file mode 100644
index 000000000000..3080990e96d3
--- /dev/null
+++ b/www/bk_edit/files/patch-src:config.h.in
@@ -0,0 +1,11 @@
+--- src/config.h.in.orig Fri Dec 26 14:04:52 2003
++++ src/config.h.in Fri Dec 26 14:05:09 2003
+@@ -7,7 +7,7 @@
+
+ #define BK_EDIT_VERSION "v@VERSION@"
+
+-#define BK_EDIT_PLUGIN_PATH "@PREFIX@/share/bkedit/*.so"
++#define BK_EDIT_PLUGIN_PATH "@PREFIX@/lib/bkedit/*.so"
+
+ #define BK_EDIT_LICENSE "This program is free software; you can redistribute it and/or modify\n" \
+ "it under the terms of the GNU General Public License as published\n" \
diff --git a/www/bk_edit/pkg-descr b/www/bk_edit/pkg-descr
new file mode 100644
index 000000000000..01d14feaa0ae
--- /dev/null
+++ b/www/bk_edit/pkg-descr
@@ -0,0 +1,17 @@
+bk_edit is an easy to use bookmark manager and editor. The program can read,
+write, edit, create, manage and convert the bookmarks of the most popular
+browsers. There is also a simple Drag & Drop interface for adding new
+bookmarks from a running browser in a very comfortable way. At the moment
+there are plugins for the following browsers and tools:
+ * SiteBar
+ * Links 2.1
+ * XBEL 1.0
+ * Opera 6, 7
+ * Galeon 1.2.5
+ * WikiLinks Export
+ * Netscape Navigator 3, 4. 6
+ * Mozilla 1.0, 1.1, 1.2, 1.3, 1.4
+ * Phoenix 0.5+ (Drag & Drop only)
+ * Konqueror 3+ (Drag & Drop only)
+
+WWW: http://www2.fht-esslingen.de/~clfuit00/sasnt/bk_edit/
diff --git a/www/bk_edit/pkg-plist b/www/bk_edit/pkg-plist
new file mode 100644
index 000000000000..6ed85f936ee3
--- /dev/null
+++ b/www/bk_edit/pkg-plist
@@ -0,0 +1,13 @@
+bin/bkedit
+lib/bkedit/all_edit.so
+lib/bkedit/galeon.so
+lib/bkedit/html.so
+lib/bkedit/links2.so
+lib/bkedit/moz.so
+lib/bkedit/nn4.so
+lib/bkedit/opera.so
+lib/bkedit/opera7.so
+lib/bkedit/sitebar.so
+lib/bkedit/wikilinks.so
+lib/bkedit/xbel.so
+@dirrm lib/bkedit