aboutsummaryrefslogtreecommitdiff
path: root/www/cakephp11
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-09 18:03:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-09 18:03:21 +0000
commit0561b556edb4968a77a112bdce8ab467f844155f (patch)
treeda1c3b525f916893c26e5720d779b38d6f92de41 /www/cakephp11
parenta93e04a3ae7a5e1604eb91334865f5cc1a488a5e (diff)
downloadports-0561b556edb4968a77a112bdce8ab467f844155f.tar.gz
ports-0561b556edb4968a77a112bdce8ab467f844155f.zip
The use of "find ... -print0/xargs -0 ..." is faster than
"find ... -print/xargs -n1 ...", so use that here to fix file and directory permissions after installation. PR: 114445 Submitted by: Greg Larkin <glarkin@sourcehosting.net> (maintainer)
Notes
Notes: svn path=/head/; revision=195317
Diffstat (limited to 'www/cakephp11')
-rw-r--r--www/cakephp11/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/cakephp11/Makefile b/www/cakephp11/Makefile
index 978fe8b474eb..3f229ae9df28 100644
--- a/www/cakephp11/Makefile
+++ b/www/cakephp11/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cakephp
PORTVERSION= 1.1.15.5144
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://cakeforge.org/frs/download.php/410/
DISTNAME= cake_${PORTVERSION}
@@ -115,8 +116,8 @@ do-install:
${WRKSRC}/index.php \
${WRKSRC}/vendors ${WWWDIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- ${FIND} ${WWWDIR} -type f -print | ${XARGS} -n1 ${CHMOD} 644
- ${FIND} ${WWWDIR} -type d -print | ${XARGS} -n1 ${CHMOD} 755
+ ${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ ${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
post-install:
@if [ -d "${CONFDIR}" ]; then \