aboutsummaryrefslogtreecommitdiff
path: root/www/castget/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-02-16 01:24:35 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-02-16 01:24:35 +0000
commit125bf96e4b80013b3ddb6451811f9cb048ad58f0 (patch)
tree5d67e8614c613532b191d5b4bc8c11c6edaeb871 /www/castget/Makefile
parent0a6e7b1a67874324382e743f9c3bba7dd968a678 (diff)
downloadports-125bf96e4b80013b3ddb6451811f9cb048ad58f0.tar.gz
ports-125bf96e4b80013b3ddb6451811f9cb048ad58f0.zip
Add port www/castget:
castget is a simple, command-line based RSS enclosure downloader. It is primarily intended for automatic, unattended downloading of podcasts. * Simple configuration. * Per-channel tagging of downloaded MP3 files using ID3v2. * Per-channel download directories. * Supports all RSS versions and Media RSS. WWW: http://www.nongnu.org/castget/
Notes
Notes: svn path=/head/; revision=185269
Diffstat (limited to 'www/castget/Makefile')
-rw-r--r--www/castget/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/castget/Makefile b/www/castget/Makefile
new file mode 100644
index 000000000000..f7fe50f1fbb1
--- /dev/null
+++ b/www/castget/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: castget
+# Date created: 16 February 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= castget
+PORTVERSION= 0.9.6
+CATEGORIES= www
+MASTER_SITES= SAVANNAH CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Command-line podcast downloader
+
+LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
+ curl.4:${PORTSDIR}/ftp/curl
+
+USE_LDCONFIG= yes
+USE_GNOME= glib20 libxml2
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --disable-static
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/castget include/libcastget.h lib/libcastget.la lib/libcastget.so lib/libcastget.so.0
+MAN1= castget.1
+MAN5= castgetrc.5
+
+.include <bsd.port.mk>