aboutsummaryrefslogtreecommitdiff
path: root/www/castget/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-14 09:03:50 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-14 09:03:50 +0000
commit92c78034188d924f379a79f8ac0354f9d91bd74d (patch)
tree4cb29c52b6921ae6c2fcfd948d11c9a42bd6b928 /www/castget/Makefile
parent3747202b888fe262f7b9e5105351880ccbc3a95f (diff)
downloadports-92c78034188d924f379a79f8ac0354f9d91bd74d.tar.gz
ports-92c78034188d924f379a79f8ac0354f9d91bd74d.zip
www/castget: fix build on GCC architectures
Compiling against id3lib now requires newer GCC: configure: error: Required library id3lib not found
Notes
Notes: svn path=/head/; revision=531661
Diffstat (limited to 'www/castget/Makefile')
-rw-r--r--www/castget/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/www/castget/Makefile b/www/castget/Makefile
index 6e44ef60e7a2..9b5f6eb958e7 100644
--- a/www/castget/Makefile
+++ b/www/castget/Makefile
@@ -15,11 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LIB
LIB_DEPENDS= libid3.so:audio/id3lib \
libcurl.so:ftp/curl
+USES= compiler:c11 gnome libtool localbase:ldflags pkgconfig tar:bzip2
USE_LDCONFIG= yes
-USES= gnome libtool pkgconfig tar:bzip2
USE_GNOME= glib20 libxml2
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
# CONFIGURE_ARGS= --disable-static
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip