aboutsummaryrefslogtreecommitdiff
path: root/www/caudium14
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-07-06 15:32:06 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-07-06 15:32:06 +0000
commit95275cebf5c8df9d60be55e7e2dc14b7453918a7 (patch)
tree78968f300d093daa9f0d74600bd0d2bf949850b4 /www/caudium14
parentd3b3b80a46c879d5839e59d7ee6237e217194af0 (diff)
downloadports-95275cebf5c8df9d60be55e7e2dc14b7453918a7.tar.gz
ports-95275cebf5c8df9d60be55e7e2dc14b7453918a7.zip
Fix build
Notes
Notes: svn path=/head/; revision=360925
Diffstat (limited to 'www/caudium14')
-rw-r--r--www/caudium14/Makefile2
-rw-r--r--www/caudium14/files/patch-src_cmods__Caudium_nb_send.c11
2 files changed, 11 insertions, 2 deletions
diff --git a/www/caudium14/Makefile b/www/caudium14/Makefile
index b8d1d3138724..0389af96a7f5 100644
--- a/www/caudium14/Makefile
+++ b/www/caudium14/Makefile
@@ -11,8 +11,6 @@ DISTNAME= Caudium-${DISTVERSION}
MAINTAINER= johans@FreeBSD.org
COMMENT= Free webserver based on the Roxen Challenger 1.3 code base
-BROKEN= Fails to compile
-
BUILD_DEPENDS= pike78:${PORTSDIR}/lang/pike78
LIB_DEPENDS= libsablot.so:${PORTSDIR}/textproc/sablotron
RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
diff --git a/www/caudium14/files/patch-src_cmods__Caudium_nb_send.c b/www/caudium14/files/patch-src_cmods__Caudium_nb_send.c
new file mode 100644
index 000000000000..019d4a376c02
--- /dev/null
+++ b/www/caudium14/files/patch-src_cmods__Caudium_nb_send.c
@@ -0,0 +1,11 @@
+--- src/cmods/_Caudium/nb_send.c.orig 2014-07-06 17:29:43.000000000 +0200
++++ src/cmods/_Caudium/nb_send.c 2014-07-06 17:29:21.000000000 +0200
+@@ -92,7 +92,7 @@ static int sbuffers; /* size of allocat
+ static void push_callback(int no)
+ {
+ add_ref(Pike_sp->u.object = THISOBJ);
+- Pike_sp->subtype = no + Pike_fp->context.identifier_level;
++ Pike_sp->subtype = no + Pike_fp->context->identifier_level;
+ Pike_sp->type = T_FUNCTION;
+ Pike_sp++;
+ }