aboutsummaryrefslogtreecommitdiff
path: root/www/cgicc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-28 23:29:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-28 23:29:51 +0000
commit49ec93a84b2018be83e76e73d54e082384fc827f (patch)
treefce790089e21131c0712be2268b79f34edf614b6 /www/cgicc
parent52fef6fb74299dfc98d9029d0a3ef042dbc25f9a (diff)
downloadports-49ec93a84b2018be83e76e73d54e082384fc827f.tar.gz
ports-49ec93a84b2018be83e76e73d54e082384fc827f.zip
- Update to 3.2.8
PR: 138282 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=240481
Diffstat (limited to 'www/cgicc')
-rw-r--r--www/cgicc/Makefile29
-rw-r--r--www/cgicc/distinfo6
-rw-r--r--www/cgicc/files/patch-Makefile.in14
-rw-r--r--www/cgicc/files/patch-cgicc::CgiEnvironment.cpp12
-rw-r--r--www/cgicc/files/patch-configure10
-rw-r--r--www/cgicc/files/patch-doc:Makefile.in11
-rw-r--r--www/cgicc/pkg-plist164
7 files changed, 31 insertions, 215 deletions
diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
index 569cd773e381..e5b335c02439 100644
--- a/www/cgicc/Makefile
+++ b/www/cgicc/Makefile
@@ -7,21 +7,38 @@
#
PORTNAME= cgicc
-PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTVERSION= 3.2.8
CATEGORIES= www devel
MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ class library for writing CGI applications
-USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
+USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262 libtool:22
+ACLOCAL_ARGS= -I m4 --install
+AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
+PORTDOCS= *
+
+post-extract:
+ @${FIND} ${WRKSRC} -type l -delete
+
post-patch:
- @${REINPLACE_CMD} -e 's|-pedantic||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/CXXFLAGS/s|-pedantic||g' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||g' ${WRKSRC}/Makefile.am
+
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} \
+ && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} ${ACLOCAL_ARGS} \
+ && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} ${AUTOHEADER_ARGS} \
+ && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE})
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
.include <bsd.port.mk>
diff --git a/www/cgicc/distinfo b/www/cgicc/distinfo
index e74dbd2a5d99..73b5050fa611 100644
--- a/www/cgicc/distinfo
+++ b/www/cgicc/distinfo
@@ -1,3 +1,3 @@
-MD5 (cgicc-3.2.3.tar.gz) = 57f290cbaea871bc2ccb004d27b1257e
-SHA256 (cgicc-3.2.3.tar.gz) = e1349bbfcb1de75cc9f38d2d35881241f44f3e3b2127dd7b13a80946e6f78a05
-SIZE (cgicc-3.2.3.tar.gz) = 718154
+MD5 (cgicc-3.2.8.tar.gz) = 7bfe01649f2b7bf582a8d0034ed0b32b
+SHA256 (cgicc-3.2.8.tar.gz) = 8718e1b9919b6381d55ef7ebca42564278b76225e83ab94db99cee18668e4033
+SIZE (cgicc-3.2.8.tar.gz) = 8142543
diff --git a/www/cgicc/files/patch-Makefile.in b/www/cgicc/files/patch-Makefile.in
deleted file mode 100644
index 07ee577fb058..000000000000
--- a/www/cgicc/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.in.orig Sat Jun 19 08:25:52 2004
-+++ Makefile.in Mon Jul 5 22:06:23 2004
-@@ -178,7 +178,10 @@
- AUTOMAKE_OPTIONS = check-news dist-bzip2
- @DEMOS_FALSE@DEMO =
- @DEMOS_TRUE@DEMO = demo contrib
--SUBDIRS = cgicc doc support $(DEMO)
-+ifndef NOPORTDOCS
-+DOC = doc
-+endif
-+SUBDIRS = cgicc support $(DEMO) $(DOC)
- CLEANFILES = *~
- MAINTAINERCLEANFILES = aclocal.m4 cgicc-*.tar.gz cgicc-*.diff
- EXTRA_DIST = BUGS README.WIN COPYING.DOC example win
diff --git a/www/cgicc/files/patch-cgicc::CgiEnvironment.cpp b/www/cgicc/files/patch-cgicc::CgiEnvironment.cpp
deleted file mode 100644
index db8c06c857e3..000000000000
--- a/www/cgicc/files/patch-cgicc::CgiEnvironment.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- cgicc/CgiEnvironment.cpp.orig Thu Mar 11 01:29:33 2004
-+++ cgicc/CgiEnvironment.cpp Thu Mar 11 01:29:42 2004
-@@ -138,7 +138,7 @@
- std::string::const_iterator data_iter;
-
- for(data_iter = data.begin(); data_iter != data.end(); ++data_iter,++wscount)
-- if(std::isspace(*data_iter) == 0)
-+ if(isspace(*data_iter) == 0)
- break;
-
- // Per RFC 2091, do not unescape the data (thanks to afm@othello.ch)
-
diff --git a/www/cgicc/files/patch-configure b/www/cgicc/files/patch-configure
deleted file mode 100644
index 6e0a74adf0b8..000000000000
--- a/www/cgicc/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Mon Mar 18 06:39:53 2002
-+++ configure Sat Nov 2 14:30:17 2002
-@@ -7835,6 +7835,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/www/cgicc/files/patch-doc:Makefile.in b/www/cgicc/files/patch-doc:Makefile.in
deleted file mode 100644
index dac0876cba35..000000000000
--- a/www/cgicc/files/patch-doc:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.in.orig Tue Jun 15 02:54:56 2004
-+++ doc/Makefile.in Mon Jul 5 22:12:44 2004
-@@ -155,7 +155,7 @@
- target_alias = @target_alias@
- CLEANFILES = *~
- DOXYFILE = Doxyfile
--docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
-+docdir = $(prefix)/share/doc/$(PACKAGE)
- TEMPLATES = index.tmpl license.tmpl lists.tmpl bugs.tmpl demos.tmpl \
- cgi-overview.tmpl tutorial.tmpl lib-overview.tmpl COPYING COPYING.LIB \
- COPYING.DOC header.html footer.html cgicc-doc.css
diff --git a/www/cgicc/pkg-plist b/www/cgicc/pkg-plist
index 38d3e5913e5b..5fd6cbb70a4f 100644
--- a/www/cgicc/pkg-plist
+++ b/www/cgicc/pkg-plist
@@ -22,168 +22,14 @@ include/cgicc/HTTPPlainHeader.h
include/cgicc/HTTPRedirectHeader.h
include/cgicc/HTTPResponseHeader.h
include/cgicc/HTTPStatusHeader.h
+include/cgicc/HTTPXHTMLHeader.h
include/cgicc/MStreamable.h
+include/cgicc/XHTMLDoctype.h
+include/cgicc/XMLDeclaration.h
+include/cgicc/XMLPI.h
lib/libcgicc.a
lib/libcgicc.la
lib/libcgicc.so
lib/libcgicc.so.5
-%%PORTDOCS%%%%DOCSDIR%%/COPYING-source.html
-%%PORTDOCS%%%%DOCSDIR%%/COPYING_8DOC-source.html
-%%PORTDOCS%%%%DOCSDIR%%/COPYING_8LIB-source.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiDefs_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiDefs_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiEnvironment_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiEnvironment_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiInput_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiInput_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiUtils_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/CgiUtils_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/Cgicc_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/Cgicc_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/FormEntry_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/FormEntry_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/FormFile_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/FormFile_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLAtomicElement_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLAtomicElement_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLAttributeList_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLAttributeList_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLAttribute_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLAttribute_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLBooleanElement_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLBooleanElement_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLClasses_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLClasses_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLDoctype_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLDoctype_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLElementList_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLElementList_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLElement_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTMLElement_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPContentHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPContentHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPCookie_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPCookie_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPHTMLHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPHTMLHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPPlainHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPPlainHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPRedirectHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPRedirectHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPResponseHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPResponseHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPStatusHeader_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/HTTPStatusHeader_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/MStreamable_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/MStreamable_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/annotated.html
-%%PORTDOCS%%%%DOCSDIR%%/bugs_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/cgi-overview_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/cgi_overview.html
-%%PORTDOCS%%%%DOCSDIR%%/cgicc-doc.css
-%%PORTDOCS%%%%DOCSDIR%%/cgicc.png
-%%PORTDOCS%%%%DOCSDIR%%/cgicc_bugs.html
-%%PORTDOCS%%%%DOCSDIR%%/cgicc_demos.html
-%%PORTDOCS%%%%DOCSDIR%%/cgicc_license.html
-%%PORTDOCS%%%%DOCSDIR%%/cgicc_lists.html
-%%PORTDOCS%%%%DOCSDIR%%/cgicc_tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1CgiEnvironment-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1CgiEnvironment.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1CgiInput-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1CgiInput.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1Cgicc-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1Cgicc.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1FormEntry-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1FormEntry.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1FormFile-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1FormFile.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAtomicElement-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAtomicElement.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAtomicElement.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAttribute-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAttribute.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAttributeList-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLAttributeList.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLBooleanElement-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLBooleanElement.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLBooleanElement.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLDoctype-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLDoctype.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLDoctype.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLElement-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLElement.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLElement.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLElementList-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTMLElementList.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPContentHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPContentHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPContentHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPCookie-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPCookie.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPCookie.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPHTMLHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPHTMLHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPHTMLHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPPlainHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPPlainHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPPlainHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPRedirectHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPRedirectHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPRedirectHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPResponseHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPResponseHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPResponseHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPStatusHeader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPStatusHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1HTTPStatusHeader.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1MStreamable-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1MStreamable.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1MStreamable.png
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1comment-members.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1comment.html
-%%PORTDOCS%%%%DOCSDIR%%/classcgicc_1_1comment.png
-%%PORTDOCS%%%%DOCSDIR%%/config_8h-source.html
-%%PORTDOCS%%%%DOCSDIR%%/cookie_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/cookie_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/demos_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/dns_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/dns_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
-%%PORTDOCS%%%%DOCSDIR%%/files.html
-%%PORTDOCS%%%%DOCSDIR%%/functions.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_enum.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_eval.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_rela.html
-%%PORTDOCS%%%%DOCSDIR%%/globals.html
-%%PORTDOCS%%%%DOCSDIR%%/globals_defs.html
-%%PORTDOCS%%%%DOCSDIR%%/hierarchy.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/index_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/lib-overview_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/lib_overview.html
-%%PORTDOCS%%%%DOCSDIR%%/license_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/license_fdl.html
-%%PORTDOCS%%%%DOCSDIR%%/license_gpl.html
-%%PORTDOCS%%%%DOCSDIR%%/license_lgpl.html
-%%PORTDOCS%%%%DOCSDIR%%/lists_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/namespacecgicc.html
-%%PORTDOCS%%%%DOCSDIR%%/namespacemembers.html
-%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_func.html
-%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_type.html
-%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
-%%PORTDOCS%%%%DOCSDIR%%/pages.html
-%%PORTDOCS%%%%DOCSDIR%%/test_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/test_8cpp.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial_8tmpl-source.html
-%%PORTDOCS%%%%DOCSDIR%%/upload_8cpp-source.html
-%%PORTDOCS%%%%DOCSDIR%%/upload_8cpp.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/aclocal/cgicc.m4
@dirrm include/cgicc