aboutsummaryrefslogtreecommitdiff
path: root/www/chems
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-06 02:42:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-06 02:42:37 +0000
commit87708195370a0a9af1c4137f461b6fbd82b4a6f8 (patch)
treed53441047b5ee89b80a56f6d90c764a2b041d952 /www/chems
parentb8f5724e484b58f028ad03d0ab38a074ede84d42 (diff)
downloadports-87708195370a0a9af1c4137f461b6fbd82b4a6f8.tar.gz
ports-87708195370a0a9af1c4137f461b6fbd82b4a6f8.zip
- Stage support
Notes
Notes: svn path=/head/; revision=342930
Diffstat (limited to 'www/chems')
-rw-r--r--www/chems/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/www/chems/Makefile b/www/chems/Makefile
index 6098387ca3c0..37af4edf8120 100644
--- a/www/chems/Makefile
+++ b/www/chems/Makefile
@@ -15,15 +15,11 @@ USE_PHP= xml iconv gd
SUB_FILES= pkg-message
WWWDIR?= ${PREFIX}/www/${PORTNAME}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
do-install:
- @${MKDIR} ${WWWDIR}
- ${CP} -R ${WRKSRC}/ ${WWWDIR}
- ${TOUCH} ${WWWDIR}/usr/config.php
- @${CHOWN} ${WWWOWN} ${WWWDIR}/usr/config.php
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}
+ ${TOUCH} ${STAGEDIR}${WWWDIR}/usr/config.php
+ @${CHOWN} ${WWWOWN} ${STAGEDIR}${WWWDIR}/usr/config.php
create-plist:
@${FIND} -s ${WRKSRC}/${file} -not -type d \
@@ -33,4 +29,4 @@ create-plist:
@${FIND} -ds ${WRKSRC}/${file} -type d \
| ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>