aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-01-27 14:22:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-01-27 14:22:25 +0000
commit9a09da6e633a2e103f88549df7ee46f92043ecc4 (patch)
tree23e3f93429684e6b3a93c7a10fae3c9334a213dc /www/cherokee
parent8e62189f6b7cb0dc323b5b7cb43863295601bdde (diff)
downloadports-9a09da6e633a2e103f88549df7ee46f92043ecc4.tar.gz
ports-9a09da6e633a2e103f88549df7ee46f92043ecc4.zip
- Update to 1.0.18
PR: ports/154211 Submitted by: Diego Schulz <dschulz@gmail.com> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268294
Diffstat (limited to 'www/cherokee')
-rw-r--r--www/cherokee/Makefile11
-rw-r--r--www/cherokee/distinfo4
-rw-r--r--www/cherokee/files/patch-admin-systemstats.py.diff34
-rw-r--r--www/cherokee/files/pkg-install.in54
-rw-r--r--www/cherokee/pkg-plist2
5 files changed, 83 insertions, 22 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index ab8fa18a6af6..31e353a51cab 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cherokee
-PORTVERSION= 1.0.15
+PORTVERSION= 1.0.18
CATEGORIES= www
MASTER_SITES= http://www.cherokee-project.com/download/1.0/${PORTVERSION}/ \
http://cherokee.osuosl.org/1.0/${PORTVERSION}/ \
@@ -73,12 +73,15 @@ CHEROKEE_LOGFILE_FILEMODE= 0600
CHEROKEE_LOGFILE_USER= root
CHEROKEE_LOGFILE_GROUP= wheel
+# Directory where to put RRD files, by default
+CHEROKEE_RRDDIR=/var/lib/cherokee/graphs
+
CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www/cherokee \
--localstatedir=${CHEROKEE_VARDIR} \
--disable-static
DEFCONFS= cherokee.conf
CONFSUBDIRS= ssl mods-available mods-enabled sites-available sites-enabled
-MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee-admin.1 \
+MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee-admin.1 cherokee-admin-launcher.1 \
cherokee-tweak.1 cherokee-worker.1
PORTDOCS= *
@@ -237,6 +240,10 @@ post-install:
CHEROKEE_LOGFILE_GROUP=${CHEROKEE_LOGFILE_GROUP} \
CHEROKEE_ERRORLOG=${CHEROKEE_ERRORLOG} \
CHEROKEE_ACCESSLOG=${CHEROKEE_ACCESSLOG} \
+ CHEROKEE_WITH_RRDTOOL=${WITH_RRDTOOL} \
+ CHEROKEE_RRDDIR=${CHEROKEE_RRDDIR} \
+ CHEROKEE_RRDDIR_USER=${CHEROKEE_USER} \
+ CHEROKEE_RRDDIR_GROUP=${CHEROKEE_GROUP} \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG} "==============================================================="
diff --git a/www/cherokee/distinfo b/www/cherokee/distinfo
index ba6fb5839074..f077b3951950 100644
--- a/www/cherokee/distinfo
+++ b/www/cherokee/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cherokee-1.0.15.tar.gz) = 014ff6ddf5491c2289cab135c28a8c69955ef2c0cd8a60531cd6bc4f4918c3eb
-SIZE (cherokee-1.0.15.tar.gz) = 5827351
+SHA256 (cherokee-1.0.18.tar.gz) = 8bedf485ffbfa0a915a5714532186d8bd2b7b4a7cc5a2197bc9f026c68fd1a2c
+SIZE (cherokee-1.0.18.tar.gz) = 5841896
diff --git a/www/cherokee/files/patch-admin-systemstats.py.diff b/www/cherokee/files/patch-admin-systemstats.py.diff
new file mode 100644
index 000000000000..58d781b9e3cb
--- /dev/null
+++ b/www/cherokee/files/patch-admin-systemstats.py.diff
@@ -0,0 +1,34 @@
+--- admin/SystemStats.py 2011-01-14 12:07:33.000000000 -0300
++++ admin/SystemStats.py-new 2011-01-21 16:44:01.000000000 -0300
+@@ -5,7 +5,7 @@
+ # Authors:
+ # Alvaro Lopez Ortega <alvaro@alobbs.com>
+ #
+-# Copyright (C) 2001-2011 Alvaro Lopez Ortega
++# Copyright (C) 2001-2010 Alvaro Lopez Ortega
+ #
+ # This program is free software; you can redistribute it and/or
+ # modify it under the terms of version 2 of the GNU General Public
+@@ -331,7 +331,7 @@
+
+ def _read_cpu_and_mem_info (self):
+ # Execute sysctl
+- ret = popen.popen_sync ("/sbin/sysctl hw.ncpu hw.clockrate kern.threads.virtual_cpu hw.pagesize vm.stats.vm.v_page_count")
++ ret = popen.popen_sync ("/sbin/sysctl -i hw.ncpu hw.clockrate kern.smp.cpus hw.pagesize vm.stats.vm.v_page_count")
+ lines = filter (lambda x: x, ret['stdout'].split('\n'))
+
+ # Parse output
+@@ -349,10 +349,11 @@
+ parts = line.split()
+ if parts[0] == 'hw.ncpu:':
+ ncpus = int(parts[1])
++ vcpus = int(parts[1])
+ elif parts[0] == 'hw.clockrate:':
+ clock = parts[1]
+- elif parts[0] == 'kern.threads.virtual_cpu:':
+- vcpus = parts[1]
++ elif parts[0] == 'kern.smp.cpus:':
++ vcpus = parts[1]
+ elif parts[0] == 'vm.stats.vm.v_page_count:':
+ pcount = int(parts[1])
+ elif parts[0] == 'hw.pagesize:':
diff --git a/www/cherokee/files/pkg-install.in b/www/cherokee/files/pkg-install.in
index bf75b0432031..ebc2da3c96c9 100644
--- a/www/cherokee/files/pkg-install.in
+++ b/www/cherokee/files/pkg-install.in
@@ -3,31 +3,51 @@
PATH=/bin:/usr/bin:/usr/sbin
-C_ACCESSLOG=${CHEROKEE_ACCESSLOG:-/var/log/cherokee.access}
-C_ERRORLOG=${CHEROKEE_ERRORLOG:-/var/log/cherokee.error}
-C_USER=${CHEROKEE_LOGFILE_USER:-root}
-C_GROUP=${CHEROKEE_LOGFILE_GROUP:-wheel}
-C_FILEMODE=${CHEROKEE_LOGFILE_FILEMODE:-0640}
+ACCESSLOG=${CHEROKEE_ACCESSLOG:-/var/log/cherokee.access}
+ERRORLOG=${CHEROKEE_ERRORLOG:-/var/log/cherokee.error}
+LOGS_USER=${CHEROKEE_LOGFILE_USER:-root}
+LOGS_GROUP=${CHEROKEE_LOGFILE_GROUP:-wheel}
+LOGS_FILEMODE=${CHEROKEE_LOGFILE_FILEMODE:-0640}
+
+WITH_RRDTOOL=${CHEROKEE_WITH_RRDTOOL:-n}
+RRDDIR=${CHEROKEE_RRDDIR:-/var/lib/cherokee/graphs}
+RRDDIR_USER=${CHEROKEE_RRDDIR_USER:-www}
+RRDDIR_GROUP=${CHEROKEE_RRDDIR_GROUP:-www}
+
case $2 in
POST-INSTALL)
- echo "$2 for $1"
- echo "Adjusting ownership (${C_USER}:${C_GROUP}) and permissions (${C_FILEMODE}) on log files:"
- echo "${C_ACCESSLOG}"
- echo "${C_ERRORLOG}"
-
- if [ ! -f ${C_ACCESSLOG} ]; then
- touch ${C_ACCESSLOG}
+
+ echo "$2 for $1"
+ echo "Adjusting ownership (${LOGS_USER}:${LOGS_GROUP}) and permissions (${LOGS_FILEMODE}) on log files:"
+ echo "${ACCESSLOG}"
+ echo "${ERRORLOG}"
+
+ if [ ! -f ${ACCESSLOG} ]; then
+ touch ${ACCESSLOG}
fi
- if [ ! -f ${C_ERRORLOG} ]; then
- touch ${C_ERRORLOG}
+ if [ ! -f ${ERRORLOG} ]; then
+ touch ${ERRORLOG}
fi
- chown ${C_USER}:${C_GROUP} ${C_ACCESSLOG} ${C_ERRORLOG}
- chmod ${C_FILEMODE} ${C_ACCESSLOG} ${C_ERRORLOG}
-
+ chown -v ${LOGS_USER}:${LOGS_GROUP} ${ACCESSLOG} ${ERRORLOG}
+ chmod -v ${LOGS_FILEMODE} ${ACCESSLOG} ${ERRORLOG}
+
+ if [ "$WITH_RRDTOOL" = "true" ]; then
+ if [ -d ${RRDDIR} ]; then
+ echo "RRD directory already exists."
+ else
+ echo "Creating directory for RRD databases..."
+ mkdir -v -p ${RRDDIR}
+ fi
+
+ echo "Adjusting ownership..."
+ chown -v ${RRDDIR_USER}:${RRDDIR_GROUP} ${RRDDIR}
+ fi
+
+ echo "$2 done."
;;
diff --git a/www/cherokee/pkg-plist b/www/cherokee/pkg-plist
index d9425de7e1cf..38cf51a9b327 100644
--- a/www/cherokee/pkg-plist
+++ b/www/cherokee/pkg-plist
@@ -179,7 +179,6 @@ lib/libcherokee-server.la
lib/libcherokee-server.so
lib/libcherokee-server.so.0
libdata/pkgconfig/cherokee.pc
-man/man1/cherokee-admin-launcher.1
sbin/cherokee
sbin/cherokee-admin
sbin/cherokee-worker
@@ -910,6 +909,7 @@ share/aclocal/cherokee.m4
%%ADMIN%%%%DATADIR%%/admin/static/images/wizards/wordpress.png
%%ADMIN%%%%DATADIR%%/admin/static/images/wizards/zend.png
%%ADMIN%%%%DATADIR%%/admin/static/js/SelectionPanel.js
+%%ADMIN%%%%DATADIR%%/admin/static/help_404.html
%%ADMIN%%%%DATADIR%%/admin/theme.html
%%ADMIN%%%%DATADIR%%/admin/upgrade_config.py
%%ADMIN%%%%DATADIR%%/admin/upgrade_config.pyc