aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-06-07 20:28:41 +0000
committerRene Ladan <rene@FreeBSD.org>2016-06-07 20:28:41 +0000
commit45d3cc73dc908af3262c6a714cb755edd03f071a (patch)
tree564e40b2ccfe669385077be2c94de93ac0c15fe3 /www/chromium/Makefile
parent071c1e89c17887adb174a6933a8f241ac326e143 (diff)
downloadports-45d3cc73dc908af3262c6a714cb755edd03f071a.tar.gz
ports-45d3cc73dc908af3262c6a714cb755edd03f071a.zip
www/chromium: update to 51.0.2704.84
Notes
Notes: svn path=/head/; revision=416521
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile43
1 files changed, 23 insertions, 20 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 6ed5c4f2e34c..b689e1cdde01 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 49.0.2623.112
-PORTREVISION= 1
+PORTVERSION= 51.0.2704.84
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
@@ -26,34 +25,35 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:devel/gperf \
${PYTHON_PKGNAMEPREFIX}ply>0:devel/py-ply \
${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib
-LIB_DEPENDS= libcairo.so:graphics/cairo \
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libcairo.so:graphics/cairo \
+ libcups.so:print/cups \
libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
- libasound.so:audio/alsa-lib \
- libfreetype.so:print/freetype2 \
- libnss3.so:security/nss \
+ libdrm.so:graphics/libdrm \
+ libexpat.so:textproc/expat2 \
libFLAC.so:audio/flac \
+ libfreetype.so:print/freetype2 \
libgnome-keyring.so:security/libgnome-keyring \
libharfbuzz.so:print/harfbuzz \
- libcups.so:print/cups \
libevent.so:devel/libevent2 \
libexif.so:graphics/libexif \
+ libfontconfig.so:x11-fonts/fontconfig \
libgcrypt.so:security/libgcrypt \
- libpci.so:devel/libpci \
- libdrm.so:graphics/libdrm \
libicuuc.so:devel/icu \
libjsoncpp.so:devel/jsoncpp \
libnspr4.so:devel/nspr \
+ libnss3.so:security/nss \
+ libpci.so:devel/libpci \
libpng.so:graphics/png \
libre2.so:devel/re2 \
libsnappy.so:archivers/snappy \
libspeechd.so:accessibility/speech-dispatcher \
libspeex.so:audio/speex \
- libxml2.so:textproc/libxml2 \
- libwebp.so:graphics/webp
+ libwebp.so:graphics/webp \
+ libxml2.so:textproc/libxml2
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-plugins \
- alsa-lib>=1.1.1_1:audio/alsa-lib \
droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
xdg-open:devel/xdg-utils
@@ -74,14 +74,16 @@ USES+= compiler:c++11-lib
CPE_VENDOR= google
CPE_PRODUCT= chrome
USE_PERL5= build
-USE_XORG= scrnsaverproto x11 xproto xscrnsaver xtst
+USE_XORG= scrnsaverproto x11 xcomposite xcursor xext xdamage xfixes xi \
+ xproto xrandr xrender xscrnsaver xtst
USE_GNOME= atk glib20 gtk20 dconf libxslt
MAKE_ARGS= -C out/${BUILDTYPE}
SHEBANG_FILES= chrome/tools/build/linux/chrome-wrapper
ALL_TARGET= chrome
INSTALLS_ICONS= yes
-#TODO bz@ : if you do undestand the gyp stuff, third_party/widevine/cdm/widevine_cdm.gyp talks about it (plz install libwidevinecdm.so)
+#TODO bz@ : install libwidevinecdm.so (see
+# third_party/widevine/cdm/widevine_cdm.gyp)
# See build/common.gypi for all the available variables.
GYP_DEFINES+= \
clang_use_chrome_plugins=0 \
@@ -97,6 +99,7 @@ GYP_DEFINES+= \
enable_webrtc=1 \
werror= \
no_gc_sections=1 \
+ OS=freebsd \
os_ver=${OSVERSION} \
prefix_dir=${LOCALBASE} \
python_ver=${PYTHON_VER} \
@@ -177,7 +180,7 @@ GYP_DEFINES+= use_pulseaudio=1
GYP_DEFINES+= use_pulseaudio=0
.endif
-.if ! ${MACHINE_CPU:Msse2}
+.if empty(MACHINE_CPU:Msse2)
GYP_DEFINES+= disable_sse2=1
.endif
@@ -315,8 +318,8 @@ pre-configure:
'third_party/libjingle' \
'third_party/libphonenumber' \
'third_party/libsrtp' \
- 'third_party/libvpx_new' \
- 'third_party/libvpx_new/source/libvpx/third_party/x86inc' \
+ 'third_party/libvpx' \
+ 'third_party/libvpx/source/libvpx/third_party/x86inc' \
'third_party/libwebm' \
'third_party/libxml/chromium' \
'third_party/libXNVCtrl' \
@@ -325,10 +328,9 @@ pre-configure:
'third_party/lzma_sdk' \
'third_party/markupsafe' \
'third_party/mesa' \
- 'third_party/mojo' \
'third_party/modp_b64' \
'third_party/mt19937ar' \
- 'third_party/npapi' \
+ 'third_party/openh264' \
'third_party/openmax_dl' \
'third_party/opus' \
'third_party/ots' \
@@ -397,7 +399,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/${BUILDTYPE}/chrome \
${STAGEDIR}${DATADIR}
cd ${WRKSRC}/out/${BUILDTYPE} && \
- ${COPYTREE_SHARE} "locales resources" ${STAGEDIR}${DATADIR}
+ ${COPYTREE_SHARE} "locales pseudo_locales resources" ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKDIR}/chromium-browser.desktop \
${STAGEDIR}${DESKTOPDIR}
${INSTALL_SCRIPT} ${WRKDIR}/chrome ${STAGEDIR}${PREFIX}/bin