aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorConrad Meyer <cem@FreeBSD.org>2020-03-25 01:43:35 +0000
committerConrad Meyer <cem@FreeBSD.org>2020-03-25 01:43:35 +0000
commit8481040786cf2b02f2c40dbb713469d3c2281d51 (patch)
treef855e2b3f610f9a3d29a2811fc6f35fdfd29a710 /www/chromium/Makefile
parent72965a98b40301b327664213e773921d1e3aa547 (diff)
downloadports-8481040786cf2b02f2c40dbb713469d3c2281d51.tar.gz
ports-8481040786cf2b02f2c40dbb713469d3c2281d51.zip
www/chromium: update to 80.0.3987.149
The Chrome stable channel has been updated to 80.0.3987.149[1]. This update includes 13 security fixes, including 9 Sev:High reports from external researchers. [1]: https://chromereleases.googleblog.com/2020/03/stable-channel-update-for-desktop_18.html PR: 245019 Approved by: jrm Security: yes Differential Revision: https://reviews.freebsd.org/D24169
Notes
Notes: svn path=/head/; revision=529072
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 5adfee1e9f54..61ab46f1d62e 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 80.0.3987.132
-PORTREVISION= 1
+PORTVERSION= 80.0.3987.149
CATEGORIES?= www java
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/cpm/chromium/:fonts
@@ -104,20 +103,19 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang
# Some parts don't have use_system_* flag, and can be turned on/off by using
# replace_gn_files.py script, some parts just turned on/off for target host
# OS "target_os == is_bsd", like libusb, libpci.
-GN_ARGS+= clang_use_chrome_plugins=false \
+GN_ARGS+= \
+ clang_use_chrome_plugins=false \
enable_hangout_services_extension=true \
enable_nacl=false \
enable_one_click_signin=true \
enable_remoting=false \
fieldtrial_testing_like_official_build=true \
is_clang=true \
- jumbo_file_merge_limit=8 \
toolkit_views=true \
treat_warnings_as_errors=false \
use_allocator="none" \
use_allocator_shim=false \
use_aura=true \
- use_bundled_fontconfig=false \
use_custom_libcxx=false \
use_gnome_keyring=false \
use_lld=true \
@@ -158,12 +156,12 @@ ALSA_RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/al
ALSA_VARS= GN_ARGS+=use_alsa=true
ALSA_VARS_OFF= GN_ARGS+=use_alsa=false
-CODECS_VARS= GN_ARGS+=ffmpeg_branding="Chrome" \
- GN_ARGS+=proprietary_codecs=true \
- GN_ARGS+=enable_platform_hevc=true
-CODECS_VARS_OFF= GN_ARGS+=ffmpeg_branding="Chromium" \
- GN_ARGS+=proprietary_codecs=false \
- GN_ARGS+=enable_platform_hevc=false
+CODECS_VARS= \
+ GN_ARGS+=ffmpeg_branding="Chrome" \
+ GN_ARGS+=proprietary_codecs=true
+CODECS_VARS_OFF= \
+ GN_ARGS+=ffmpeg_branding="Chromium" \
+ GN_ARGS+=proprietary_codecs=false
CUPS_LIB_DEPENDS= libcups.so:print/cups
CUPS_VARS= GN_ARGS+=use_cups=true