aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-02-24 10:52:51 +0000
committerRene Ladan <rene@FreeBSD.org>2019-02-24 10:52:51 +0000
commita31400d152016c35271aa6f676744c02865e6bf4 (patch)
tree97fd2c7c3e5f479435a4e0f4f48d23817386d0be /www/chromium/Makefile
parentc8108e6df419f1acad6b797a2f16ef1221be74ae (diff)
downloadports-a31400d152016c35271aa6f676744c02865e6bf4.tar.gz
ports-a31400d152016c35271aa6f676744c02865e6bf4.zip
www/chromium: update to 72.0.3626.119 [1]
PR: 234773 Submitted by: cpm [1], Matthias Wolf [1] Obtained from: https://github.com/cpu82/freebsd-chromium.git MFH: 2019Q1
Notes
Notes: svn path=/head/; revision=493750
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 196fb8aacd97..6821a4c5f01d 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 71.0.3578.98
-PORTREVISION= 2
+PORTVERSION= 72.0.3626.119
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/cpm/chromium/:fonts
@@ -182,7 +181,6 @@ DEBUG_VARS_OFF= BUILDTYPE=Release \
GN_ARGS+=remove_webcore_debug_symbols=true \
WANTSPACE="a fair amount of free disk space (~ 6.5GB)"
-DRIVER_BUILD_DEPENDS= git:devel/git
DRIVER_MAKE_ARGS= chromedriver
KERBEROS_VARS= GN_ARGS+=use_kerberos=true
@@ -216,6 +214,13 @@ PLIST_SUB+= NOT_AARCH64="@comment "
PLIST_SUB+= NOT_AARCH64=""
.endif
+# Make better javascript with java
+.if ${ARCH} == amd64 && !defined(GN_ONLY)
+JAVA_BUILD= yes
+JAVA_VERSION= 1.8
+USE_JAVA= yes
+.endif
+
# Allow relocations against read-only segments (override lld default)
LDFLAGS_i386= -Wl,-znotext
@@ -268,6 +273,12 @@ do-configure:
# Setup nodejs dependency
@${MKDIR} ${WRKSRC}/third_party/node/freebsd/node-freebsd-x64/bin
${LN} -sf ${LOCALBASE}/bin/node ${WRKSRC}/third_party/node/freebsd/node-freebsd-x64/bin/node
+
+ # Setup java dependency on amd64
+.if ${ARCH} == amd64
+ @${MKDIR} ${WRKDIR}/bin
+ ${LN} -sf ${LOCALBASE}/openjdk8/bin/java ${WRKDIR}/bin/java
+.endif
.endif
do-test-TEST-on: