aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2019-01-07 19:47:18 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2019-01-07 19:47:18 +0000
commitab34cf48c6364f23214d9242e83eefd174f7f820 (patch)
treece7704d873ee687272322780c46fc9ddee28a619 /www/chromium/Makefile
parent8b8ed1280fd0f67a28315ef6868ea74d951179ee (diff)
downloadports-ab34cf48c6364f23214d9242e83eefd174f7f820.tar.gz
ports-ab34cf48c6364f23214d9242e83eefd174f7f820.zip
www/chromium: Update to 71.0.3578.98
Changelog: https://chromium.googlesource.com/chromium/src/+log/68.0.3440.106..71.0.3578.98?pretty=fuller&n=10000 PR: 233990 Submitted by: Matthias Wolf <freebsd@rheinwolf.de> Reported by: nikolaibitinit@gmail.com Reviewed by: rene, cpm Approved by: rene, cpm MFH: 2019Q1 Security: http://vuxml.freebsd.org/freebsd/546d4dd4-10ea-11e9-b407-080027ef1a23.html Security: http://vuxml.freebsd.org/freebsd/720590df-10eb-11e9-b407-080027ef1a23.html
Notes
Notes: svn path=/head/; revision=489612
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 4b6c80c9053c..6c21667e2d69 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 68.0.3440.106
-PORTREVISION= 7
+PORTVERSION= 71.0.3578.98
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/cpm/chromium/:fonts
@@ -25,6 +24,7 @@ BUILD_DEPENDS+= gperf:devel/gperf \
ffmpeg>=3.2.2,1:multimedia/ffmpeg \
flock:sysutils/flock \
node:www/node \
+ ${LOCALBASE}/bin/ar:devel/binutils \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat \
${LOCALBASE}/share/usbids/usb.ids:misc/usbids \
${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${PY_FLAVOR}
@@ -32,6 +32,7 @@ BUILD_DEPENDS+= gperf:devel/gperf \
.if !defined(GN_ONLY)
LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-atk \
+ libatspi.so:accessibility/at-spi2-core \
libspeechd.so:accessibility/speech-dispatcher \
libsnappy.so:archivers/snappy \
libFLAC.so:audio/flac \
@@ -72,11 +73,12 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386
USES= compiler:c++14-lang localbase:ldflags ninja pkgconfig \
python:2.7,build shebangfix tar:xz
.else
-USES= bison cpe desktop-file-utils gnome jpeg localbase:ldflags \
+USES= bison cpe desktop-file-utils dos2unix gl gnome jpeg localbase:ldflags \
ninja perl5 pkgconfig python:2.7,build shebangfix tar:xz
.endif
MAKE_ARGS= -C out/${BUILDTYPE}
BINARY_ALIAS= python=${PYTHON_CMD}
+DOS2UNIX_FILES= third_party/skia/third_party/vulkanmemoryallocator/include/vk_mem_alloc.h
.if !defined(GN_ONLY)
CPE_VENDOR= google
@@ -107,6 +109,7 @@ GN_ARGS+= clang_use_chrome_plugins=false \
enable_remoting=false \
fieldtrial_testing_like_official_build=true \
is_clang=true \
+ jumbo_file_merge_limit=8 \
toolkit_views=true \
treat_warnings_as_errors=false \
use_allocator="none" \
@@ -115,7 +118,7 @@ GN_ARGS+= clang_use_chrome_plugins=false \
use_bundled_fontconfig=false \
use_custom_libcxx=false \
use_gnome_keyring=false \
- use_gtk3=true \
+ use_jumbo_build=true \
use_lld=true \
use_sysroot=false \
use_system_freetype=true \
@@ -125,7 +128,7 @@ GN_ARGS+= clang_use_chrome_plugins=false \
extra_ldflags="${LDFLAGS}"
# TODO: investigate building with these options:
# use_system_minigbm
-GN_BOOTSTRAP_FLAGS= --no-clean --no-rebuild
+GN_BOOTSTRAP_FLAGS= --no-clean --no-rebuild --skip-generate-buildfiles
# FreeBSD Chromium Api Key
# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys .
@@ -206,13 +209,13 @@ TEST_DISTFILES= ${PORTNAME}-${DISTVERSION}-testdata${EXTRACT_SUFX} \
# swiftshader/lib/{libEGL.so,libGLESv2.so} is x86 only
.if ${ARCH} == aarch64
-PLIST_SUB+= NOT_AARCH64="@comment "
+PLIST_SUB+= NOT_AARCH64="@comment "
.else
PLIST_SUB+= NOT_AARCH64=""
.endif
-BUILD_DEPENDS+= ${LOCALBASE}/bin/ar:devel/binutils
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-llvm-base
+# Allow relocations against read-only segments (override lld default)
+LDFLAGS_i386= -Wl,-znotext
# TODO: -isystem, would be just as ugly as this approach, but more reliably
# build would fail without C_INCLUDE_PATH/CPLUS_INCLUDE_PATH env var set.
@@ -266,6 +269,7 @@ do-configure:
.endif
do-test-TEST-on:
+ cd ${WRKSRC}/out/${BUILDTYPE}/gn_build && ./gn_unittests
.for t in ${TEST_TARGETS}
cd ${WRKSRC}/out/${BUILDTYPE} && ${SETENV} LC_ALL=en_US.UTF-8 \
./${t} --gtest_filter=-${EXCLUDE_${t}:ts:} || ${TRUE}
@@ -276,7 +280,6 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_MAN} ${WRKSRC}/chrome/app/resources/manpage.1.in \
${STAGEDIR}${MANPREFIX}/man/man1/chrome.1
- ${INSTALL_DATA} ${WRKSRC}/out/${BUILDTYPE}/*.service ${STAGEDIR}${DATADIR}
.for s in 22 24 48 64 128 256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}x${s}/apps
${INSTALL_DATA} ${WRKSRC}/chrome/app/theme/chromium/product_logo_${s}.png \