aboutsummaryrefslogtreecommitdiff
path: root/www/chromium
diff options
context:
space:
mode:
authorRobert Nagy <robert@openbsd.org>2022-07-12 20:07:54 +0000
committerRene Ladan <rene@FreeBSD.org>2022-07-14 07:54:43 +0000
commitb1c7d48f37e746b786cb18b27dbafb9b3da57d89 (patch)
treeb1457c1dc64822337dd55c4bd8eaed4555e59582 /www/chromium
parent4c1779fcd46f94f40b062f9842cf688f835c2f05 (diff)
downloadports-b1c7d48f37e746b786cb18b27dbafb9b3da57d89.tar.gz
ports-b1c7d48f37e746b786cb18b27dbafb9b3da57d89.zip
www/chromium: enable PGO (profiled) build which can yield up to a 10% speedup
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile5
-rw-r--r--www/chromium/distinfo4
-rw-r--r--www/chromium/files/patch-build_config_compiler_pgo_pgo.gni11
3 files changed, 6 insertions, 14 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index dd58cb03f294..e00dae9997eb 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,11 +2,12 @@
PORTNAME= chromium
PORTVERSION= 103.0.5060.114
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ chrome-linux-${PORTVERSION}-llvm13.profdata${EXTRACT_SUFX}:external
MAINTAINER= chromium@FreeBSD.org
COMMENT= Google web browser based on WebKit
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 7cefefc1d9d1..6111262706ba 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,6 +1,8 @@
-TIMESTAMP = 1657433538
+TIMESTAMP = 1657647066
SHA256 (chromium-103.0.5060.114.tar.xz) = 77683510f03b947332461b03954488474d95e49992efc11908f4bd8045635965
SIZE (chromium-103.0.5060.114.tar.xz) = 1470895580
+SHA256 (chrome-linux-103.0.5060.114-llvm13.profdata.tar.xz) = dfa0acf171f0cfae3bccf3252bc58515326652613e695571701cd93fdc3cc9ff
+SIZE (chrome-linux-103.0.5060.114-llvm13.profdata.tar.xz) = 24396508
SHA256 (chromium-103.0.5060.114-testdata.tar.xz) = e99066081eaaec1d0eeffb9c3afdd89b1a8dec96d32d84fc9895e298fa1c2a03
SIZE (chromium-103.0.5060.114-testdata.tar.xz) = 260754688
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
diff --git a/www/chromium/files/patch-build_config_compiler_pgo_pgo.gni b/www/chromium/files/patch-build_config_compiler_pgo_pgo.gni
deleted file mode 100644
index 87304bc3d133..000000000000
--- a/www/chromium/files/patch-build_config_compiler_pgo_pgo.gni
+++ /dev/null
@@ -1,11 +0,0 @@
---- build/config/compiler/pgo/pgo.gni.orig 2022-02-07 13:39:41 UTC
-+++ build/config/compiler/pgo/pgo.gni
-@@ -16,7 +16,7 @@ declare_args() {
- # TODO(crbug.com/1052397): Remove chromeos_is_browser_only once
- # target_os switch for lacros-chrome is completed.
- (is_win || is_mac ||
-- (is_linux && !chromeos_is_browser_only && !is_chromecast))) {
-+ (is_linux && !chromeos_is_browser_only && !is_chromecast && !is_bsd))) {
- chrome_pgo_phase = 2
- }
-