aboutsummaryrefslogtreecommitdiff
path: root/www/chromium
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-01-10 20:57:15 +0000
committerRene Ladan <rene@FreeBSD.org>2012-01-10 20:57:15 +0000
commite5740c9e6bdf75a9eff32795f311ad39de79c24f (patch)
tree62d681d56fa6c77f621fbe976e5346e01c1163b6 /www/chromium
parentefbadcabe8af1f09e83e288c6f24e0a958315e08 (diff)
downloadports-e5740c9e6bdf75a9eff32795f311ad39de79c24f.tar.gz
ports-e5740c9e6bdf75a9eff32795f311ad39de79c24f.zip
Fix warnings at the start of the build.
PR: ports/163921 (based on) Submitted by: Shane Ambler [freebsd shaneware.biz] Patched by: George Liaskos
Notes
Notes: svn path=/head/; revision=288916
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile11
-rw-r--r--www/chromium/files/patch-base__allocator__allocator.gyp6
2 files changed, 14 insertions, 3 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index a383a1deeb05..7fa3eac60e67 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -181,6 +181,17 @@ post-patch:
${WRKSRC}/third_party/WebKit/Source/WebCore/css/makeprop.pl \
${WRKSRC}/third_party/WebKit/Source/WebCore/css/makevalues.pl \
${WRKSRC}/third_party/WebKit/Source/WebCore/make-hash-tools.pl
+# http://code.google.com/p/chromium/issues/detail?id=96629
+ @${REINPLACE_CMD} -e "s|'type': 'settings',|'type': 'none',|" \
+ ${WRKSRC}/third_party/icu/icu.gyp \
+ ${WRKSRC}/third_party/flac/flac.gyp \
+ ${WRKSRC}/third_party/speex/speex.gyp \
+ ${WRKSRC}/third_party/sqlite/sqlite.gyp \
+ ${WRKSRC}/third_party/harfbuzz/harfbuzz.gyp \
+ ${WRKSRC}/third_party/libevent/libevent.gyp \
+ ${WRKSRC}/third_party/libjpeg_turbo/libjpeg.gyp \
+ ${WRKSRC}/tools/gyp/test/settings/settings.gyp \
+ ${WRKSRC}/v8/tools/gyp/v8.gyp
do-configure:
cd ${WRKSRC} && \
diff --git a/www/chromium/files/patch-base__allocator__allocator.gyp b/www/chromium/files/patch-base__allocator__allocator.gyp
index 404e6714b27b..623eea863dca 100644
--- a/www/chromium/files/patch-base__allocator__allocator.gyp
+++ b/www/chromium/files/patch-base__allocator__allocator.gyp
@@ -1,5 +1,5 @@
---- base/allocator/allocator.gyp.orig 2011-11-28 21:53:42.000000000 +0200
-+++ base/allocator/allocator.gyp 2011-11-28 22:01:26.000000000 +0200
+--- base/allocator/allocator.gyp.orig 2012-01-05 10:01:52.000000000 +0200
++++ base/allocator/allocator.gyp 2012-01-09 22:00:51.000000000 +0200
@@ -7,326 +7,198 @@
'jemalloc_dir': '../../third_party/jemalloc/chromium',
'tcmalloc_dir': '../../third_party/tcmalloc/chromium',
@@ -34,7 +34,7 @@
+ 'targets': [
+ {
+ 'target_name': 'allocator',
-+ 'type': 'settings',
++ 'type': 'none',
+ 'direct_dependent_settings': {
'defines': [
- ['PERFTOOLS_DLL_DECL', '']