aboutsummaryrefslogtreecommitdiff
path: root/www/cntlm/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-27 22:30:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-27 22:30:32 +0000
commit59ce2e85625d0aa1b1b690d1c15ab9f278495cb2 (patch)
treeca8b6c6b1e1a6ccc269f0c9903dba50de5281ed8 /www/cntlm/Makefile
parentb0547724b97c2f1faab9b9268b81c6aaef5b420c (diff)
downloadports-59ce2e85625d0aa1b1b690d1c15ab9f278495cb2.tar.gz
ports-59ce2e85625d0aa1b1b690d1c15ab9f278495cb2.zip
Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy. It takes the address of your
proxy or proxies (host1..N and port1..N) and opens a listening socket, forwarding each request to the parent proxy (moving in a circular list if the active parent stops working). Along the way, a connection to the parent is created anew and authenticated or, if available, previously cached connection is reused to achieve higher efficiency and faster responses. When the chain is set up, cntlm should be used as a proxy in your applications. Cntlm also integrates transparent TCP/IP port forwarding (tunneling) through the parent (incl. authentication). WWW: http://cntlm.sourceforge.net/ PR: ports/137016 Submitted by: Antony Mawer <ports at mawer.org>
Notes
Notes: svn path=/head/; revision=238461
Diffstat (limited to 'www/cntlm/Makefile')
-rw-r--r--www/cntlm/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/cntlm/Makefile b/www/cntlm/Makefile
new file mode 100644
index 000000000000..311221f8c028
--- /dev/null
+++ b/www/cntlm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: cntlm
+# Date created: 23 July 2009
+# Whom: Antony Mawer <ports@mawer.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cntlm
+PORTVERSION= 0.35.1
+CATEGORIES= www
+MASTER_SITES= SF
+
+MAINTAINER= ports@mawer.org
+COMMENT= An NTLM / NTLM Session Response / NTLMv2 authenticating HTTP proxy
+
+USE_RC_SUBR= cntlm
+HAS_CONFIGURE= yes
+ALL_TARGET= cntlm
+MAN1= cntlm.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cntlm ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/doc/cntlm.conf ${PREFIX}/etc/cntlm.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/doc/cntlm.1 ${PREFIX}/man/man1
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/cntlm.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/cntlm.conf.sample ${PREFIX}/etc/cntlm.conf; \
+ fi
+
+.include <bsd.port.post.mk>