aboutsummaryrefslogtreecommitdiff
path: root/www/cocoon/Makefile.options
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-09 14:19:38 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-09 14:19:38 +0000
commit7639d5e8803b1a27c5d8de25d99b9cd624595927 (patch)
tree439ecb50d43c1024d90890a778f7d405d9aa424c /www/cocoon/Makefile.options
parentb1544d81d8f45a7a09d6645f134f0f8ef7cdd0be (diff)
downloadports-7639d5e8803b1a27c5d8de25d99b9cd624595927.tar.gz
ports-7639d5e8803b1a27c5d8de25d99b9cd624595927.zip
* Handle recursive dependencies when dealing with blocks selected by the user.
* Handle deprecated blocks. * Select all non-deprecated blocks by default. PR: ports/69944 Submitted by: Jean-Baptiste Quenot (maintainer)
Notes
Notes: svn path=/head/; revision=115745
Diffstat (limited to 'www/cocoon/Makefile.options')
-rw-r--r--www/cocoon/Makefile.options107
1 files changed, 54 insertions, 53 deletions
diff --git a/www/cocoon/Makefile.options b/www/cocoon/Makefile.options
index 1b84a4effba1..4ad158d4fa71 100644
--- a/www/cocoon/Makefile.options
+++ b/www/cocoon/Makefile.options
@@ -1,56 +1,57 @@
# ex:ts=22
#
-OPTIONS+= DOCS 'Include the documentation and samples' off
+OPTIONS+= DOCS 'Include the documentation and samples' on
-OPTIONS+= AUTHENTICATION_FW 'Enable the authentication-fw block' off
-OPTIONS+= BATIK 'Enable the Batik block' off
-OPTIONS+= BSF 'Enable the bsf block' off
-OPTIONS+= CHAPERON 'Enable the chaperon block' off
-OPTIONS+= DATABASES 'Enable the databases block' off
-OPTIONS+= FOP 'Enable the FOP Block (implies BATIK)' off
-OPTIONS+= HSQLDB 'Enable the hsqldb block' off
-OPTIONS+= HTML 'Enable the html block' off
-OPTIONS+= ITEXT 'Enable the itext block' off
-OPTIONS+= JFOR 'Enable the JFOR Block' off
-OPTIONS+= JSP 'Enable the jsp block' off
-OPTIONS+= LINKREWRITER 'Enable the linkrewriter block' off
-OPTIONS+= LUCENE 'Enable the lucene block' off
-OPTIONS+= NAMING 'Enable the naming block' off
-OPTIONS+= PARANOID 'Enable the Paranoid Cocoon Servlet' off
-OPTIONS+= PHP 'Enable the php block' off
-OPTIONS+= POI 'Enable the poi block' off
-OPTIONS+= PORTAL_FW 'Enable the portal-fw block' off
-OPTIONS+= PROFILER 'Enable the profiler block' off
-OPTIONS+= PYTHON 'Enable the python block' off
-OPTIONS+= SESSION_FW 'Enable the session-fw block' off
-OPTIONS+= SWF 'Enable the swf block' off
-OPTIONS+= VELOCITY 'Enable the velocity block' off
-OPTIONS+= WEB3 'Enable the web3 block' off
-OPTIONS+= XMLDB 'Enable the xmldb block' off
-OPTIONS+= XSP 'Enable the xsp block' off
-OPTIONS+= APPLES 'Enable the apples block' off
-OPTIONS+= ASCIIART 'Enable the asciiart block' off
-OPTIONS+= AXIS 'Enable the axis block' off
-OPTIONS+= CRON 'Enable the cron block' off
-OPTIONS+= DELI 'Enable the deli block' off
-OPTIONS+= EVENTCACHE 'Enable the eventcache block' off
-OPTIONS+= FORMS 'Enable the forms block' off
-OPTIONS+= JAVAFLOW 'Enable the javaflow block' off
-OPTIONS+= JMS 'Enable the jms block' off
-OPTIONS+= LINOTYPE 'Enable the linotype block' off
-OPTIONS+= MAIL 'Enable the mail block' off
-OPTIONS+= MIDI 'Enable the midi block' off
-OPTIONS+= OJB 'Enable the ojb block' off
-OPTIONS+= PETSTORE 'Enable the petstore block' off
-OPTIONS+= PORTAL 'Enable the portal block' off
-OPTIONS+= PROXY 'Enable the proxy block' off
-OPTIONS+= QDOX 'Enable the qdox block' off
-OPTIONS+= REPOSITORY 'Enable the repository block' off
-OPTIONS+= SCRATCHPAD 'Enable the scratchpad block' off
-OPTIONS+= SERIALIZERS 'Enable the serializers block' off
-OPTIONS+= SLIDE 'Enable the slide block' off
-OPTIONS+= SLOP 'Enable the slop block' off
-OPTIONS+= STX 'Enable the stx block' off
-OPTIONS+= TAGLIB 'Enable the taglib block' off
-OPTIONS+= TOUR 'Enable the tour block' off
-OPTIONS+= WEBDAV 'Enable the webdav block' off
+OPTIONS+= AUTHENTICATION_FW 'Enable the authentication-fw block' on
+OPTIONS+= BATIK 'Enable the Batik block' on
+OPTIONS+= BSF 'Enable the bsf block' on
+OPTIONS+= CHAPERON 'Enable the chaperon block' on
+OPTIONS+= DATABASES 'Enable the databases block' on
+OPTIONS+= FOP 'Enable the FOP Block (implies BATIK)' on
+OPTIONS+= HSQLDB 'Enable the hsqldb block' on
+OPTIONS+= HTML 'Enable the html block' on
+OPTIONS+= ITEXT 'Enable the itext block' on
+OPTIONS+= JFOR 'Enable the JFOR Block' on
+OPTIONS+= JSP 'Enable the jsp block' on
+OPTIONS+= LINKREWRITER 'Enable the linkrewriter block' on
+OPTIONS+= LUCENE 'Enable the lucene block' on
+OPTIONS+= NAMING 'Enable the naming block' on
+OPTIONS+= PARANOID 'Enable the Paranoid Cocoon Servlet' on
+OPTIONS+= PHP 'Enable the php block' on
+OPTIONS+= POI 'Enable the poi block' on
+OPTIONS+= PORTAL_FW 'Enable the portal-fw block' on
+OPTIONS+= PROFILER 'Enable the profiler block' on
+OPTIONS+= PYTHON 'Enable the python block' on
+OPTIONS+= SESSION_FW 'Enable the session-fw block' on
+OPTIONS+= SWF 'Enable the swf block' on
+OPTIONS+= VELOCITY 'Enable the velocity block' on
+OPTIONS+= WEB3 'Enable the web3 block' on
+OPTIONS+= XMLDB 'Enable the xmldb block' on
+OPTIONS+= XSP 'Enable the xsp block' on
+OPTIONS+= APPLES 'Enable the apples block' on
+OPTIONS+= ASCIIART 'Enable the asciiart block' on
+OPTIONS+= AXIS 'Enable the axis block' on
+OPTIONS+= CRON 'Enable the cron block' on
+OPTIONS+= DELI 'Enable the deli block' on
+OPTIONS+= EVENTCACHE 'Enable the eventcache block' on
+OPTIONS+= FORMS 'Enable the forms block' on
+OPTIONS+= JAVAFLOW 'Enable the javaflow block' on
+OPTIONS+= JMS 'Enable the jms block' on
+OPTIONS+= LINOTYPE 'Enable the linotype block' on
+OPTIONS+= MAIL 'Enable the mail block' on
+OPTIONS+= MIDI 'Enable the midi block' on
+OPTIONS+= OJB 'Enable the ojb block' on
+OPTIONS+= PETSTORE 'Enable the petstore block' on
+OPTIONS+= PORTAL 'Enable the portal block' on
+OPTIONS+= PROXY 'Enable the proxy block' on
+OPTIONS+= QDOX 'Enable the qdox block' on
+OPTIONS+= REPOSITORY 'Enable the repository block' on
+OPTIONS+= SCRATCHPAD 'Enable the scratchpad block' on
+OPTIONS+= SERIALIZERS 'Enable the serializers block' on
+OPTIONS+= SLIDE 'Enable the slide block' on
+OPTIONS+= SLOP 'Enable the slop block' on
+OPTIONS+= STX 'Enable the stx block' on
+OPTIONS+= TAGLIB 'Enable the taglib block' on
+OPTIONS+= TOUR 'Enable the tour block' on
+OPTIONS+= WEBDAV 'Enable the webdav block' on
+OPTIONS+= WOODY 'Enable the woody block' off