aboutsummaryrefslogtreecommitdiff
path: root/www/dalbum/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-11 17:56:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-11 17:56:26 +0000
commit2c0177e347de3ea5a3949d9d7ea0e87c19e69275 (patch)
treebbacba08341c374004a4d1dc33bd7b5f6d97cd29 /www/dalbum/Makefile
parent03fc24b6bebfb2e6799f23249fd2efa916ddfff7 (diff)
downloadports-2c0177e347de3ea5a3949d9d7ea0e87c19e69275.tar.gz
ports-2c0177e347de3ea5a3949d9d7ea0e87c19e69275.zip
- Add LICENSE
- Add missing USES=php - Move permission handling to plist - Regenerate patches
Notes
Notes: svn path=/head/; revision=421854
Diffstat (limited to 'www/dalbum/Makefile')
-rw-r--r--www/dalbum/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/dalbum/Makefile b/www/dalbum/Makefile
index 8bbb163a2c4b..126c99e59c6b 100644
--- a/www/dalbum/Makefile
+++ b/www/dalbum/Makefile
@@ -11,9 +11,12 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Free, highly customizable PHP photo album
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/license.txt
+
RUN_DEPENDS= convert:graphics/ImageMagick
-USES= cpe
+USES= cpe php
CPE_VERSION= ${PORTVERSION:C/^([0-9])([0-9][0-9]).*/\1.\2/}
CPE_UPDATE= ${PORTVERSION:C/^.*\.//}
USE_PHP= session pcre
@@ -32,7 +35,7 @@ post-patch:
@${RM} ${WRKSRC}/config/config.php.*
do-install:
- @${MKDIR} -m 0775 ${STAGEDIR}${PREFIX}/${DALBUM_DIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${DALBUM_DIR}
@cd ${WRKSRC} && ${FIND} .htaccess .private config images include pictures *.css *.js *.php *.txt -print | \
${CPIO} --quiet -pdum \
${STAGEDIR}${PREFIX}/${DALBUM_DIR}