aboutsummaryrefslogtreecommitdiff
path: root/www/dansguardian-devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-01-05 01:20:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-01-05 01:20:29 +0000
commit8883a7f87a6d6374805bbeb1ef93639f9fe736f2 (patch)
tree91ec7b23cad3e332131f7913293bac12fb9be808 /www/dansguardian-devel
parent0d3df9cca5be0533d9c515e978118f1ece157a64 (diff)
downloadports-8883a7f87a6d6374805bbeb1ef93639f9fe736f2.tar.gz
ports-8883a7f87a6d6374805bbeb1ef93639f9fe736f2.zip
Re-add www/dansguardian-devel with new alpha version 2.12.0.0
Requested by: Marcello Coutinho <marcellocoutinho@gmail.com> Thanks to: dougb@
Notes
Notes: svn path=/head/; revision=288534
Diffstat (limited to 'www/dansguardian-devel')
-rw-r--r--www/dansguardian-devel/Makefile137
-rw-r--r--www/dansguardian-devel/distinfo2
-rw-r--r--www/dansguardian-devel/files/dansguardian.in31
-rw-r--r--www/dansguardian-devel/pkg-descr19
-rw-r--r--www/dansguardian-devel/pkg-message15
-rw-r--r--www/dansguardian-devel/pkg-plist377
6 files changed, 581 insertions, 0 deletions
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
new file mode 100644
index 000000000000..32e56481ba15
--- /dev/null
+++ b/www/dansguardian-devel/Makefile
@@ -0,0 +1,137 @@
+# New ports collection makefile for: dansguardian
+# Date created: April 02, 2002
+# Whom: Freddie Cash <fjwcash@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dansguardian
+PORTVERSION= 2.12.0.0
+CATEGORIES= www
+MASTER_SITES= # empty, see below
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= A fast, feature-rich web content filter for Squid proxy servers
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
+USE_RC_SUBR= dansguardian
+USE_GNOME= pkgconfig
+
+CONFLICTS= dansguardian-2.10.*
+LATEST_LINK= dansguardian-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var \
+ --with-logdir=/var/log \
+ --with-piddir=/var/run \
+ --with-libiconv=${LOCALBASE} \
+ --enable-fancydm
+
+MAN8= dansguardian.8
+
+OPTIONS= APACHE "Enable Apache support for access denied page" on \
+ TRICKLE "Enable the trickle download manager" on \
+ CLISCAN "Enable support for CLI content scanners" off \
+ CLAMD "Enable ClamAV daemon support (clamd)" off \
+ ICAP "Enable ICAP AV content scanner support (testing)" off \
+ KAV "Enable Kaspersky AV support (testing)" off \
+ NTLM "Enable NTLM authentication plugin" off \
+ EMAIL "Enable e-mail reporting support" off \
+ DEBUG "Enable debug options - not for production use" off
+
+DG_URL= http://dansguardian.org/index.php?page=copyright2
+CONFDIR= ${PREFIX}/etc/dansguardian
+
+RESTRICTED= Redistribution and commercial download is restricted. Check ${DG_URL} for more info
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_APACHE)
+USE_APACHE= 20+
+.endif
+
+.if !defined(WITHOUT_TRICKLE)
+CONFIGURE+= --enable-trickledm
+PLIST_SUB+= TRICKLECONF=""
+.else
+PLIST_SUB+= TRICKLECONF="@comment "
+.endif
+
+.if defined(WITH_CLISCAN)
+CONFIGURE_ARGS+= --enable-commandline
+PLIST_SUB+= CLISCANCONF=""
+.else
+PLIST_SUB+= CLISCANCONF="@comment "
+.endif
+
+.if defined(WITH_CLAMD)
+CONFIGURE_ARGS+= --enable-clamd
+RUN_DEPENDS+= ${LOCALBASE}/sbin/clamd:${PORTSDIR}/security/clamav
+PLIST_SUB+= CLAMDCONF=""
+.else
+PLIST_SUB+= CLAMDCONF="@comment "
+.endif
+
+.if defined(WITH_ICAP)
+CONFIGURE_ARGS+= --enable-icap
+PLIST_SUB+= ICAPCONF=""
+.else
+PLIST_SUB+= ICAPCONF="@comment "
+.endif
+
+.if defined(WITH_KAV)
+CONFIGURE_ARGS+= --enable-kavd
+PLIST_SUB+= KAVDCONF=""
+.else
+PLIST_SUB+= KAVDCONF="@comment "
+.endif
+
+.if defined(WITH_CLAMD) || defined(WITH_ICAP) || defined(WITH_KAV) || defined(WITH_CLISCAN)
+PLIST_SUB+= SCANNERS=""
+.else
+PLIST_SUB+= SCANNERS="@comment "
+.endif
+
+.if defined(WITH_NTLM)
+CONFIGURE_ARGS+= --enable-ntlm --with-libiconv=${LOCALBASE}
+USE_ICONV= yes
+PLIST_SUB+= NTLMCONF=""
+.else
+PLIST_SUB+= NTLMCONF="@comment "
+.endif
+
+.if defined(WITH_EMAIL)
+CONFIGURE_ARGS+= --enable-email
+PLIST_SUB+= EMAILCONF=""
+.else
+PLIST_SUB+= EMAILCONF="@comment "
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-dgdebug
+.endif
+
+#.if defined(NOPORTDOCS)
+#PLISTSUB+= DOCINST="@comment "
+#.else
+#PLISTSUB+= DOCINST=""
+#.endif
+
+# User needs to manually download the distfile
+.if !(exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})) && !defined(PACKAGE_BUILDING)
+IGNORE= commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make
+.endif
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/install-data-am/ s|install-dist_docDATA||' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+
+post-install:
+# Display post-install message
+ @${CAT} pkg-message
+
+.include <bsd.port.post.mk>
diff --git a/www/dansguardian-devel/distinfo b/www/dansguardian-devel/distinfo
new file mode 100644
index 000000000000..b753786228eb
--- /dev/null
+++ b/www/dansguardian-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dansguardian-2.12.0.0.tar.gz) = 625ee95d00b80d340ae0d05df4ca44396c042ea944fde90b2a75542bdbc424a4
+SIZE (dansguardian-2.12.0.0.tar.gz) = 596435
diff --git a/www/dansguardian-devel/files/dansguardian.in b/www/dansguardian-devel/files/dansguardian.in
new file mode 100644
index 000000000000..d4c7c8b2c3cd
--- /dev/null
+++ b/www/dansguardian-devel/files/dansguardian.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: dansguardian
+# REQUIRE: NETWORKING SERVERS squid
+# KEYWORD: shutdown
+
+# Define these dansguardian_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/dansguardian
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+# dansguardian_enable="YES"
+# dansguardian_flags="<set as needed>"
+
+dansguardian_enable=${dansguardian_enable:-"NO"}
+dansguardian_pidfile=${dansguardian_pidfile:-"/var/run/dansguardian.pid"}
+
+. /etc/rc.subr
+
+name="dansguardian"
+rcvar=${name}_enable
+command="%%PREFIX%%/sbin/${name}"
+
+load_rc_config $name
+
+pidfile="${dansguardian_pidfile}"
+
+run_rc_command "$1"
diff --git a/www/dansguardian-devel/pkg-descr b/www/dansguardian-devel/pkg-descr
new file mode 100644
index 000000000000..1fc44ff0d35f
--- /dev/null
+++ b/www/dansguardian-devel/pkg-descr
@@ -0,0 +1,19 @@
+DansGuardian is a web content filtering proxy for Linux, FreeBSD, OpenBSD,
+and Solaris. It relies on a proxy server for all fetching of pages. It has
+been most extensively tested with Squid; however, DansGuardian should work
+with any proxy server.
+
+It filters using multiple methods, including:
+ - URL and domain filtering - content phrase filtering
+ - PICS filtering - MIME filtering
+ - file extension filtering - POST filtering
+ - username and source IP filtering - virus filtering
+
+This version also includes support for filter groups (simple ACLs),
+pre-emptive blocking, improved URL caches, and fork pooling for
+improved performance under heavy load.
+
+This is the development version of DansGuardian and is still
+considered to be Beta quality.
+
+WWW: http://dansguardian.org
diff --git a/www/dansguardian-devel/pkg-message b/www/dansguardian-devel/pkg-message
new file mode 100644
index 000000000000..6b13852a12f7
--- /dev/null
+++ b/www/dansguardian-devel/pkg-message
@@ -0,0 +1,15 @@
+===> Please Note:
+
+*******************************************************************************
+ This port has created a log file named dansguardian.log that can get
+ quite large. Please read the newsyslog(8) man page for instructions
+ on configuring log rotation and compression.
+
+ This port has been converted to the new RC framework and should work
+ correctly via rcorder. Please read the comments in the startup script
+ for instructions on enabling the daemon.
+
+ WITH_CLAMAV, WITH_ICAP, WITH_KASP, WITH_NTLM are all experimental
+ options that I am not currently able to test. Let me know how these
+ work (or not) for you. (Patches always welcome.)
+*******************************************************************************
diff --git a/www/dansguardian-devel/pkg-plist b/www/dansguardian-devel/pkg-plist
new file mode 100644
index 000000000000..46c359bf15e2
--- /dev/null
+++ b/www/dansguardian-devel/pkg-plist
@@ -0,0 +1,377 @@
+@exec mkdir -p etc/dansguardian
+@exec mkdir -p etc/dansguardian/authplugins
+%%SCANNERS%%@exec mkdir -p etc/dansguardian/contentscanners
+@exec mkdir -p etc/dansguardian/downloadmanagers
+@exec mkdir -p etc/dansguardian/lists
+@exec mkdir -p etc/dansguardian/lists/authplugins
+@exec mkdir -p etc/dansguardian/lists/blacklists
+@exec mkdir -p etc/dansguardian/lists/blacklists/ads
+%%SCANNERS%%@exec mkdir -p etc/dansguardian/lists/contentscanners
+@exec mkdir -p etc/dansguardian/lists/downloadmanagers
+@exec mkdir -p etc/dansguardian/lists/phraselists
+@exec mkdir -p etc/dansguardian/lists/phraselists/badwords
+@exec mkdir -p etc/dansguardian/lists/phraselists/chat
+@exec mkdir -p etc/dansguardian/lists/phraselists/drugadvocacy
+@exec mkdir -p etc/dansguardian/lists/phraselists/gambling
+@exec mkdir -p etc/dansguardian/lists/phraselists/games
+@exec mkdir -p etc/dansguardian/lists/phraselists/goodphrases
+@exec mkdir -p etc/dansguardian/lists/phraselists/googlesearches
+@exec mkdir -p etc/dansguardian/lists/phraselists/gore
+@exec mkdir -p etc/dansguardian/lists/phraselists/illegaldrugs
+@exec mkdir -p etc/dansguardian/lists/phraselists/intolerance
+@exec mkdir -p etc/dansguardian/lists/phraselists/legaldrugs
+@exec mkdir -p etc/dansguardian/lists/phraselists/malware
+@exec mkdir -p etc/dansguardian/lists/phraselists/news
+@exec mkdir -p etc/dansguardian/lists/phraselists/nudism
+@exec mkdir -p etc/dansguardian/lists/phraselists/peer2peer
+@exec mkdir -p etc/dansguardian/lists/phraselists/personals
+@exec mkdir -p etc/dansguardian/lists/phraselists/pornography
+@exec mkdir -p etc/dansguardian/lists/phraselists/proxies
+@exec mkdir -p etc/dansguardian/lists/phraselists/sport
+@exec mkdir -p etc/dansguardian/lists/phraselists/violence
+@exec mkdir -p etc/dansguardian/lists/phraselists/warezhacking
+@exec mkdir -p etc/dansguardian/lists/phraselists/weapons
+@exec mkdir -p etc/dansguardian/lists/phraselists/webmail
+@exec mkdir -p etc/dansguardian/lists/phraselists/conspiracy
+@exec mkdir -p etc/dansguardian/lists/phraselists/domainsforsale
+@exec mkdir -p etc/dansguardian/lists/phraselists/forums
+@exec mkdir -p etc/dansguardian/lists/phraselists/idtheft
+@exec mkdir -p etc/dansguardian/lists/phraselists/music
+@exec mkdir -p etc/dansguardian/lists/phraselists/rta
+@exec mkdir -p etc/dansguardian/lists/phraselists/safelabel
+@exec mkdir -p etc/dansguardian/lists/phraselists/secretsocieties
+@exec mkdir -p etc/dansguardian/lists/phraselists/translation
+@exec mkdir -p etc/dansguardian/lists/phraselists/travel
+@exec mkdir -p etc/dansguardian/lists/phraselists/upstreamfilter
+@exec mkdir -p %%DATADIR%%
+@exec mkdir -p %%DATADIR%%/languages
+@exec mkdir -p %%DATADIR%%/languages/arspanish
+@exec mkdir -p %%DATADIR%%/languages/bulgarian
+@exec mkdir -p %%DATADIR%%/languages/chinesebig5
+@exec mkdir -p %%DATADIR%%/languages/chinesegb2312
+@exec mkdir -p %%DATADIR%%/languages/czech
+@exec mkdir -p %%DATADIR%%/languages/danish
+@exec mkdir -p %%DATADIR%%/languages/dutch
+@exec mkdir -p %%DATADIR%%/languages/french
+@exec mkdir -p %%DATADIR%%/languages/german
+@exec mkdir -p %%DATADIR%%/languages/hebrew
+@exec mkdir -p %%DATADIR%%/languages/hungarian
+@exec mkdir -p %%DATADIR%%/languages/indonesian
+@exec mkdir -p %%DATADIR%%/languages/italian
+@exec mkdir -p %%DATADIR%%/languages/japanese
+@exec mkdir -p %%DATADIR%%/languages/lithuanian
+@exec mkdir -p %%DATADIR%%/languages/malay
+@exec mkdir -p %%DATADIR%%/languages/mxspanish
+@exec mkdir -p %%DATADIR%%/languages/polish
+@exec mkdir -p %%DATADIR%%/languages/portuguese
+@exec mkdir -p %%DATADIR%%/languages/ptbrazilian
+@exec mkdir -p %%DATADIR%%/languages/russian-1251
+@exec mkdir -p %%DATADIR%%/languages/russian-koi8-r
+@exec mkdir -p %%DATADIR%%/languages/slovak
+@exec mkdir -p %%DATADIR%%/languages/spanish
+@exec mkdir -p %%DATADIR%%/languages/swedish
+@exec mkdir -p %%DATADIR%%/languages/turkish
+@exec mkdir -p %%DATADIR%%/languages/ukenglish
+@exec mkdir -p %%DATADIR%%/scripts
+sbin/dansguardian
+%%DATADIR%%/blockedflash.swf
+%%DATADIR%%/languages/arspanish/messages
+%%DATADIR%%/languages/arspanish/fancydmtemplate.html
+%%DATADIR%%/languages/arspanish/template.html
+%%DATADIR%%/languages/spanish/messages
+%%DATADIR%%/languages/spanish/fancydmtemplate.html
+%%DATADIR%%/languages/spanish/template.html
+%%DATADIR%%/languages/mxspanish/messages
+%%DATADIR%%/languages/mxspanish/fancydmtemplate.html
+%%DATADIR%%/languages/mxspanish/template.html
+%%DATADIR%%/languages/japanese/messages
+%%DATADIR%%/languages/japanese/fancydmtemplate.html
+%%DATADIR%%/languages/japanese/template.html
+%%DATADIR%%/languages/malay/messages
+%%DATADIR%%/languages/malay/fancydmtemplate.html
+%%DATADIR%%/languages/malay/template.html
+%%DATADIR%%/languages/czech/messages
+%%DATADIR%%/languages/czech/fancydmtemplate.html
+%%DATADIR%%/languages/czech/template.html
+%%DATADIR%%/languages/hungarian/messages
+%%DATADIR%%/languages/hungarian/fancydmtemplate.html
+%%DATADIR%%/languages/hungarian/template.html
+%%DATADIR%%/languages/ptbrazilian/messages
+%%DATADIR%%/languages/ptbrazilian/fancydmtemplate.html
+%%DATADIR%%/languages/ptbrazilian/template.html
+%%DATADIR%%/languages/hebrew/messages
+%%DATADIR%%/languages/hebrew/fancydmtemplate.html
+%%DATADIR%%/languages/hebrew/template.html
+%%DATADIR%%/languages/turkish/messages
+%%DATADIR%%/languages/turkish/fancydmtemplate.html
+%%DATADIR%%/languages/turkish/template.html
+%%DATADIR%%/languages/bulgarian/messages
+%%DATADIR%%/languages/bulgarian/fancydmtemplate.html
+%%DATADIR%%/languages/bulgarian/template.html
+%%DATADIR%%/languages/danish/messages
+%%DATADIR%%/languages/danish/fancydmtemplate.html
+%%DATADIR%%/languages/danish/template.html
+%%DATADIR%%/languages/indonesian/messages
+%%DATADIR%%/languages/indonesian/fancydmtemplate.html
+%%DATADIR%%/languages/indonesian/template.html
+%%DATADIR%%/languages/russian-1251/messages
+%%DATADIR%%/languages/russian-1251/fancydmtemplate.html
+%%DATADIR%%/languages/russian-1251/template.html
+%%DATADIR%%/languages/ukenglish/messages
+%%DATADIR%%/languages/ukenglish/fancydmtemplate.html
+%%DATADIR%%/languages/ukenglish/template.html
+%%DATADIR%%/languages/chinesebig5/messages
+%%DATADIR%%/languages/chinesebig5/fancydmtemplate.html
+%%DATADIR%%/languages/chinesebig5/template.html
+%%DATADIR%%/languages/dutch/messages
+%%DATADIR%%/languages/dutch/fancydmtemplate.html
+%%DATADIR%%/languages/dutch/template.html
+%%DATADIR%%/languages/italian/messages
+%%DATADIR%%/languages/italian/fancydmtemplate.html
+%%DATADIR%%/languages/italian/template.html
+%%DATADIR%%/languages/russian-koi8-r/messages
+%%DATADIR%%/languages/russian-koi8-r/fancydmtemplate.html
+%%DATADIR%%/languages/russian-koi8-r/template.html
+%%DATADIR%%/languages/chinesegb2312/messages
+%%DATADIR%%/languages/chinesegb2312/fancydmtemplate.html
+%%DATADIR%%/languages/chinesegb2312/template.html
+%%DATADIR%%/languages/french/messages
+%%DATADIR%%/languages/french/fancydmtemplate.html
+%%DATADIR%%/languages/french/template.html
+%%DATADIR%%/languages/lithuanian/messages
+%%DATADIR%%/languages/lithuanian/fancydmtemplate.html
+%%DATADIR%%/languages/lithuanian/template.html
+%%DATADIR%%/languages/polish/messages
+%%DATADIR%%/languages/polish/fancydmtemplate.html
+%%DATADIR%%/languages/polish/template.html
+%%DATADIR%%/languages/slovak/messages
+%%DATADIR%%/languages/slovak/fancydmtemplate.html
+%%DATADIR%%/languages/slovak/template.html
+%%DATADIR%%/languages/german/messages
+%%DATADIR%%/languages/german/fancydmtemplate.html
+%%DATADIR%%/languages/german/template.html
+%%DATADIR%%/languages/portuguese/messages
+%%DATADIR%%/languages/portuguese/fancydmtemplate.html
+%%DATADIR%%/languages/portuguese/template.html
+%%DATADIR%%/languages/swedish/messages
+%%DATADIR%%/languages/swedish/fancydmtemplate.html
+%%DATADIR%%/languages/swedish/template.html
+%%DATADIR%%/transparent1x1.gif
+%%DATADIR%%/dansguardian.pl
+%%DATADIR%%/scripts/dansguardian
+%%DATADIR%%/scripts/logrotation
+%%DATADIR%%/scripts/bsd-init
+%%DATADIR%%/scripts/solaris-init
+%%DATADIR%%/scripts/systemv-init
+etc/dansguardian/authplugins/ident.conf
+etc/dansguardian/authplugins/ip.conf
+etc/dansguardian/authplugins/proxy-basic.conf
+etc/dansguardian/authplugins/proxy-digest.conf
+%%NTLMCONF%%etc/dansguardian/authplugins/proxy-ntlm.conf
+etc/dansguardian/lists/authplugins/ipgroups
+etc/dansguardian/lists/bannedrooms/default
+etc/dansguardian/lists/exceptionextensionlist
+etc/dansguardian/lists/exceptionfilesitelist
+etc/dansguardian/lists/exceptionmimetypelist
+etc/dansguardian/lists/bannedregexpheaderlist
+etc/dansguardian/lists/exceptionfileurllist
+etc/dansguardian/lists/headerregexplist
+etc/dansguardian/lists/logregexpurllist
+etc/dansguardian/lists/logsitelist
+etc/dansguardian/lists/logurllist
+etc/dansguardian/lists/blacklists/ads/domains
+etc/dansguardian/lists/blacklists/ads/urls
+etc/dansguardian/lists/downloadmanagers/managedextensionlist
+etc/dansguardian/lists/downloadmanagers/managedmimetypelist
+etc/dansguardian/lists/phraselists/badwords/weighted_dutch
+etc/dansguardian/lists/phraselists/badwords/weighted_french
+etc/dansguardian/lists/phraselists/badwords/weighted_german
+etc/dansguardian/lists/phraselists/badwords/weighted_portuguese
+etc/dansguardian/lists/phraselists/badwords/weighted_spanish
+etc/dansguardian/lists/phraselists/chat/weighted
+etc/dansguardian/lists/phraselists/chat/weighted_italian
+etc/dansguardian/lists/phraselists/drugadvocacy/weighted
+etc/dansguardian/lists/phraselists/gambling/weighted
+etc/dansguardian/lists/phraselists/gambling/weighted_portuguese
+etc/dansguardian/lists/phraselists/gambling/banned
+etc/dansguardian/lists/phraselists/gambling/banned_portuguese
+etc/dansguardian/lists/phraselists/games/weighted
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general_danish
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general_dutch
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general_malay
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general_polish
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general_portuguese
+etc/dansguardian/lists/phraselists/goodphrases/weighted_general_swedish
+etc/dansguardian/lists/phraselists/goodphrases/weighted_news
+etc/dansguardian/lists/phraselists/goodphrases/exception
+etc/dansguardian/lists/phraselists/goodphrases/exception_email
+etc/dansguardian/lists/phraselists/googlesearches/banned
+etc/dansguardian/lists/phraselists/gore/weighted
+etc/dansguardian/lists/phraselists/gore/weighted_portuguese
+etc/dansguardian/lists/phraselists/illegaldrugs/weighted
+etc/dansguardian/lists/phraselists/illegaldrugs/weighted_portuguese
+etc/dansguardian/lists/phraselists/illegaldrugs/banned
+etc/dansguardian/lists/phraselists/intolerance/weighted
+etc/dansguardian/lists/phraselists/intolerance/weighted_portuguese
+etc/dansguardian/lists/phraselists/intolerance/banned_portuguese
+etc/dansguardian/lists/phraselists/legaldrugs/weighted
+etc/dansguardian/lists/phraselists/malware/weighted
+etc/dansguardian/lists/phraselists/news/weighted
+etc/dansguardian/lists/phraselists/nudism/weighted
+etc/dansguardian/lists/phraselists/peer2peer/weighted
+etc/dansguardian/lists/phraselists/personals/weighted
+etc/dansguardian/lists/phraselists/personals/weighted_portuguese
+etc/dansguardian/lists/phraselists/pornography/banned
+etc/dansguardian/lists/phraselists/pornography/banned_portuguese
+etc/dansguardian/lists/phraselists/pornography/weighted
+etc/dansguardian/lists/phraselists/pornography/weighted_chinese
+etc/dansguardian/lists/phraselists/pornography/weighted_danish
+etc/dansguardian/lists/phraselists/pornography/weighted_dutch
+etc/dansguardian/lists/phraselists/pornography/weighted_french
+etc/dansguardian/lists/phraselists/pornography/weighted_german
+etc/dansguardian/lists/phraselists/pornography/weighted_italian
+etc/dansguardian/lists/phraselists/pornography/weighted_japanese
+etc/dansguardian/lists/phraselists/pornography/weighted_malay
+etc/dansguardian/lists/phraselists/pornography/weighted_norwegian
+etc/dansguardian/lists/phraselists/pornography/weighted_polish
+etc/dansguardian/lists/phraselists/pornography/weighted_portuguese
+etc/dansguardian/lists/phraselists/pornography/weighted_russian
+etc/dansguardian/lists/phraselists/pornography/weighted_russian_utf8
+etc/dansguardian/lists/phraselists/pornography/weighted_spanish
+etc/dansguardian/lists/phraselists/pornography/weighted_swedish
+etc/dansguardian/lists/phraselists/proxies/weighted
+etc/dansguardian/lists/phraselists/sport/weighted
+etc/dansguardian/lists/phraselists/violence/weighted
+etc/dansguardian/lists/phraselists/violence/weighted_portuguese
+etc/dansguardian/lists/phraselists/warezhacking/weighted
+etc/dansguardian/lists/phraselists/weapons/weighted
+etc/dansguardian/lists/phraselists/weapons/weighted_portuguese
+etc/dansguardian/lists/phraselists/webmail/weighted
+etc/dansguardian/lists/phraselists/conspiracy/weighted
+etc/dansguardian/lists/phraselists/domainsforsale/weighted
+etc/dansguardian/lists/phraselists/forums/weighted
+etc/dansguardian/lists/phraselists/idtheft/weighted
+etc/dansguardian/lists/phraselists/music/weighted
+etc/dansguardian/lists/phraselists/rta/banned
+etc/dansguardian/lists/phraselists/safelabel/banned
+etc/dansguardian/lists/phraselists/secretsocieties/weighted
+etc/dansguardian/lists/phraselists/translation/weighted
+etc/dansguardian/lists/phraselists/travel/weighted
+etc/dansguardian/lists/phraselists/upstreamfilter/weighted
+etc/dansguardian/lists/bannedextensionlist
+etc/dansguardian/lists/bannediplist
+etc/dansguardian/lists/bannedmimetypelist
+etc/dansguardian/lists/bannedregexpurllist
+etc/dansguardian/lists/bannedsitelist
+etc/dansguardian/lists/bannedurllist
+etc/dansguardian/lists/contentregexplist
+etc/dansguardian/lists/exceptioniplist
+etc/dansguardian/lists/exceptionsitelist
+etc/dansguardian/lists/exceptionurllist
+etc/dansguardian/lists/filtergroupslist
+etc/dansguardian/lists/greysitelist
+etc/dansguardian/lists/greyurllist
+etc/dansguardian/lists/pics
+etc/dansguardian/lists/bannedphraselist
+etc/dansguardian/lists/weightedphraselist
+etc/dansguardian/lists/exceptionphraselist
+etc/dansguardian/lists/urlregexplist
+etc/dansguardian/lists/exceptionregexpurllist
+%%SCANNERS%%etc/dansguardian/lists/contentscanners/exceptionvirusmimetypelist
+%%SCANNERS%%etc/dansguardian/lists/contentscanners/exceptionvirusextensionlist
+%%SCANNERS%%etc/dansguardian/lists/contentscanners/exceptionvirussitelist
+%%SCANNERS%%etc/dansguardian/lists/contentscanners/exceptionvirusurllist
+etc/dansguardian/downloadmanagers/default.conf
+etc/dansguardian/downloadmanagers/fancy.conf
+%%CLAMDCONF%%etc/dansguardian/contentscanners/clamdscan.conf
+%%KAVDCONF%%etc/dansguardian/contentscanners/kavdscan.conf
+%%ICAPCONF%%etc/dansguardian/contentscanners/icapscan.conf
+%%CLISCANCONF%%etc/dansguardian/contentscanners/commandlinescan.conf
+etc/dansguardian/dansguardian.conf
+etc/dansguardian/dansguardianf1.conf
+%%PORTDOCS%%%%DOCSDIR%%/AuthPlugins
+%%PORTDOCS%%%%DOCSDIR%%/ContentScanners
+%%PORTDOCS%%%%DOCSDIR%%/DownloadManagers
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/Plugins
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/languages/arspanish
+@dirrm %%DATADIR%%/languages/bulgarian
+@dirrm %%DATADIR%%/languages/chinesebig5
+@dirrm %%DATADIR%%/languages/chinesegb2312
+@dirrm %%DATADIR%%/languages/czech
+@dirrm %%DATADIR%%/languages/danish
+@dirrm %%DATADIR%%/languages/dutch
+@dirrm %%DATADIR%%/languages/french
+@dirrm %%DATADIR%%/languages/german
+@dirrm %%DATADIR%%/languages/hebrew
+@dirrm %%DATADIR%%/languages/hungarian
+@dirrm %%DATADIR%%/languages/indonesian
+@dirrm %%DATADIR%%/languages/italian
+@dirrm %%DATADIR%%/languages/japanese
+@dirrm %%DATADIR%%/languages/lithuanian
+@dirrm %%DATADIR%%/languages/malay
+@dirrm %%DATADIR%%/languages/mxspanish
+@dirrm %%DATADIR%%/languages/polish
+@dirrm %%DATADIR%%/languages/portuguese
+@dirrm %%DATADIR%%/languages/ptbrazilian
+@dirrm %%DATADIR%%/languages/russian-1251
+@dirrm %%DATADIR%%/languages/russian-koi8-r
+@dirrm %%DATADIR%%/languages/slovak
+@dirrm %%DATADIR%%/languages/spanish
+@dirrm %%DATADIR%%/languages/swedish
+@dirrm %%DATADIR%%/languages/turkish
+@dirrm %%DATADIR%%/languages/ukenglish
+@dirrm %%DATADIR%%/languages
+@dirrm %%DATADIR%%
+@dirrm etc/dansguardian/lists/bannedrooms
+@dirrm etc/dansguardian/lists/phraselists/badwords
+@dirrm etc/dansguardian/lists/phraselists/chat
+@dirrm etc/dansguardian/lists/phraselists/drugadvocacy
+@dirrm etc/dansguardian/lists/phraselists/gambling
+@dirrm etc/dansguardian/lists/phraselists/games
+@dirrm etc/dansguardian/lists/phraselists/goodphrases
+@dirrm etc/dansguardian/lists/phraselists/googlesearches
+@dirrm etc/dansguardian/lists/phraselists/gore
+@dirrm etc/dansguardian/lists/phraselists/illegaldrugs
+@dirrm etc/dansguardian/lists/phraselists/intolerance
+@dirrm etc/dansguardian/lists/phraselists/legaldrugs
+@dirrm etc/dansguardian/lists/phraselists/malware
+@dirrm etc/dansguardian/lists/phraselists/news
+@dirrm etc/dansguardian/lists/phraselists/nudism
+@dirrm etc/dansguardian/lists/phraselists/peer2peer
+@dirrm etc/dansguardian/lists/phraselists/personals
+@dirrm etc/dansguardian/lists/phraselists/pornography
+@dirrm etc/dansguardian/lists/phraselists/proxies
+@dirrm etc/dansguardian/lists/phraselists/sport
+@dirrm etc/dansguardian/lists/phraselists/violence
+@dirrm etc/dansguardian/lists/phraselists/warezhacking
+@dirrm etc/dansguardian/lists/phraselists/weapons
+@dirrm etc/dansguardian/lists/phraselists/webmail
+@dirrm etc/dansguardian/lists/phraselists/conspiracy
+@dirrm etc/dansguardian/lists/phraselists/domainsforsale
+@dirrm etc/dansguardian/lists/phraselists/forums
+@dirrm etc/dansguardian/lists/phraselists/idtheft
+@dirrm etc/dansguardian/lists/phraselists/music
+@dirrm etc/dansguardian/lists/phraselists/rta
+@dirrm etc/dansguardian/lists/phraselists/safelabel
+@dirrm etc/dansguardian/lists/phraselists/secretsocieties
+@dirrm etc/dansguardian/lists/phraselists/translation
+@dirrm etc/dansguardian/lists/phraselists/travel
+@dirrm etc/dansguardian/lists/phraselists/upstreamfilter
+@dirrm etc/dansguardian/lists/phraselists
+@dirrm etc/dansguardian/lists/downloadmanagers
+%%SCANNERS%%@dirrm etc/dansguardian/lists/contentscanners
+@dirrm etc/dansguardian/lists/blacklists/ads
+@dirrm etc/dansguardian/lists/blacklists
+@dirrm etc/dansguardian/lists/authplugins
+@dirrm etc/dansguardian/lists
+@dirrm etc/dansguardian/downloadmanagers
+%%SCANNERS%%@dirrm etc/dansguardian/contentscanners
+@dirrm etc/dansguardian/authplugins
+@dirrm etc/dansguardian
+@unexec echo If permanently deleting this package, /var/log/dansguardian.log must be removed manually
+@unexec echo If permanently deleting this package, custom configuration files must be removed manually