aboutsummaryrefslogtreecommitdiff
path: root/www/devd
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-15 04:40:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-15 04:40:50 +0000
commit2fcf1f9bbc58175d931b5e433536685c6d336248 (patch)
tree36e367aa7bc81ed04948a232580865ebd0894507 /www/devd
parent7914e2e4ffa748e369c76f9a835f4dff1a554c53 (diff)
downloadports-2fcf1f9bbc58175d931b5e433536685c6d336248.tar.gz
ports-2fcf1f9bbc58175d931b5e433536685c6d336248.zip
New port: www/devd: Local webserver for developers
Notes
Notes: svn path=/head/; revision=504225
Diffstat (limited to 'www/devd')
-rw-r--r--www/devd/Makefile23
-rw-r--r--www/devd/distinfo3
-rw-r--r--www/devd/pkg-descr10
3 files changed, 36 insertions, 0 deletions
diff --git a/www/devd/Makefile b/www/devd/Makefile
new file mode 100644
index 000000000000..f15b6a4b83a1
--- /dev/null
+++ b/www/devd/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= devd
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9
+CATEGORIES= www
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Local webserver for developers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= cortesi
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= ${GO_PKGNAME}/cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/devd/distinfo b/www/devd/distinfo
new file mode 100644
index 000000000000..76baf36d2eff
--- /dev/null
+++ b/www/devd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1560573058
+SHA256 (cortesi-devd-v0.9_GH0.tar.gz) = 5aee062c49ffba1e596713c0c32d88340360744f57619f95809d01c59bff071f
+SIZE (cortesi-devd-v0.9_GH0.tar.gz) = 5120152
diff --git a/www/devd/pkg-descr b/www/devd/pkg-descr
new file mode 100644
index 000000000000..3391871f29d4
--- /dev/null
+++ b/www/devd/pkg-descr
@@ -0,0 +1,10 @@
+Devd is a single statically compiled binary with no external dependencies.
+No need to install gigantic frameworks like Node JS, just copy over the devd
+binary and be done with it.
+
+No config file, no daemonization, and logs that are designed to be read in the
+terminal by a developer. Logs are colorized and log entries span multiple lines.
+Devd's logs are detailed, warn about corner cases that other daemons ignore, and
+can optionally include things like detailed timing information and full headers.
+
+WWW: https://github.com/cortesi/devd