aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2007-10-03 17:26:00 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2007-10-03 17:26:00 +0000
commita8d5e8bd519ca47649dd87ca8a7586daef28bd78 (patch)
tree3da7b300c236583ae49a2ef4d3e5dbd20740fdfc /www/dillo2
parent7e67407bc97576f48967326a44b9e0c49c4d30ee (diff)
downloadports-a8d5e8bd519ca47649dd87ca8a7586daef28bd78.tar.gz
ports-a8d5e8bd519ca47649dd87ca8a7586daef28bd78.zip
Respect the global WITHOUT_IPV6 and local WITHOUT_DILLO_IPV6.
Approved by: maintainer(Thomas-Martin Seck <tmseck@netcologne.de>)
Notes
Notes: svn path=/head/; revision=200741
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index c1b664c1dd6e..0310242f2c25 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -30,8 +30,11 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
+CONFIGURE_ARGS= --enable-cookies --enable-threaded-dns \
--libdir=${PREFIX}/libexec
+.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
.if defined(WITH_DILLO_SSL)
CONFIGURE_ARGS+= --enable-ssl
@@ -69,6 +72,11 @@ pre-configure:
@${ECHO_CMD} " Set WITH_DILLO_DLGUI=yes in your make environment or on the"
@${ECHO_CMD} " commandline to enable a FLTK2 based gui for download operations."
.endif
+.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Set WITHOUT_DILLO_IPV6=yes (or WITHOUT_IPV6=yes) in your make"
+ @${ECHO_CMD} " environment or on the commandline to disable IPv6 support."
+.endif
@${ECHO_CMD} ""
.include <bsd.port.mk>