aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-02-26 10:36:27 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-02-26 10:36:27 +0000
commite27be0e14ff8f2131933a8bfe5767aa38882bcf7 (patch)
treea29936eeda1a6de8342e5bc76b465084e9ec530d /www/dillo2
parent87be5af1131bf39a962b4ffe36c0cf3e2a587b1c (diff)
downloadports-e27be0e14ff8f2131933a8bfe5767aa38882bcf7.tar.gz
ports-e27be0e14ff8f2131933a8bfe5767aa38882bcf7.zip
Add dillo 0.3.2, a fast, small graphical Web browser built upon GTK+.
PR: 25312 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Notes
Notes: svn path=/head/; revision=38783
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile25
-rw-r--r--www/dillo2/distinfo1
-rw-r--r--www/dillo2/files/patch-aa38
-rw-r--r--www/dillo2/pkg-comment1
-rw-r--r--www/dillo2/pkg-descr17
-rw-r--r--www/dillo2/pkg-plist1
6 files changed, 83 insertions, 0 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
new file mode 100644
index 000000000000..8825cdd71ae7
--- /dev/null
+++ b/www/dillo2/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: dillo
+# Date created: 23 February 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dillo
+PORTVERSION= 0.3.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ intl.1:${PORTSDIR}/devel/gettext
+
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--includedir="${LOCALBASE}/include" \
+ --libdir="${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/www/dillo2/distinfo b/www/dillo2/distinfo
new file mode 100644
index 000000000000..9ebd0f3e6669
--- /dev/null
+++ b/www/dillo2/distinfo
@@ -0,0 +1 @@
+MD5 (dillo-0.3.2.tar.gz) = 224c2d7cd7bb77457b6aaec28ed19af6
diff --git a/www/dillo2/files/patch-aa b/www/dillo2/files/patch-aa
new file mode 100644
index 000000000000..ff90249ff0e8
--- /dev/null
+++ b/www/dillo2/files/patch-aa
@@ -0,0 +1,38 @@
+--- configure.orig Wed Dec 27 22:36:16 2000
++++ configure Fri Feb 23 15:51:30 2001
+@@ -1617,7 +1617,7 @@
+ jpeg_ok=no
+ fi
+ done
+-
++jpeg_ok=yes
+ fi
+ echo "$ac_t""$jpeg_ok" 1>&6
+ if test "$jpeg_ok" = yes; then
+@@ -1627,14 +1627,14 @@
+ fi
+ fi
+
+-echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
+-echo "configure:1632: checking for pthread_create in -lpthread" >&5
++echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
++echo "configure:1632: checking for pthread_create in -lc_r" >&5
+ ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpthread $LIBS"
++LIBS="-lc_r $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1640 "configure"
+ #include "confdefs.h"
+@@ -1668,7 +1668,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-lc_r $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
diff --git a/www/dillo2/pkg-comment b/www/dillo2/pkg-comment
new file mode 100644
index 000000000000..86c4046af250
--- /dev/null
+++ b/www/dillo2/pkg-comment
@@ -0,0 +1 @@
+A fast, small graphical Web browser built upon GTK+
diff --git a/www/dillo2/pkg-descr b/www/dillo2/pkg-descr
new file mode 100644
index 000000000000..7ffe9e193fce
--- /dev/null
+++ b/www/dillo2/pkg-descr
@@ -0,0 +1,17 @@
+Dillo is a web browser project completely written in C (currently the code
+is based on gzilla-0.2.2's widget, and a new improved network engine
+written from scratch).
+
+Dillo is small; source and binary are less than 220 Kb each.
+
+Dillo aims to be a multiplataform browser alternative that's small,
+stable, developer-friendly, usable, fast, and extensible.
+
+Dillo is mainly based on GTK+ (GNOME is NOT required!)
+
+Dillo is very fast!
+
+WWW: http://dillo.sourceforge.net/
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/www/dillo2/pkg-plist b/www/dillo2/pkg-plist
new file mode 100644
index 000000000000..b339b7ba6971
--- /dev/null
+++ b/www/dillo2/pkg-plist
@@ -0,0 +1 @@
+bin/dillo