aboutsummaryrefslogtreecommitdiff
path: root/www/dokuwiki
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-30 05:36:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-30 05:36:26 +0000
commite2d0511a84684d3ccdf4c5f42d394752df7514a2 (patch)
tree7c3b980445b7387c60c73d066a1663976ba61253 /www/dokuwiki
parent428ea32770abeb87333226e72a3e7d9495802e89 (diff)
downloadports-e2d0511a84684d3ccdf4c5f42d394752df7514a2.tar.gz
ports-e2d0511a84684d3ccdf4c5f42d394752df7514a2.zip
- Fix security issue(Image resize DOS-Attack in fetch.php)
- bump PORTREVISION PR: ports/103798 Security: http://bugs.splitbrain.org/?do=details&id=924
Notes
Notes: svn path=/head/; revision=174129
Diffstat (limited to 'www/dokuwiki')
-rw-r--r--www/dokuwiki/Makefile5
-rw-r--r--www/dokuwiki/files/patch-lib-exe-fetch.php24
2 files changed, 28 insertions, 1 deletions
diff --git a/www/dokuwiki/Makefile b/www/dokuwiki/Makefile
index c4439fdba0ed..70c49d7acc26 100644
--- a/www/dokuwiki/Makefile
+++ b/www/dokuwiki/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dokuwiki
PORTVERSION= ${DIST_VER:S/${PORTNAME}//:S/-//g}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://www.splitbrain.org/_media/projects/dokuwiki/ \
http://dev.splitbrain.org/browse/snapshots/
@@ -84,6 +84,9 @@ pre-patch:
@${FIND} ${WRKSRC}/conf -name "*.php.bak" -delete
.endif
+post-patch:
+ @${FIND} ${WRKSRC}/lib/exe -name "*.orig" -delete
+
pre-install:
@${TOUCH} ${WRKSRC}/data/changes.log
diff --git a/www/dokuwiki/files/patch-lib-exe-fetch.php b/www/dokuwiki/files/patch-lib-exe-fetch.php
new file mode 100644
index 000000000000..6210e59c9ea3
--- /dev/null
+++ b/www/dokuwiki/files/patch-lib-exe-fetch.php
@@ -0,0 +1,24 @@
+--- lib/exe/fetch.php.bak Fri Mar 10 04:32:34 2006
++++ lib/exe/fetch.php Fri Sep 29 12:54:09 2006
+@@ -21,8 +21,8 @@
+ //get input
+ $MEDIA = getID('media',false); // no cleaning - maybe external
+ $CACHE = calc_cache($_REQUEST['cache']);
+- $WIDTH = $_REQUEST['w'];
+- $HEIGHT = $_REQUEST['h'];
++ $WIDTH = (int) $_REQUEST['w'];
++ $HEIGHT = (int) $_REQUEST['h'];
+ list($EXT,$MIME) = mimetype($MEDIA);
+ if($EXT === false){
+ $EXT = 'unknown';
+@@ -198,6 +198,10 @@
+ $info = getimagesize($file);
+ if(!$h) $h = round(($w * $info[1]) / $info[0]);
+
++ /*
++ * This is the fix for http://bugs.splitbrain.org/?do=details&id=924
++ */
++ if($w > 2000 || $h > 2000) return $file;
+
+ //cache
+ $local = getCacheName($file,'.media.'.$w.'x'.$h.'.'.$ext);