aboutsummaryrefslogtreecommitdiff
path: root/www/drupal6
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2006-02-22 00:40:20 +0000
committerBrooks Davis <brooks@FreeBSD.org>2006-02-22 00:40:20 +0000
commit68a827096e1709099e9797b5d216efc6a38ec797 (patch)
tree7fdb262bfa03b0013b9d9c94bfd17496c421d1a0 /www/drupal6
parent1356eb4c4be59ca640f1decc47dac73dc9313ed6 (diff)
downloadports-68a827096e1709099e9797b5d216efc6a38ec797.tar.gz
ports-68a827096e1709099e9797b5d216efc6a38ec797.zip
Big port infrastructure overhaul to ease module maintance. The user
visiable changes are: - Use OPTIONS to control php#-mysql and pear-DB (for PostgreSQL support) depends. - Replace the DRUPDIR make variable with DRUPAL_BASE. Other changes include abstracting some command paths and most of the module makefiles out into a bsd.drupal.mk that lives in www/drupal for now. Module updates to follow.
Notes
Notes: svn path=/head/; revision=156631
Diffstat (limited to 'www/drupal6')
-rw-r--r--www/drupal6/Makefile73
-rw-r--r--www/drupal6/bsd.drupal.mk75
-rw-r--r--www/drupal6/files/pkg-message.in10
-rw-r--r--www/drupal6/pkg-plist307
4 files changed, 271 insertions, 194 deletions
diff --git a/www/drupal6/Makefile b/www/drupal6/Makefile
index 7bbca36610bc..31ebcad22f3d 100644
--- a/www/drupal6/Makefile
+++ b/www/drupal6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= drupal
PORTVERSION= 4.6.5
-PORTREVISION= 2006010502
+PORTREVISION= 2006010503
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -16,59 +16,60 @@ DIST_SUBDIR= drupal
MAINTAINER= brooks@FreeBSD.org
COMMENT= CMS that supports pgsql and mysql
+DRUPAL_PORT= yes
+
USE_PHP= gd pcre session xml
WANT_PHP_WEB= yes
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libpq.so)
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if !defined(DRUPDIR)
-pre-fetch:
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Define DRUPDIR to override default of 'www/drupal'."
- @${ECHO_MSG} ""
-.endif
+OPTIONS+= MYSQL "MySQL database support" on \
+ PGSQL "PostgreSQL database support" off
-DRUPDIR?= www/drupal
WWWOWN?= www
WWWGRP?= www
NO_BUILD= yes
DOCS= CHANGELOG.txt INSTALL.txt LICENSE.txt MAINTAINERS.txt
-PLIST_SUB+= DRUPDIR=${DRUPDIR}
-SUB_LIST+= DRUPDIR=${DRUPDIR}
SUB_FILES+= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQL)
+# XXX: should be "USE_PHP+=mysql", but the depends are added too early
+# by bsd.php.mk
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/mysql.so:${PORTSDIR}/${mysql_DEPENDS}
+.endif
+.if defined(WITH_PGSQL)
+RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
do-install:
- ${MKDIR} ${PREFIX}/${DRUPDIR}
- ${CP} ${WRKSRC}/.htaccess ${PREFIX}/${DRUPDIR}
- ${CP} ${WRKSRC}/cron.php ${PREFIX}/${DRUPDIR}
- ${CP} -R ${WRKSRC}/database ${PREFIX}/${DRUPDIR}
- ${CP} ${WRKSRC}/favicon.ico ${PREFIX}/${DRUPDIR}
- ${CP} -R ${WRKSRC}/includes ${PREFIX}/${DRUPDIR}
- ${CP} ${WRKSRC}/index.php ${PREFIX}/${DRUPDIR}
- ${CP} -R ${WRKSRC}/misc ${PREFIX}/${DRUPDIR}
- ${CP} -R ${WRKSRC}/modules ${PREFIX}/${DRUPDIR}
- ${CP} -R ${WRKSRC}/scripts ${PREFIX}/${DRUPDIR}
- ${MKDIR} ${PREFIX}/${DRUPDIR}/sites/default
- ${CP} ${WRKSRC}/sites/default/settings.php ${PREFIX}/${DRUPDIR}/sites/default/settings.php-dist
- @if [ ! -f ${PREFIX}/${DRUPDIR}/sites/default/settings.php ]; then \
- ${CP} -p ${PREFIX}/${DRUPDIR}/sites/default/settings.php-dist ${PREFIX}/${DRUPDIR}/sites/default/settings.php ; \
+ ${MKDIR} ${DRUPAL_DIR}
+ ${CP} ${WRKSRC}/.htaccess ${DRUPAL_DIR}
+ ${CP} ${WRKSRC}/cron.php ${DRUPAL_DIR}
+ ${CP} -R ${WRKSRC}/database ${DRUPAL_DIR}
+ ${CP} ${WRKSRC}/favicon.ico ${DRUPAL_DIR}
+ ${CP} -R ${WRKSRC}/includes ${DRUPAL_DIR}
+ ${CP} ${WRKSRC}/index.php ${DRUPAL_DIR}
+ ${CP} -R ${WRKSRC}/misc ${DRUPAL_DIR}
+ ${CP} -R ${WRKSRC}/modules ${DRUPAL_DIR}
+ ${CP} -R ${WRKSRC}/scripts ${DRUPAL_DIR}
+ ${MKDIR} ${DRUPAL_DIR}/sites/default
+ ${CP} ${WRKSRC}/sites/default/settings.php ${DRUPAL_DIR}/sites/default/settings.php-dist
+ @if [ ! -f ${DRUPAL_DIR}/sites/default/settings.php ]; then \
+ ${CP} -p ${DRUPAL_DIR}/sites/default/settings.php-dist ${DRUPAL_DIR}/sites/default/settings.php ; \
fi
- ${CP} -R ${WRKSRC}/themes ${PREFIX}/${DRUPDIR}
- ${CP} ${WRKSRC}/update.php ${PREFIX}/${DRUPDIR}
- ${CP} ${WRKSRC}/xmlrpc.php ${PREFIX}/${DRUPDIR}
+ ${CP} -R ${WRKSRC}/themes ${DRUPAL_DIR}
+ ${CP} ${WRKSRC}/update.php ${DRUPAL_DIR}
+ ${CP} ${WRKSRC}/xmlrpc.php ${DRUPAL_DIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/${DRUPDIR}/doc
- ${CP} ${DOCS:S|^|${WRKSRC}/|} ${PREFIX}/${DRUPDIR}/doc
+ ${MKDIR} ${DOCSDIR}
+ ${CP} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${DRUPDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DRUPAL_DIR}
post-install:
@${CAT} ${PKGMESSAGE}
+.include "${.CURDIR}/bsd.drupal.mk"
.include <bsd.port.post.mk>
diff --git a/www/drupal6/bsd.drupal.mk b/www/drupal6/bsd.drupal.mk
new file mode 100644
index 000000000000..37fb9249394f
--- /dev/null
+++ b/www/drupal6/bsd.drupal.mk
@@ -0,0 +1,75 @@
+# $FreeBSD$
+#
+
+DRUPAL_BASE?= www/drupal
+DRUPAL_DIR= ${PREFIX}/${DRUPAL_BASE}
+DRUPAL_DOCSDIR?= ${PREFIX}/${DRUPAL_BASE}/doc
+PLIST_SUB+= DRUPAL_BASE=${DRUPAL_BASE}
+SUB_LIST+= DRUPAL_BASE=${DRUPAL_BASE} DRUPAL_DIR=${DRUPAL_DIR}
+
+.if defined(DRUPAL_PORT)
+DOCSDIR?= ${DRUPAL_DOCSDIR}
+.endif
+
+.if defined(DRUPAL_MODULE)
+DRUPAL_VERSION?= 4.6.0
+DRUPAL_MODDIR?= ${DRUPAL_BASE}/modules
+DOCSDIR?= ${DRUPAL_DOCSDIR}/${PORTNAME}
+
+# We have to mirror the distfiles because they are automaticly
+# regenerated snapshots that change size even when nothing changes in the
+# files themselves so they will generally be MASTER_SITE_LOCAL
+MASTER_SITES?= ${MASTER_SITE_LOCAL}
+PKGNAMEPREFIX= drupal-
+DIST_SUBDIR= drupal
+
+RUN_DEPENDS= ${LOCALBASE}/${DRUPAL_BASE}/index.php:${PORTSDIR}/www/drupal
+
+NO_BUILD?= yes
+
+WRKSRC?= ${WRKDIR}/${PORTNAME}
+
+.if defined(MODULE_CONF_FILES)
+SUB_FILES= pkg-install
+SUB_LIST+= CONF_FILES=${MODULE_CONF_FILES:C|^|${DRUPAL_MODDIR}/|} \
+ CONF_DIRS=${MODULE_CONF_DIRS:C|^|${DRUPAL_MODDIR}/|}
+# XXX: where?
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${PKGINSTALL}
+.endif
+
+PLIST_SUB+= DRUPAL_MODDIR=${DRUPAL_MODDIR}
+PLIST_FILES+= ${MODULE_FILES:C|^|%%DRUPAL_MODDIR%%/|}
+PLIST_FILES+= ${MODULE_CONF_FILES:C|^|%%DRUPAL_MODDIR%%/|:C|$|-dist|}
+PLIST_DIRS+= ${MODULE_DIRS:C|^|%%DRUPAL_MODDIR%%/|}
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= ${DOC_FILES:C|^|%%DOCSDIR%%/|}
+PLIST_DIRS+= ${DOC_DIRS:C|^|%%DOCSDIR%%/|}
+PLIST_DIRS+= %%DOCSDIR%%
+.endif
+
+do-install:
+.if defined(MODULE_CONF_DIRS)
+ @${MKDIR} ${MODULE_CONF_DIRS:C|^|${PREFIX}/${DRUPAL_MODDIR}/|}
+.endif
+.if defined(MODULE_DIRS)
+ @${MKDIR} ${MODULE_DIRS:C|^|${PREFIX}/${DRUPAL_MODDIR}/|}
+.endif
+.for f in ${MODULE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${DRUPAL_MODDIR}/${f}
+.endfor
+.for f in ${MODULE_CONF_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${DRUPAL_MODDIR}/${f}-dist
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${DOC_DIRS:C|^|${DOCSDIR}/|}
+.for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/${f}
+.endfor
+.endif
+
+.if defined(MODULE_CONF_FILES)
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+.endif
diff --git a/www/drupal6/files/pkg-message.in b/www/drupal6/files/pkg-message.in
index 10d65e2c1fea..d64eb1b7bc7f 100644
--- a/www/drupal6/files/pkg-message.in
+++ b/www/drupal6/files/pkg-message.in
@@ -4,22 +4,22 @@ You now need to create the DB where Drupal is going to live
createdb -U pgsql -W drupal
createuser -U pgsql -P -e drupal
createlang -U pgsql -W plpgsql drupal
- psql -U drupal drupal < %%PREFIX%%/%%DRUPDIR%%/database/database.pgsql
+ psql -U drupal drupal < %%DRUPAL_DIR%%/database/database.pgsql
MySQL::
mysqladmin -u dba_user -p create drupal
mysql -u dba_user -p
GRANT ALL PRIVILEGES ON drupal.* TO drupal@localhost IDENTIFIED BY 'passwd';
- mysql -u drupal -p drupal < %%PREFIX%%/%%DRUPDIR%%/database/database.mysql"
+ mysql -u drupal -p drupal < %%DRUPAL_DIR%%/database/database.mysql"
-Then edit the %%PREFIX%%/%%DRUPDIR%%/sites/default/settings.php
+Then edit the %%DRUPAL_DIR%%/sites/default/settings.php
to your needs. Once you have done that you must add appropriate
configuration directives to your apache configuration file
(%%PREFIX%%/etc/apache(2)/httpd.conf). A typical configuration would be:
- Alias /drupal "%%PREFIX%%/%%DRUPDIR%%"
+ Alias /drupal "%%DRUPAL_DIR%%"
- <Directory "%%PREFIX%%/%%DRUPDIR%%">
+ <Directory "%%DRUPAL_DIR%%">
Options Indexes FollowSymlinks MultiViews
AllowOverride None
Order allow,deny
diff --git a/www/drupal6/pkg-plist b/www/drupal6/pkg-plist
index 734e8b5dee00..10159905b407 100644
--- a/www/drupal6/pkg-plist
+++ b/www/drupal6/pkg-plist
@@ -1,153 +1,154 @@
-%%DRUPDIR%%/.htaccess
-%%DRUPDIR%%/cron.php
-%%DRUPDIR%%/database/database.mysql
-%%DRUPDIR%%/database/database.pgsql
-%%DRUPDIR%%/database/updates.inc
-%%PORTDOCS%%%%DRUPDIR%%/doc/CHANGELOG.txt
-%%PORTDOCS%%%%DRUPDIR%%/doc/INSTALL.txt
-%%PORTDOCS%%%%DRUPDIR%%/doc/LICENSE.txt
-%%PORTDOCS%%%%DRUPDIR%%/doc/MAINTAINERS.txt
-%%DRUPDIR%%/favicon.ico
-%%DRUPDIR%%/includes/bootstrap.inc
-%%DRUPDIR%%/includes/common.inc
-%%DRUPDIR%%/includes/database.inc
-%%DRUPDIR%%/includes/database.mysql.inc
-%%DRUPDIR%%/includes/database.pgsql.inc
-%%DRUPDIR%%/includes/file.inc
-%%DRUPDIR%%/includes/image.inc
-%%DRUPDIR%%/includes/locale.inc
-%%DRUPDIR%%/includes/menu.inc
-%%DRUPDIR%%/includes/module.inc
-%%DRUPDIR%%/includes/pager.inc
-%%DRUPDIR%%/includes/session.inc
-%%DRUPDIR%%/includes/tablesort.inc
-%%DRUPDIR%%/includes/theme.inc
-%%DRUPDIR%%/includes/xmlrpc.inc
-%%DRUPDIR%%/includes/xmlrpcs.inc
-%%DRUPDIR%%/index.php
-%%DRUPDIR%%/misc/arrow-asc.png
-%%DRUPDIR%%/misc/arrow-desc.png
-%%DRUPDIR%%/misc/blog.png
-%%DRUPDIR%%/misc/drupal.css
-%%DRUPDIR%%/misc/druplicon-small.png
-%%DRUPDIR%%/misc/druplicon.png
-%%DRUPDIR%%/misc/forum-closed.png
-%%DRUPDIR%%/misc/forum-default.png
-%%DRUPDIR%%/misc/forum-hot-new.png
-%%DRUPDIR%%/misc/forum-hot.png
-%%DRUPDIR%%/misc/forum-new.png
-%%DRUPDIR%%/misc/forum-sticky.png
-%%DRUPDIR%%/misc/menu-collapsed.png
-%%DRUPDIR%%/misc/menu-expanded.png
-%%DRUPDIR%%/misc/menu-leaf.png
-%%DRUPDIR%%/misc/powered-by-drupal-dark.png
-%%DRUPDIR%%/misc/powered-by-drupal-light.png
-%%DRUPDIR%%/misc/powered-by-drupal.png
-%%DRUPDIR%%/misc/print.css
-%%DRUPDIR%%/misc/watchdog-error.png
-%%DRUPDIR%%/misc/watchdog-warning.png
-%%DRUPDIR%%/misc/xml.png
-%%DRUPDIR%%/modules/aggregator.module
-%%DRUPDIR%%/modules/archive.module
-%%DRUPDIR%%/modules/block.module
-%%DRUPDIR%%/modules/blog.module
-%%DRUPDIR%%/modules/blogapi.module
-%%DRUPDIR%%/modules/book.module
-%%DRUPDIR%%/modules/comment.module
-%%DRUPDIR%%/modules/contact.module
-%%DRUPDIR%%/modules/drupal.module
-%%DRUPDIR%%/modules/filter.module
-%%DRUPDIR%%/modules/forum.module
-%%DRUPDIR%%/modules/help.module
-%%DRUPDIR%%/modules/legacy.module
-%%DRUPDIR%%/modules/locale.module
-%%DRUPDIR%%/modules/menu.module
-%%DRUPDIR%%/modules/node.module
-%%DRUPDIR%%/modules/page.module
-%%DRUPDIR%%/modules/path.module
-%%DRUPDIR%%/modules/ping.module
-%%DRUPDIR%%/modules/poll.module
-%%DRUPDIR%%/modules/profile.module
-%%DRUPDIR%%/modules/queue.module
-%%DRUPDIR%%/modules/search.module
-%%DRUPDIR%%/modules/statistics.module
-%%DRUPDIR%%/modules/story.module
-%%DRUPDIR%%/modules/system.module
-%%DRUPDIR%%/modules/taxonomy.module
-%%DRUPDIR%%/modules/throttle.module
-%%DRUPDIR%%/modules/tracker.module
-%%DRUPDIR%%/modules/upload.module
-%%DRUPDIR%%/modules/user.module
-%%DRUPDIR%%/modules/watchdog.module
-%%DRUPDIR%%/scripts/code-clean.sh
-%%DRUPDIR%%/scripts/code-style.pl
-%%DRUPDIR%%/scripts/cron-curl.sh
-%%DRUPDIR%%/scripts/cron-lynx.sh
-%%DRUPDIR%%/scripts/prefix.sh
-@unexec if cmp -s %D/%%DRUPDIR%%/sites/default/settings.php-dist %D/%%DRUPDIR%%/sites/default/settings.php; then rm -f %D/%%DRUPDIR%%/sites/default/settings.php; fi
-%%DRUPDIR%%/sites/default/settings.php-dist
-@exec if [ ! -f %D/%%DRUPDIR%%/sites/default/settings.php ] ; then cp -p %D/%F %B/settings.php; fi
-%%DRUPDIR%%/themes/bluemarine/logo.png
-%%DRUPDIR%%/themes/bluemarine/screenshot.png
-%%DRUPDIR%%/themes/bluemarine/style.css
-%%DRUPDIR%%/themes/bluemarine/xtemplate.xtmpl
-%%DRUPDIR%%/themes/chameleon/background.png
-%%DRUPDIR%%/themes/chameleon/chameleon.theme
-%%DRUPDIR%%/themes/chameleon/common.css
-%%DRUPDIR%%/themes/chameleon/logo.png
-%%DRUPDIR%%/themes/chameleon/marvin/bullet.png
-%%DRUPDIR%%/themes/chameleon/marvin/druplicon-watermark.png
-%%DRUPDIR%%/themes/chameleon/marvin/logo.png
-%%DRUPDIR%%/themes/chameleon/marvin/screenshot.png
-%%DRUPDIR%%/themes/chameleon/marvin/style.css
-%%DRUPDIR%%/themes/chameleon/screenshot.png
-%%DRUPDIR%%/themes/chameleon/style.css
-%%DRUPDIR%%/themes/engines/xtemplate/xtemplate.engine
-%%DRUPDIR%%/themes/engines/xtemplate/xtemplate.inc
-%%DRUPDIR%%/themes/pushbutton/arrow-next-hover.png
-%%DRUPDIR%%/themes/pushbutton/arrow-next-visited.png
-%%DRUPDIR%%/themes/pushbutton/arrow-next.png
-%%DRUPDIR%%/themes/pushbutton/arrow-prev-hover.png
-%%DRUPDIR%%/themes/pushbutton/arrow-prev-visited.png
-%%DRUPDIR%%/themes/pushbutton/arrow-prev.png
-%%DRUPDIR%%/themes/pushbutton/arrow-up-hover.png
-%%DRUPDIR%%/themes/pushbutton/arrow-up-visited.png
-%%DRUPDIR%%/themes/pushbutton/arrow-up.png
-%%DRUPDIR%%/themes/pushbutton/background.png
-%%DRUPDIR%%/themes/pushbutton/forum-container.jpg
-%%DRUPDIR%%/themes/pushbutton/forum-link.png
-%%DRUPDIR%%/themes/pushbutton/header-a.jpg
-%%DRUPDIR%%/themes/pushbutton/header-b.jpg
-%%DRUPDIR%%/themes/pushbutton/header-c.png
-%%DRUPDIR%%/themes/pushbutton/icon-block.png
-%%DRUPDIR%%/themes/pushbutton/icon-comment.png
-%%DRUPDIR%%/themes/pushbutton/logo-active.jpg
-%%DRUPDIR%%/themes/pushbutton/logo-background.jpg
-%%DRUPDIR%%/themes/pushbutton/logo-hover.jpg
-%%DRUPDIR%%/themes/pushbutton/logo.png
-%%DRUPDIR%%/themes/pushbutton/screenshot.png
-%%DRUPDIR%%/themes/pushbutton/style.css
-%%DRUPDIR%%/themes/pushbutton/tabs-off.png
-%%DRUPDIR%%/themes/pushbutton/tabs-on.png
-%%DRUPDIR%%/themes/pushbutton/tabs-option-hover.png
-%%DRUPDIR%%/themes/pushbutton/tabs-option-off.png
-%%DRUPDIR%%/themes/pushbutton/tabs-option-on.png
-%%DRUPDIR%%/themes/pushbutton/xtemplate.xtmpl
-%%DRUPDIR%%/update.php
-%%DRUPDIR%%/xmlrpc.php
-@dirrm %%DRUPDIR%%/themes/pushbutton
-@dirrm %%DRUPDIR%%/themes/engines/xtemplate
-@dirrm %%DRUPDIR%%/themes/engines
-@dirrm %%DRUPDIR%%/themes/chameleon/marvin
-@dirrm %%DRUPDIR%%/themes/chameleon
-@dirrm %%DRUPDIR%%/themes/bluemarine
-@dirrm %%DRUPDIR%%/themes
-@dirrmtry %%DRUPDIR%%/sites/default
-@dirrmtry %%DRUPDIR%%/sites
-@dirrm %%DRUPDIR%%/scripts
-@dirrm %%DRUPDIR%%/modules
-@dirrm %%DRUPDIR%%/misc
-@dirrm %%DRUPDIR%%/includes
-%%PORTDOCS%%@dirrm %%DRUPDIR%%/doc
-@dirrm %%DRUPDIR%%/database
-@unexec rmdir %D/%%DRUPDIR%% 2>/dev/null || (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %D/%%DRUPDIR%% and its contents manually.")
+%%DRUPAL_BASE%%/.htaccess
+%%DRUPAL_BASE%%/cron.php
+%%DRUPAL_BASE%%/database/database.mysql
+%%DRUPAL_BASE%%/database/database.pgsql
+%%DRUPAL_BASE%%/database/updates.inc
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/MAINTAINERS.txt
+%%DRUPAL_BASE%%/favicon.ico
+%%DRUPAL_BASE%%/includes/bootstrap.inc
+%%DRUPAL_BASE%%/includes/common.inc
+%%DRUPAL_BASE%%/includes/database.inc
+%%DRUPAL_BASE%%/includes/database.mysql.inc
+%%DRUPAL_BASE%%/includes/database.pgsql.inc
+%%DRUPAL_BASE%%/includes/file.inc
+%%DRUPAL_BASE%%/includes/image.inc
+%%DRUPAL_BASE%%/includes/locale.inc
+%%DRUPAL_BASE%%/includes/menu.inc
+%%DRUPAL_BASE%%/includes/module.inc
+%%DRUPAL_BASE%%/includes/pager.inc
+%%DRUPAL_BASE%%/includes/session.inc
+%%DRUPAL_BASE%%/includes/tablesort.inc
+%%DRUPAL_BASE%%/includes/theme.inc
+%%DRUPAL_BASE%%/includes/xmlrpc.inc
+%%DRUPAL_BASE%%/includes/xmlrpcs.inc
+%%DRUPAL_BASE%%/index.php
+%%DRUPAL_BASE%%/misc/arrow-asc.png
+%%DRUPAL_BASE%%/misc/arrow-desc.png
+%%DRUPAL_BASE%%/misc/blog.png
+%%DRUPAL_BASE%%/misc/drupal.css
+%%DRUPAL_BASE%%/misc/druplicon-small.png
+%%DRUPAL_BASE%%/misc/druplicon.png
+%%DRUPAL_BASE%%/misc/forum-closed.png
+%%DRUPAL_BASE%%/misc/forum-default.png
+%%DRUPAL_BASE%%/misc/forum-hot-new.png
+%%DRUPAL_BASE%%/misc/forum-hot.png
+%%DRUPAL_BASE%%/misc/forum-new.png
+%%DRUPAL_BASE%%/misc/forum-sticky.png
+%%DRUPAL_BASE%%/misc/menu-collapsed.png
+%%DRUPAL_BASE%%/misc/menu-expanded.png
+%%DRUPAL_BASE%%/misc/menu-leaf.png
+%%DRUPAL_BASE%%/misc/powered-by-drupal-dark.png
+%%DRUPAL_BASE%%/misc/powered-by-drupal-light.png
+%%DRUPAL_BASE%%/misc/powered-by-drupal.png
+%%DRUPAL_BASE%%/misc/print.css
+%%DRUPAL_BASE%%/misc/watchdog-error.png
+%%DRUPAL_BASE%%/misc/watchdog-warning.png
+%%DRUPAL_BASE%%/misc/xml.png
+%%DRUPAL_BASE%%/modules/aggregator.module
+%%DRUPAL_BASE%%/modules/archive.module
+%%DRUPAL_BASE%%/modules/block.module
+%%DRUPAL_BASE%%/modules/blog.module
+%%DRUPAL_BASE%%/modules/blogapi.module
+%%DRUPAL_BASE%%/modules/book.module
+%%DRUPAL_BASE%%/modules/comment.module
+%%DRUPAL_BASE%%/modules/contact.module
+%%DRUPAL_BASE%%/modules/drupal.module
+%%DRUPAL_BASE%%/modules/filter.module
+%%DRUPAL_BASE%%/modules/forum.module
+%%DRUPAL_BASE%%/modules/help.module
+%%DRUPAL_BASE%%/modules/legacy.module
+%%DRUPAL_BASE%%/modules/locale.module
+%%DRUPAL_BASE%%/modules/menu.module
+%%DRUPAL_BASE%%/modules/node.module
+%%DRUPAL_BASE%%/modules/page.module
+%%DRUPAL_BASE%%/modules/path.module
+%%DRUPAL_BASE%%/modules/ping.module
+%%DRUPAL_BASE%%/modules/poll.module
+%%DRUPAL_BASE%%/modules/profile.module
+%%DRUPAL_BASE%%/modules/queue.module
+%%DRUPAL_BASE%%/modules/search.module
+%%DRUPAL_BASE%%/modules/statistics.module
+%%DRUPAL_BASE%%/modules/story.module
+%%DRUPAL_BASE%%/modules/system.module
+%%DRUPAL_BASE%%/modules/taxonomy.module
+%%DRUPAL_BASE%%/modules/throttle.module
+%%DRUPAL_BASE%%/modules/tracker.module
+%%DRUPAL_BASE%%/modules/upload.module
+%%DRUPAL_BASE%%/modules/user.module
+%%DRUPAL_BASE%%/modules/watchdog.module
+%%DRUPAL_BASE%%/scripts/code-clean.sh
+%%DRUPAL_BASE%%/scripts/code-style.pl
+%%DRUPAL_BASE%%/scripts/cron-curl.sh
+%%DRUPAL_BASE%%/scripts/cron-lynx.sh
+%%DRUPAL_BASE%%/scripts/prefix.sh
+@unexec if cmp -s %D/%%DRUPAL_BASE%%/sites/default/settings.php-dist %D/%%DRUPAL_BASE%%/sites/default/settings.php; then rm -f %D/%%DRUPAL_BASE%%/sites/default/settings.php; fi
+%%DRUPAL_BASE%%/sites/default/settings.php-dist
+@exec if [ ! -f %D/%%DRUPAL_BASE%%/sites/default/settings.php ] ; then cp -p %D/%F %B/settings.php; fi
+%%DRUPAL_BASE%%/themes/bluemarine/logo.png
+%%DRUPAL_BASE%%/themes/bluemarine/screenshot.png
+%%DRUPAL_BASE%%/themes/bluemarine/style.css
+%%DRUPAL_BASE%%/themes/bluemarine/xtemplate.xtmpl
+%%DRUPAL_BASE%%/themes/chameleon/background.png
+%%DRUPAL_BASE%%/themes/chameleon/chameleon.theme
+%%DRUPAL_BASE%%/themes/chameleon/common.css
+%%DRUPAL_BASE%%/themes/chameleon/logo.png
+%%DRUPAL_BASE%%/themes/chameleon/marvin/bullet.png
+%%DRUPAL_BASE%%/themes/chameleon/marvin/druplicon-watermark.png
+%%DRUPAL_BASE%%/themes/chameleon/marvin/logo.png
+%%DRUPAL_BASE%%/themes/chameleon/marvin/screenshot.png
+%%DRUPAL_BASE%%/themes/chameleon/marvin/style.css
+%%DRUPAL_BASE%%/themes/chameleon/screenshot.png
+%%DRUPAL_BASE%%/themes/chameleon/style.css
+%%DRUPAL_BASE%%/themes/engines/xtemplate/xtemplate.engine
+%%DRUPAL_BASE%%/themes/engines/xtemplate/xtemplate.inc
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-next-hover.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-next-visited.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-next.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-prev-hover.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-prev-visited.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-prev.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-up-hover.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-up-visited.png
+%%DRUPAL_BASE%%/themes/pushbutton/arrow-up.png
+%%DRUPAL_BASE%%/themes/pushbutton/background.png
+%%DRUPAL_BASE%%/themes/pushbutton/forum-container.jpg
+%%DRUPAL_BASE%%/themes/pushbutton/forum-link.png
+%%DRUPAL_BASE%%/themes/pushbutton/header-a.jpg
+%%DRUPAL_BASE%%/themes/pushbutton/header-b.jpg
+%%DRUPAL_BASE%%/themes/pushbutton/header-c.png
+%%DRUPAL_BASE%%/themes/pushbutton/icon-block.png
+%%DRUPAL_BASE%%/themes/pushbutton/icon-comment.png
+%%DRUPAL_BASE%%/themes/pushbutton/logo-active.jpg
+%%DRUPAL_BASE%%/themes/pushbutton/logo-background.jpg
+%%DRUPAL_BASE%%/themes/pushbutton/logo-hover.jpg
+%%DRUPAL_BASE%%/themes/pushbutton/logo.png
+%%DRUPAL_BASE%%/themes/pushbutton/screenshot.png
+%%DRUPAL_BASE%%/themes/pushbutton/style.css
+%%DRUPAL_BASE%%/themes/pushbutton/tabs-off.png
+%%DRUPAL_BASE%%/themes/pushbutton/tabs-on.png
+%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-hover.png
+%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-off.png
+%%DRUPAL_BASE%%/themes/pushbutton/tabs-option-on.png
+%%DRUPAL_BASE%%/themes/pushbutton/xtemplate.xtmpl
+%%DRUPAL_BASE%%/update.php
+%%DRUPAL_BASE%%/xmlrpc.php
+@dirrm %%DRUPAL_BASE%%/themes/pushbutton
+@dirrm %%DRUPAL_BASE%%/themes/engines/xtemplate
+@dirrm %%DRUPAL_BASE%%/themes/engines
+@dirrm %%DRUPAL_BASE%%/themes/chameleon/marvin
+@dirrm %%DRUPAL_BASE%%/themes/chameleon
+@dirrm %%DRUPAL_BASE%%/themes/bluemarine
+@dirrm %%DRUPAL_BASE%%/themes
+@dirrmtry %%DRUPAL_BASE%%/sites/default
+@dirrmtry %%DRUPAL_BASE%%/sites
+@dirrm %%DRUPAL_BASE%%/scripts
+@dirrmtry %%DRUPAL_BASE%%/modules
+@dirrm %%DRUPAL_BASE%%/misc
+@dirrm %%DRUPAL_BASE%%/includes
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DRUPAL_BASE%%/database
+@dirrmtry %%DRUPAL_BASE%%
+@unexec (test -d %D/%%DRUPAL_BASE%% && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %D/%%DRUPAL_BASE%% and its contents manually.")) || true