aboutsummaryrefslogtreecommitdiff
path: root/www/elinks
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2017-02-20 18:46:24 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2017-02-20 18:46:24 +0000
commit3fdf74fad0202455987b3c73e4cb454bba3d5932 (patch)
treec5e20051cc908ccefd52d402631934f722223f4d /www/elinks
parent9825ecf4c7c8c9e5706af540aa0640ffc26a2011 (diff)
downloadports-3fdf74fad0202455987b3c73e4cb454bba3d5932.tar.gz
ports-3fdf74fad0202455987b3c73e4cb454bba3d5932.zip
- Add LICENSE
- Fix build with libressl-devel PR: 216914 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=434484
Diffstat (limited to 'www/elinks')
-rw-r--r--www/elinks/Makefile3
-rw-r--r--www/elinks/files/patch-src_network_ssl_socket.c11
2 files changed, 14 insertions, 0 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index f5e5181360c5..4581aba50a1b 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= http://elinks.or.cz/download/
MAINTAINER= beat@FreeBSD.org
COMMENT= Links text WWW browser with enhancements
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
USES= bison cpe execinfo gmake localbase ssl tar:bzip2
CONFIGURE_ARGS= --without-zlib
diff --git a/www/elinks/files/patch-src_network_ssl_socket.c b/www/elinks/files/patch-src_network_ssl_socket.c
new file mode 100644
index 000000000000..66395cd74ed3
--- /dev/null
+++ b/www/elinks/files/patch-src_network_ssl_socket.c
@@ -0,0 +1,11 @@
+--- src/network/ssl/socket.c.orig 2017-02-08 12:49:43 UTC
++++ src/network/ssl/socket.c
+@@ -67,7 +67,7 @@ static void
+ ssl_set_no_tls(struct socket *socket)
+ {
+ #ifdef CONFIG_OPENSSL
+- ((ssl_t *) socket->ssl)->options |= SSL_OP_NO_TLSv1;
++ SSL_set_options((ssl_t *) socket->ssl, SSL_OP_NO_TLSv1);
+ #elif defined(CONFIG_GNUTLS)
+ {
+ /* GnuTLS does not support SSLv2 because it is "insecure".