aboutsummaryrefslogtreecommitdiff
path: root/www/emacs-w3m/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-07-10 02:57:15 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-07-10 02:57:15 +0000
commitbdf954a1a87b36f44ba6f61c3264c24c4176e26a (patch)
tree9ca5ba7b121ce4a210ee32c2fdc60b5e357d3b4b /www/emacs-w3m/Makefile
parent2bd73027be5b84e09317a5cd1db9c1b86f5ceaf2 (diff)
downloadports-bdf954a1a87b36f44ba6f61c3264c24c4176e26a.tar.gz
ports-bdf954a1a87b36f44ba6f61c3264c24c4176e26a.zip
Fix dependencies for EMACS_PORT_NAME = emacs22.
Notes
Notes: svn path=/head/; revision=167323
Diffstat (limited to 'www/emacs-w3m/Makefile')
-rw-r--r--www/emacs-w3m/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/emacs-w3m/Makefile b/www/emacs-w3m/Makefile
index cc241df99a35..1ffa8592e210 100644
--- a/www/emacs-w3m/Makefile
+++ b/www/emacs-w3m/Makefile
@@ -49,7 +49,7 @@ WITHOUT_OCTET_VIEWER= yes
SHIMBUN= ""
.endif
-.if (${EMACS_PORT_NAME} == "emacs21")
+.if (${EMACS_PORT_NAME} == "emacs21") || (${EMACS_PORT_NAME} == "emacs22")
FLIM_PORT= ${PORTSDIR}/editors/flim
SEMI_PORT= ${PORTSDIR}/editors/semi
MULE_UCS_PORT= ${PORTSDIR}/converters/mule-ucs
@@ -76,8 +76,11 @@ RUN_DEPENDS+= ${FLIM_COOKIE}:${FLIM_PORT}
.if !defined(WITHOUT_OCTET_VIEWER)
RUN_DEPENDS+= ${SEMI_COOKIE}:${SEMI_PORT} \
wvHtml:${PORTSDIR}/textproc/wv \
- xlhtml:${PORTSDIR}/textproc/xlhtml \
- ${MULE_UCS_ELISP_FILE}:${MULE_UCS_PORT}
+ xlhtml:${PORTSDIR}/textproc/xlhtml
+
+.if ${EMACS_PORT_NAME} != "emacs22"
+RUN_DEPENDS+= ${MULE_UCS_ELISP_FILE}:${MULE_UCS_PORT}
+.endif
.endif
pre-everything::