aboutsummaryrefslogtreecommitdiff
path: root/www/envoy/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-06-15 12:34:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-06-15 12:34:54 +0000
commitfd7d97d3361457aaa57b4230aace532a051482f0 (patch)
treea102f0cca1d64eaf05fb34ea54f5a4b1fbb47db2 /www/envoy/Makefile
parent37e74360ea9d0514baaf4df008077e4bacc5a04e (diff)
downloadports-fd7d97d3361457aaa57b4230aace532a051482f0.tar.gz
ports-fd7d97d3361457aaa57b4230aace532a051482f0.zip
www/envoy: connect most of the available extensions to the build.
Diffstat (limited to 'www/envoy/Makefile')
-rw-r--r--www/envoy/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/envoy/Makefile b/www/envoy/Makefile
index 93b79025739e..6765c0d10dd7 100644
--- a/www/envoy/Makefile
+++ b/www/envoy/Makefile
@@ -25,11 +25,13 @@ LIB_DEPENDS= libabsl_base.so:devel/abseil \
libbrotlidec.so:archivers/brotli \
libcares.so:dns/c-ares \
libcircllhist.so:devel/libcircllhist \
+ libcurl.so:ftp/curl \
libevent.so:devel/libevent-devel \
libfmt.so:devel/libfmt \
libgpr.so:devel/grpc \
libicuuc.so:devel/icu \
libnghttp2.so:www/libnghttp2 \
+ libopentracing.so:devel/libopentracing \
libprotobuf.so:devel/protobuf \
libre2.so:devel/re2 \
libxxhash.so:devel/xxhash \
@@ -73,6 +75,8 @@ post-patch:
${WRKSRC}/source/common/network/address_impl.cc
@${REINPLACE_CMD} -e 's,O_SYMLINK,O_NOFOLLOW,' \
${WRKSRC}/source/common/filesystem/kqueue/watcher_impl.cc
+ @${REINPLACE_CMD} -e '/opentracing::v/s,v2,v3,' \
+ ${WRKSRC}/source/extensions/tracers/common/ot/opentracing_driver_impl.cc
@${REINPLACE_CMD} -e '23s,^,#include "absl/status/status.h",' \
${WRKDIR}/cel-cpp-11f9d66/eval/public/ast_traverse.cc
@${REINPLACE_CMD} -e '/^#include "eval\/testutil\/test_message/d' \