aboutsummaryrefslogtreecommitdiff
path: root/www/erlang-mochiweb
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-06-27 12:54:11 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-06-27 12:54:11 +0000
commit683f16618521c66911dd06539b9e9435270de4fb (patch)
tree7d61b3e1ed0576b122e72f1a7f9244ea99379aba /www/erlang-mochiweb
parent721e168e9d060422da130abce2fc6e8b20781eed (diff)
downloadports-683f16618521c66911dd06539b9e9435270de4fb.tar.gz
ports-683f16618521c66911dd06539b9e9435270de4fb.zip
Sorting out some Erlang stuff:
- Rename a few Erlang-related ports using the erlang- prefix; it will avoid confusion with elixir- ports. - Remove DOCS and EXAMPLES where not actually useful. - Simplify RUN_DEPENDS where possible. - Move textproc/exmpp to devel/erlang-exmpp. - Add missing R18 compatibility fix for devel/erlang-oserl. - Upgrade erlang-cuttlefish to 2.0.3. The idea is that libraries ("deps") have the "erlang-" prefix, while larger projects (rabbitmq, yaws, couchdb, etc) keep their usual names.
Notes
Notes: svn path=/head/; revision=390698
Diffstat (limited to 'www/erlang-mochiweb')
-rw-r--r--www/erlang-mochiweb/Makefile42
-rw-r--r--www/erlang-mochiweb/distinfo2
-rw-r--r--www/erlang-mochiweb/pkg-descr4
-rw-r--r--www/erlang-mochiweb/pkg-plist81
4 files changed, 129 insertions, 0 deletions
diff --git a/www/erlang-mochiweb/Makefile b/www/erlang-mochiweb/Makefile
new file mode 100644
index 000000000000..6b9117b22f3d
--- /dev/null
+++ b/www/erlang-mochiweb/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= mochiweb
+PORTVERSION= 2.12.2
+DISTVERSIONPREFIX= v
+CATEGORIES= www devel
+PKGNAMEPREFIX= erlang-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Erlang library for building lightweight HTTP servers
+
+LICENSE= MIT
+
+BUILD_DEPENDS= erl:${PORTSDIR}/lang/erlang
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+CONFLICTS= mochiweb-basho-[0-9]*
+
+USES= cpe
+CPE_VENDOR= mochiweb_project
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+USE_GITHUB= yes
+GH_ACCOUNT= mochi
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ for FILE in CHANGES.md README; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${FILE} ${STAGEDIR}${DOCSDIR}; \
+ done
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
+ ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
+ ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
+
+.include <bsd.port.mk>
diff --git a/www/erlang-mochiweb/distinfo b/www/erlang-mochiweb/distinfo
new file mode 100644
index 000000000000..7213a33822e9
--- /dev/null
+++ b/www/erlang-mochiweb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mochi-mochiweb-v2.12.2_GH0.tar.gz) = 73369f5a2e0d5477632a3d1fa44c674f2dfc98908f86bfd6bd77b266bdb88684
+SIZE (mochi-mochiweb-v2.12.2_GH0.tar.gz) = 284186
diff --git a/www/erlang-mochiweb/pkg-descr b/www/erlang-mochiweb/pkg-descr
new file mode 100644
index 000000000000..5323a5663f62
--- /dev/null
+++ b/www/erlang-mochiweb/pkg-descr
@@ -0,0 +1,4 @@
+MochiWeb is an Erlang library for building lightweight HTTP servers,
+from Mochi Media, Inc.
+
+WWW: https://github.com/mochi/mochiweb
diff --git a/www/erlang-mochiweb/pkg-plist b/www/erlang-mochiweb/pkg-plist
new file mode 100644
index 000000000000..19dc5154a621
--- /dev/null
+++ b/www/erlang-mochiweb/pkg-plist
@@ -0,0 +1,81 @@
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochifmt.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochifmt_records.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochifmt_std.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiglobal.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochihex.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochijson.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochijson2.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochilists.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochilogfile2.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochinum.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochitemp.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiutf8.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb.app
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_acceptor.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_base64url.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_charref.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_cookies.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_cover.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_echo.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_headers.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_html.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_http.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_io.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_mime.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_multipart.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_request.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_response.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_session.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_socket.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_socket_server.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_util.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_websocket.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/ebin/reloader.beam
+lib/erlang/lib/mochiweb-%%VERSION%%/include/internal.hrl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt_records.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt_std.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiglobal.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochihex.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochijson.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochijson2.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochilists.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochilogfile2.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochinum.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochitemp.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiutf8.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb.app.src
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_acceptor.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_base64url.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_charref.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_cookies.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_cover.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_echo.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_headers.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_html.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_http.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_io.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_mime.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_multipart.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_request.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_response.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_session.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_socket.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_socket_server.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_util.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_websocket.erl
+lib/erlang/lib/mochiweb-%%VERSION%%/src/reloader.erl
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.md
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api.hrl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api_client.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api_lib.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https/https_store.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https/server_cert.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https/server_key.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keepalive/keepalive.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/websocket.erl