aboutsummaryrefslogtreecommitdiff
path: root/www/faup
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-11-25 22:07:21 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-11-25 22:07:21 +0000
commitdbaeeeeb71a1d88c4337bb9f1803ad654e570256 (patch)
treea511f77bf3a403d4013384b72356201d6a738079 /www/faup
parent17dcb8e9f485433cf5d16ae80926fae41810c55a (diff)
downloadports-dbaeeeeb71a1d88c4337bb9f1803ad654e570256.tar.gz
ports-dbaeeeeb71a1d88c4337bb9f1803ad654e570256.zip
New port: www/faup
Faup stands for Finally An Url Parser and is a library and command line tool to parse URLs and normalize fields with two constraints: - Work with real-life urls (resilient to badly formated ones) - Be fast: no allocation for string parsing and read characters only once WWW: http://stricaud.github.io/faup/
Notes
Notes: svn path=/head/; revision=334899
Diffstat (limited to 'www/faup')
-rw-r--r--www/faup/Makefile35
-rw-r--r--www/faup/distinfo2
-rw-r--r--www/faup/files/patch-CMakeLists.txt11
-rw-r--r--www/faup/files/patch-src__lib__modules__CMakeLists.txt8
-rw-r--r--www/faup/pkg-descr6
-rw-r--r--www/faup/pkg-plist23
6 files changed, 85 insertions, 0 deletions
diff --git a/www/faup/Makefile b/www/faup/Makefile
new file mode 100644
index 000000000000..0e8fc11e83c0
--- /dev/null
+++ b/www/faup/Makefile
@@ -0,0 +1,35 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= faup
+PORTVERSION= 1.4
+CATEGORIES= www devel
+MASTER_SITES= http://github.com/stricaud/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/ \
+ LOCAL/antoine
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Fast URL decoder library
+
+LICENSE= WTFPL
+LICENSE_NAME= Do What The [expletive] You Want To Public License, Version 2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+FETCH_ARGS= -Fpr
+USES= cmake:outsource
+USE_LDCONFIG= yes
+USE_LUA= 5.1
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/faup/distinfo b/www/faup/distinfo
new file mode 100644
index 000000000000..81c32ed9b7ed
--- /dev/null
+++ b/www/faup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (faup-1.4.tar.gz) = 4cee73571ae35694b4a741c4a6b6fac7039c5e014bc63b67aab716b6ae177086
+SIZE (faup-1.4.tar.gz) = 570002
diff --git a/www/faup/files/patch-CMakeLists.txt b/www/faup/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5d6678024084
--- /dev/null
+++ b/www/faup/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./CMakeLists.txt.orig 2013-09-25 08:53:24.000000000 +0000
++++ ./CMakeLists.txt 2013-11-16 12:02:09.000000000 +0000
+@@ -74,7 +74,7 @@
+
+ set(FAUP_INCLUDE_DIRS "${faup-project_SOURCE_DIR}/src/lib/include/" "${faup-project_BINARY_DIR}/src/lib/include")
+
+-set(FAUP_LIBRARY "${faup-project_BINARY_DIR}/src/lib/libfaupl.so")
++set(FAUP_LIBRARY faupl)
+ if(WIN32)
+ set(FAUP_LIBRARY "${faup-project_BINARY_DIR}/src/lib/${CMAKE_BUILD_TYPE}/faup_static.lib")
+ endif(WIN32)
diff --git a/www/faup/files/patch-src__lib__modules__CMakeLists.txt b/www/faup/files/patch-src__lib__modules__CMakeLists.txt
new file mode 100644
index 000000000000..a2b191b3fa44
--- /dev/null
+++ b/www/faup/files/patch-src__lib__modules__CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./src/lib/modules/CMakeLists.txt.orig 2013-09-25 08:53:24.000000000 +0000
++++ ./src/lib/modules/CMakeLists.txt 2013-11-16 12:02:09.000000000 +0000
+@@ -5,4 +5,4 @@
+
+ install(FILES ${MODULES_AVAILABLE} DESTINATION share/faup/modules_available)
+
+-install(CODE "file(MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/share/faup/modules_enabled)")
++install(DIRECTORY DESTINATION share/faup/modules_enabled)
diff --git a/www/faup/pkg-descr b/www/faup/pkg-descr
new file mode 100644
index 000000000000..fb0553af1958
--- /dev/null
+++ b/www/faup/pkg-descr
@@ -0,0 +1,6 @@
+Faup stands for Finally An Url Parser and is a library and command line tool to
+parse URLs and normalize fields with two constraints:
+- Work with real-life urls (resilient to badly formated ones)
+- Be fast: no allocation for string parsing and read characters only once
+
+WWW: http://stricaud.github.io/faup/
diff --git a/www/faup/pkg-plist b/www/faup/pkg-plist
new file mode 100644
index 000000000000..4bac2d0b65ba
--- /dev/null
+++ b/www/faup/pkg-plist
@@ -0,0 +1,23 @@
+bin/faup
+include/faup/compat.h
+include/faup/datadir.h
+include/faup/decode.h
+include/faup/faup.h
+include/faup/features.h
+include/faup/modules.h
+include/faup/options.h
+include/faup/output.h
+include/faup/portable.h
+include/faup/tld-tree.h
+include/faup/tld.h
+lib/libfaupl.so
+lib/libfaupl.so.1
+%%DATADIR%%/README.txt
+%%DATADIR%%/mozilla.tlds
+%%DATADIR%%/modules_available/emulation_ie.lua
+%%DATADIR%%/modules_available/uppercase.lua
+@exec mkdir -p %D/%%DATADIR%%/modules_enabled
+@dirrm %%DATADIR%%/modules_available
+@dirrm %%DATADIR%%/modules_enabled
+@dirrm %%DATADIR%%
+@dirrm include/faup