aboutsummaryrefslogtreecommitdiff
path: root/www/fcgiwrap
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2018-06-07 17:57:18 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2018-06-07 17:57:18 +0000
commitf12cf0f8771eb6c864c87b8518a59f7518e3375d (patch)
tree124c44b1f6a0bfc7d1906c25c84f2223751136c9 /www/fcgiwrap
parent56b67d3ed0fcfdd5d6a2093443a68bed42b4f649 (diff)
downloadports-f12cf0f8771eb6c864c87b8518a59f7518e3375d.tar.gz
ports-f12cf0f8771eb6c864c87b8518a59f7518e3375d.zip
- Unbreak socket mode logic
Reported by: clusteradm
Notes
Notes: svn path=/head/; revision=471940
Diffstat (limited to 'www/fcgiwrap')
-rw-r--r--www/fcgiwrap/Makefile2
-rw-r--r--www/fcgiwrap/files/fcgiwrap.in5
2 files changed, 4 insertions, 3 deletions
diff --git a/www/fcgiwrap/Makefile b/www/fcgiwrap/Makefile
index ef27b49f6d73..aa2d6f887365 100644
--- a/www/fcgiwrap/Makefile
+++ b/www/fcgiwrap/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fcgiwrap
PORTVERSION= 1.1.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= www
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/www/fcgiwrap/files/fcgiwrap.in b/www/fcgiwrap/files/fcgiwrap.in
index 4a53c09870c9..a0306721c703 100644
--- a/www/fcgiwrap/files/fcgiwrap.in
+++ b/www/fcgiwrap/files/fcgiwrap.in
@@ -68,7 +68,6 @@ fcgiwrap_setfib() {
fcgiwrap_precmd() {
fcgiwrap_setfib
install -d -o root -g wheel -m 1777 /var/run/fcgiwrap
- umask $(printf 0%o $(echo $((0777 - $(echo 0${fcgiwrap_socket_mode})))))
}
fcgiwrap_postcmd() {
@@ -80,13 +79,15 @@ fcgiwrap_postcmd() {
return
;;
esac
+ if [ -n "${fcgiwrap_socket_mode}" ]; then
+ chmod ${fcgiwrap_socket_mode} ${fcgiwrap_socket#unix:}
+ fi
if [ "${fcgiwrap_socket_owner}" != "${fcgiwrap_user}" ]; then
chown ${fcgiwrap_socket_owner} ${fcgiwrap_socket#unix:}
fi
if [ "${fcgiwrap_socket_group}" != "${fcgiwrap_group}" ]; then
chgrp ${fcgiwrap_socket_group} ${fcgiwrap_socket#unix:}
fi
- umask ${fcgiwrap_saved_umask}
}
fcgiwrap_stop() {