aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-10-28 23:47:31 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-10-28 23:47:31 +0000
commit81dcc5c369b72813fedab62fd8db1d519e59f9c9 (patch)
tree8882ad4994c8ba7ca143a8cc48ac00eabaada077 /www/firefox-esr
parenta9e0dfb648698b1cb123f72e337c6cedb484d12d (diff)
downloadports-81dcc5c369b72813fedab62fd8db1d519e59f9c9.tar.gz
ports-81dcc5c369b72813fedab62fd8db1d519e59f9c9.zip
gecko: speed up VP9 decoding on i386
Disable bundled FFmpeg decoders for VP* and FLAC on i386 as those don't support SIMD optimizations due to build issues upstream. More recent versions of those are already provided by multimedia/ffmpeg, anyway. MFH: 2017Q4
Notes
Notes: svn path=/head/; revision=453085
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug141255873
2 files changed, 74 insertions, 1 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 7f2ec96aa6df..19964e31e3af 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.4.1
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1412558 b/www/firefox-esr/files/patch-bug1412558
new file mode 100644
index 000000000000..ffa49490caf6
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1412558
@@ -0,0 +1,73 @@
+diff --git dom/media/flac/FlacDecoder.cpp dom/media/flac/FlacDecoder.cpp
+index 53fc3c9937f7..b23771ab80fa 100644
+--- dom/media/flac/FlacDecoder.cpp
++++ dom/media/flac/FlacDecoder.cpp
+@@ -36,7 +36,7 @@ FlacDecoder::CreateStateMachine()
+ /* static */ bool
+ FlacDecoder::IsEnabled()
+ {
+-#ifdef MOZ_FFVPX
++#if defined(MOZ_FFMPEG) || defined(MOZ_FFVPX)
+ return MediaPrefs::FlacEnabled();
+ #else
+ // Until bug 1295886 is fixed.
+diff --git media/ffvpx/README_MOZILLA media/ffvpx/README_MOZILLA
+index 5d3a6037efe0..43144b726a92 100644
+--- media/ffvpx/README_MOZILLA
++++ media/ffvpx/README_MOZILLA
+@@ -17,14 +17,6 @@ configuration files were generated as follow using the configure script:
+ config*:
+ replace: /HAVE_(MALLOC_H|ARC4RANDOM|LOCALTIME_R|MEMALIGN|POSIX_MEMALIGN)/d
+
+-config_darwin32.h:
+-add to configure command: --disable-asm --disable-yasm --cc='clang -m32'
+-
+-config_unix32.h:
+-add to configure command: --disable-asm --disable-yasm --cc='clang -m32'
+-replace: s/HAVE_SYSCTL 1/HAVE_SYSCTL 0/ and s/HAVE_MEMALIGN 1/HAVE_MEMALIGN 0/ and s/HAVE_POSIX_MEMALIGN 1/HAVE_POSIX_MEMALIGN 0/
+-
+-
+ config_unix64.h/config_unix64.asm:
+ replace: s/HAVE_SYSCTL 1/HAVE_SYSCTL 0
+
+diff --git media/ffvpx/config.h media/ffvpx/config.h
+index dab01e05cd65..26ebe529bd98 100644
+--- media/ffvpx/config.h
++++ media/ffvpx/config.h
+@@ -27,17 +27,9 @@
+ #define HAVE_LIBC_MSVCRT 0
+ #endif
+ #elif defined(XP_DARWIN)
+-#if defined(HAVE_64BIT_BUILD)
+ #include "config_darwin64.h"
+-#else
+-#include "config_darwin32.h"
+-#endif
+ #elif defined(XP_UNIX)
+-#if defined(HAVE_64BIT_BUILD)
+ #include "config_unix64.h"
+-#else
+-#include "config_unix32.h"
+-#endif
+ #endif
+ #include "config_common.h"
+ #endif // MOZ_FFVPX_CONFIG_H
+diff --git old-configure.in old-configure.in
+index b8ce71278548..410be683c2f6 100644
+--- old-configure.in
++++ old-configure.in
+@@ -3279,11 +3279,11 @@ dnl = FFmpeg's ffvpx configuration
+ dnl ========================================================
+
+ MOZ_FFVPX=
+-case "$CPU_ARCH" in
+- x86)
++case "$OS_ARCH:$CPU_ARCH" in
++ WINNT:x86)
+ MOZ_FFVPX=1
+ ;;
+- x86_64)
++ *:x86_64)
+ MOZ_FFVPX=1
+ ;;
+ esac