aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-10 12:34:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-10 12:34:02 +0000
commitfe1203c57f0fe82490a6274d3609b56ec62b3853 (patch)
tree9ecdc323457c34c252f33dbd505349ea05ac31a4 /www/firefox/Makefile
parenta791f77ab3cd942574e7e67ef37b90d52bd38898 (diff)
downloadports-fe1203c57f0fe82490a6274d3609b56ec62b3853.tar.gz
ports-fe1203c57f0fe82490a6274d3609b56ec62b3853.zip
www/firefox: fix build on powerpc64
In file included from Unified_cpp_common_audio_gn0.cpp:101: /wrkdirs/usr/ports/www/firefox/work/firefox-97.0/third_party/libwebrtc/common_audio/wav_file.cc:93:2: error: "Need to convert samples to big-endian when reading from WAV file" ^ /wrkdirs/usr/ports/www/firefox/work/firefox-97.0/third_party/libwebrtc/common_audio/wav_file.cc:133:2: error: "Need to convert samples to big-endian when reading from WAV file" ^ /wrkdirs/usr/ports/www/firefox/work/firefox-97.0/third_party/libwebrtc/common_audio/wav_file.cc:217:2: error: "Need to convert samples to little-endian when writing to WAV file" ^ /wrkdirs/usr/ports/www/firefox/work/firefox-97.0/third_party/libwebrtc/common_audio/wav_file.cc:247:2: error: "Need to convert samples to little-endian when writing to WAV file" ^ In file included from Unified_cpp_common_audio_gn0.cpp:110: /wrkdirs/usr/ports/www/firefox/work/firefox-97.0/third_party/libwebrtc/common_audio/wav_header.cc:30:2: error: "Code not working properly for big endian platforms." ^
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 9f70d4ac097c..3e658284dc52 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -48,7 +48,7 @@ MOZ_OPTIONS= --enable-application=browser \
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc64
-MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
+MOZ_OPTIONS+= --disable-webrtc --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx \
${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \