aboutsummaryrefslogtreecommitdiff
path: root/www/galeon
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /www/galeon
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Notes
Notes: svn path=/head/; revision=40539
Diffstat (limited to 'www/galeon')
-rw-r--r--www/galeon/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 674bd58ef19f..4a42e13b96bf 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -39,8 +39,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -D_REENTRANT -D_THREAD_SAFE -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} -pthread ${GCC_R_LIB}"
+ -D_REENTRANT ${PTHREAD_CFLAGS} -fno-rtti" \
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS} ${GCC_R_LIB}"
.if exists(/usr/lib/libgcc_r.a)
GCC_R_LIB= -lgcc_r
@@ -56,12 +56,12 @@ post-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|-lpthread|-pthread|g'
+ s|-lpthread|${PTHREAD_LIBS}|g'
post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \